Closed Bug 690635 Opened 8 years ago Closed 8 months ago

Issues with camera input on DroidX

Categories

(Firefox for Android Graveyard :: General, defect, P2)

Firefox 9
defect

Tracking

(firefox9 fixed, fennec-)

RESOLVED WONTFIX
Firefox 10
Tracking Status
firefox9 --- fixed
fennec - ---

People

(Reporter: wesj, Assigned: fabrice)

References

Details

Attachments

(2 files)

When I try to use camera input on my phone all I get is a black box.

I've been playing with a simple Android apps and find that I basically have to call setPreviewDisplay in order to receive any frames in the PreviewCallback. AFAICT, we never call it. The docs read like the camera should not work without calling setPreviewDisplay, so I'm either surprised that camera input works on any phones, or surprised that I have the one that actually follows the spec.
Requesting tracking-firefox9 because this is a bug in a new feature in Firefox 9 (camera support, bug 659188) that appears to make it unusable on some devices.  We'll want to fix this on Aurora if we can, or discuss turning off the feature for release.
Blocks: 659188
tracking-fennec: --- → ?
Version: Trunk → Firefox 9
What's the status here?
tracking-fennec: ? → +
I spent some time on Monday playing with this. Fabrice pointed me to some older patches of his which did attach a SurfaceView to the camera. I was receiving "Surface is NULL" (or something along those lines) messages in logcat.
Attached patch patchSplinter Review
Fix by setting up a hidden SurfaceView for the camera preview. We use a 8x16 size since some phones don't like a 1x1 preview surface (http://soledadpenades.com/2011/04/05/native-startpreview-failed-on-nexus-s-check-your-preview-size/)
Assignee: nobody → fabrice
Attachment #566094 - Flags: review?(wjohnston)
Duplicate of this bug: 692667
Attachment #566094 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/f04220527e2a
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 10
Depends on: 694795
Comment on attachment 566094 [details] [diff] [review]
patch

low risk patch that increases our device support for camera
Attachment #566094 - Flags: approval-mozilla-beta?
To clarify, we are asking for approval for Firefox 9 (currently on Aurora but migrating to beta on November 8).  This fixes a bug in the new camera feature in Firefox 9 that makes the camera unusable on some devices.  The patch is Android-only, and has been in the nightly channel for several weeks.  One regression was found in that time (bug 694795); we have a fix for it and are requesting approval for that fix too.
Comment on attachment 566094 [details] [diff] [review]
patch

[Triage Comment]
Approving for Beta 9 to ensure camera input is working on correctly on all mobile devices.
Attachment #566094 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I verified this on the latest Beta using www.people.mozilla.com/~fdesre/capture. On Motorola Droid Pro the bug is reproducible. When I press capture on the test page a black box is displayed where the capture should be. Also the framing of the picture box is not correct - see the attached screenshot.
Tested this on some other devices and the issue is not reproducible for them.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Bug is also reproducible on Motorola Droid 2 (Android 2.3):
Build ID:
Mozilla/5.0(Android; Linux arm7l; rv:9.0) Gecko/20111116 Firefox/9.0 Fennec/9.0
Tracking '-' on Native we use the OS provided camera.
tracking-fennec: + → -
Closing all opened bug in a graveyard component
Status: REOPENED → RESOLVED
Closed: 8 years ago8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.