Closed Bug 694795 Opened 8 years ago Closed 8 years ago

Black rectangle in top left corner after opening a link from another app

Categories

(Firefox for Android Graveyard :: General, defect)

Firefox 10
ARM
Android
defect
Not set

Tracking

(firefox9 unaffected)

VERIFIED FIXED
Firefox 10
Tracking Status
firefox9 --- unaffected

People

(Reporter: mbrubeck, Assigned: fabrice)

References

Details

(Keywords: regression, reproducible)

Attachments

(2 files)

Attached image screenshot
Steps to reproduce:
1. Open fennec on Android
2. Switch to another app and tap on a link
3. Choose to open the link in fennec

Expected results: Fennec reappears and the link opens in a new tab.

Results: Fennec reappears and the link opens in a new tab, *and* a small black rectangle appears in the top left corner of the screen.  The black rectangle remains fixed in the corner, obscuring whatever Fennec chrome or content is there.

I can't reproduce this by following similar steps in desktop Fennec.  It happens only when opening a link from another Android app while Fennec is already running.  Just opening a link in a new tab does not trigger the bug, nor does launching fennec by tapping a link from another app.

This bug occurs in Nightly 10.0a1 (I first noticed it in the 2011-10-14 build, but I don't know exactly which builds are affected).  It does not occur in Aurora 9.0a2.
This is due to the camera support added in bug 690635 for some devices.

Matt, you can assign it to me if you prefer.
Sure!  Thanks.
Assignee: mbrubeck → fabrice
Blocks: 690635
696001 shows a different way to get to the same problem.
I was always able to reproduce this issue while I've performed the str from bug 696013
Keywords: reproducible
Attached patch patchSplinter Review
Fixed by adding the camera view only when we need it. It looks like it was popping on top of the gecko surfaceview each time fennec was paused/resumed (eg just choosing "browse" to get the filepicker chooser was enough to trigger the bug)
Attachment #572123 - Flags: review?(mbrubeck)
Comment on attachment 572123 [details] [diff] [review]
patch

The code looks good.  Has it been tested to make sure it works on phones that were affected by bug 690635?
Attachment #572123 - Flags: review?(mbrubeck) → review+
Yes, I tested on two phones that had this problem, along with a couple others an a galaxy tab 10.1
Comment on attachment 572123 [details] [diff] [review]
patch

fixes a bug introduced by Bug 690635
Attachment #572123 - Flags: approval-mozilla-beta?
To clarify, we are asking for approval for Firefox 9 (currently on Aurora but migrating to beta on November 8).  See bug 690635 comment 9 for details.
https://hg.mozilla.org/mozilla-central/rev/1c9cae22054b
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 10
Comment on attachment 572123 [details] [diff] [review]
patch

[Triage Comment]
Approving for Beta 9 to ensure camera input is working on correctly on all mobile devices.
Attachment #572123 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified fixed on Mozilla/5.0 (Android; Linux armv7l; rv:9.0) Gecko/20111116 Firefox/9.0 Fennec/9.0
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.