search button in 2.4 version

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: bertranddepommery, Unassigned)

Tracking

SeaMonkey 2.4 Branch
x86
Windows XP

SeaMonkey Tracking Flags

(seamonkey2.3 unaffected, seamonkey2.4 affected)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20110928 Firefox/7.0.1 SeaMonkey/2.4.1
Build ID: 20110928161145

Steps to reproduce:

The search button don't run. (it is running in 2.3.3 version)
XP familial, french version


Actual results:

I must install the search button like firefox to active the seach button whith the personnalisation of the tools bar (in frech : personnalisation la barre d'outil)

Comment 1

7 years ago
DUP Bug 687186 - Search does nothing from right click context menu on Windows 7 ?

Comment 2

7 years ago
(In reply to bertranddepommery from comment #0)
>
> The search button don't run. 

Do you mean the search button in the Location Bar?
 
> I must install the search button like firefox ...

What exactly do you install? Please give an URL or the name of the AddIn you install.


(comment #1)
> DUP Bug 687186 ...?

That bug deals with the context menu. This bug reports problems with a "button".
(Reporter)

Comment 3

7 years ago
(In reply to Hb from comment #2)
> (In reply to bertranddepommery from comment #0)
> >
> > The search button don't run. 
> 
> Do you mean the search button in the Location Bar?
If the location bar is the bar usualy placed just below the bar of the menu, my answer is yes.
>  
> > I must install the search button like firefox ...
> 
> What exactly do you install? Please give an URL or the name of the AddIn you
> install.
Install is perhaps not the good word: i get the button like firefox from the boxe, opened whith the right click of the mouse, "modification of the tools bar" to the "location" bar. 
> 
> 
> (comment #1)
> > DUP Bug 687186 ...?
> 
> That bug deals with the context menu. This bug reports problems with a
> "button".
I think that this button give not the same result that this in 2.3.3 and before version. This button does'nt give directly the seach motor (as google). The only function as when we write any thing in the address bar, we can click in the little bar where the serch motor is mentionned.
When we write in the address bar click the serch button dont run as in 2.3.3 version.
This button become as in 2.3.3 when we get the search button like firefox in the "location bar", but to have this two search button in the "location bar" is luxuriuous... and vain.

in french
Je crois que le bouton "rechercher" n'a pas les fonctions de celui de la 2.3.3 et les versions antérieures. Ce bouton ne donne pas l’accès direct au moteur de recherche choisi. Quand on écrit sa requête dans la barre d'adresse, le bouton "rechercher" est inerte, on ne peut que cliquer dans la petite barre qui se développe en dessous de la barre d'adresse.
Ce bouton retrouve ses fonctions connues dans la 2.3.3 si on glisse dans la barre d'outil (location bar) le bouton ressemblant à celui de Firefox, pris dans la boîte ouverte avec "personnaliser" (clic droit dans la barre d'outil puis "personnaliser"). Mais avoir les deux boutons en même temps est un peu luxueux et inutile...

Y hope this frech explanation whith my answer's describe more clarely the default. This default is present on 4 XP machines whith seamonkey 2.4.1.
sincerly
Bertrand
(In reply to bertranddepommery from comment #3)

je vais essayer de traduire. Au passage, j'ajoute (sous N.B.) des commentaires en français dans l'espoir de résoudre les incompréhensions.

N.B. Bien que ma langue maternelle soit le français, j'ai toujours lu en anglais les manuels d'informatique (quand j'ai commencé en 1970, les manuels français étaient de mauvaises traductions de versions périmées des manuels anglais). Ma connaissance de la terminologie française actuelle est donc imparfaite.

> (In reply to Hb from comment #2)
> > (In reply to bertranddepommery from comment #0)
> > >
> > > The search button don't run. 
> > 
> > Do you mean the search button in the Location Bar?
> If the location bar is the bar usualy placed just below the bar of the menu,
> my answer is yes.

GLOSSAIRE
=========

search engine = moteur de recherche

location bar = URL bar = barre d'adresse (non compris les boutons figurant à gauche et à droite de celle-ci sur la même barre d'outils)

toolbar = barre d'outils

button palette = boîte à outils (réserve de boutons)

to customize = personnaliser

to drag (and drop) (with the mouse) = faire glisser (et lâcher) (avec la souris)

search bar = barre de recherche (voir plus loin)

to highlight = mettre en surbrillance

> >  
> > > I must install the search button like firefox ...
> > 
> > What exactly do you install? Please give an URL or the name of the AddIn you
> > install.
> Install is perhaps not the good word: i get the button like firefox from the
> boxe, opened whith the right click of the mouse, "modification of the tools
> bar" to the "location" bar.

customize (or something). Get the search button from the palette obtained by right-clicking the toolbar, then "Customize…", and place it on the toolbar.
 
> > 
> > 
> > (comment #1)
> > > DUP Bug 687186 ...?
> > 
> > That bug deals with the context menu. This bug reports problems with a
> > "button".
> I think that this button give not the same result that this in 2.3.3 and
> before version. This button does'nt give directly the seach motor (as
> google).
> The only function as when we write any thing in the address bar, we
> can click in the little bar where the serch motor is mentionned.
> When we write in the address bar click the serch button dont run as in 2.3.3
> version.
> This button become as in 2.3.3 when we get the search button like firefox in
> the "location bar", but to have this two search button in the "location bar"
> is luxuriuous... and vain.
> 
> in french
> Je crois que le bouton "rechercher" n'a pas les fonctions de celui de la
> 2.3.3 et les versions antérieures.

I believe that the Search button has a different functionality than in SeaMonkey 2.3.3 and earlier.

> Ce bouton ne donne pas l’accès direct au
> moteur de recherche choisi.

This button doesn't directly invoke the selected search engine.

> Quand on écrit sa requête dans la barre
> d'adresse, le bouton "rechercher" est inerte, on ne peut que cliquer dans la
> petite barre qui se développe en dessous de la barre d'adresse.

When typing a search key in the location bar, the Search button does nothing, all one can do is click [the bottom entry] in the drop-down widget which appears under the location bar.

N.B. Quel bouton "rechercher", si on ne l'a pas encore extrait de la boîte à outils?

> Ce bouton retrouve ses fonctions connues dans la 2.3.3 si on glisse dans la
> barre d'outil (location bar) le bouton ressemblant à celui de Firefox, pris
> dans la boîte ouverte avec "personnaliser" (clic droit dans la barre d'outil
> puis "personnaliser"). Mais avoir les deux boutons en même temps est un peu
> luxueux et inutile...

This button recovers the functions it had in 2.3.3 if one drags to the toolbar the button which looks like Firefox's, taken in the tools palette (opened by right-clicking the toolbar, then "Customize…". But having both buttons at the same time is a useless luxury.

NB. Le bouton "Rechercher" (ressemblant au bouton "Go" [Aller à?]) venant de la boîte à outils devrait suffire. Le petit bouton avec un triangle pointe en bas, qui fait partie intégrante de la barre d'adresse à main droite, n'est pas un bouton de recherche mais un bouton d'historique. L'autre bouton, immédiatement à gauche de ce dernier, sert à marquer les "bookmarks" (favoris? signets?).
Il y a aussi (dans la boîte à outils) une barre de recherche distincte de la barre d'adresse, que l'on peut faire glisser sur n'importe quelle barre d'outils (je la mets à la place des "bookmarks" que je range dans la boîte à outils, pour ouvrir celles-ci le menu me suffit). Cette barre de recherche permet (si on le désire) de sélectionner un moteur autre que celui par défaut. Lorsqu'elle est présente, c'est sur elle qu'agit le bouton "Rechercher". La recherche à partir de la barre d'adresse peut toujours être activée, soit en cliquant sur l'élément inférieur du menu déroulant qui apparaît sous la barre d'adresse, soit en appuyant sur "Entrée" après avoir mis cet élément en surbrillance (par exemple au moyen de la touche flèche-en-haut).

> 
> Y hope this frech explanation whith my answer's describe more clarely the
> default. This default is present on 4 XP machines whith seamonkey 2.4.1.
> sincerly
> Bertrand

N.B. Bertrand, peux-tu essayer de déterminer si ceci est un doublon de la bug 687186 ? Si le texte anglais est trop difficile pour toi, n'hésite pas à me demander des explications par courriel.

Bertrand, can you try to determine if this is a duplicate of bug 687186 ? If the English text is too hard for you, feel free to email me to ask explanations.
status-seamonkey2.3: --- → unaffected
status-seamonkey2.4: --- → affected
(Reporter)

Comment 5

7 years ago
(In reply to Tony Mechelynck [:tonymec] from comment #4)
> (In reply to bertranddepommery from comment #3)
> 
> je vais essayer de traduire. Au passage, j'ajoute (sous N.B.) des
> commentaires en français dans l'espoir de résoudre les incompréhensions.
> 
> N.B. Bien que ma langue maternelle soit le français, j'ai toujours lu en
> anglais les manuels d'informatique (quand j'ai commencé en 1970, les manuels
> français étaient de mauvaises traductions de versions périmées des manuels
> anglais). Ma connaissance de la terminologie française actuelle est donc
> imparfaite.
> 
> > (In reply to Hb from comment #2)
> > > (In reply to bertranddepommery from comment #0)
> > > >
> > > > The search button don't run. 
> > > 
> > > Do you mean the search button in the Location Bar?
> > If the location bar is the bar usualy placed just below the bar of the menu,
> > my answer is yes.
> 
> GLOSSAIRE
> =========
> 
> search engine = moteur de recherche
> 
> location bar = URL bar = barre d'adresse (non compris les boutons figurant à
> gauche et à droite de celle-ci sur la même barre d'outils)
> 
> toolbar = barre d'outils
> 
> button palette = boîte à outils (réserve de boutons)
> 
> to customize = personnaliser
> 
> to drag (and drop) (with the mouse) = faire glisser (et lâcher) (avec la
> souris)
> 
> search bar = barre de recherche (voir plus loin)
> 
> to highlight = mettre en surbrillance
> 
> > >  
> > > > I must install the search button like firefox ...
I drag and drop the search button of the button pallette (opened with customize)on the toolbar
> > > 
> > > What exactly do you install? Please give an URL or the name of the AddIn you
> > > install.
> > Install is perhaps not the good word: i get the button like firefox from the
> > boxe, opened whith the right click of the mouse, "modification of the tools
> > bar" to the "location" bar.
> 
> customize (or something). Get the search button from the palette obtained by
> right-clicking the toolbar, then "Customize…", and place it on the toolbar.
>  
> > > 
> > > 
> > > (comment #1)
> > > > DUP Bug 687186 ...?
> > > 
> > > That bug deals with the context menu. This bug reports problems with a
> > > "button".
> > I think that this button give not the same result that this in 2.3.3 and
> > before version. This button does'nt give directly the seach motor (as
> > google).
> > The only function as when we write any thing in the address bar, we
> > can click in the little bar where the serch motor is mentionned.
> > When we write in the address bar click the serch button dont run as in 2.3.3
> > version.
> > This button become as in 2.3.3 when we get the search button like firefox in
> > the "location bar", but to have this two search button in the "location bar"
> > is luxuriuous... and vain.
> > 
> > in french
> > Je crois que le bouton "rechercher" n'a pas les fonctions de celui de la
> > 2.3.3 et les versions antérieures.
> 
> I believe that the Search button has a different functionality than in
> SeaMonkey 2.3.3 and earlier.
> 
> > Ce bouton ne donne pas l’accès direct au
> > moteur de recherche choisi.
> 
> This button doesn't directly invoke the selected search engine.
> 
> > Quand on écrit sa requête dans la barre
> > d'adresse, le bouton "rechercher" est inerte, on ne peut que cliquer dans la
> > petite barre qui se développe en dessous de la barre d'adresse.
> 
> When typing a search key in the location bar, the Search button does
> nothing, all one can do is click [the bottom entry] in the drop-down widget
> which appears under the location bar.
> 
> N.B. Quel bouton "rechercher", si on ne l'a pas encore extrait de la boîte à
> outils?
Le bouton "rechercher" est present dans la barre d'outil dès la première ouverture du navigateur de Seamonkey
The seach button is present at the first running of Seamonkey
> 
> > Ce bouton retrouve ses fonctions connues dans la 2.3.3 si on glisse dans la
> > barre d'outil (location bar) le bouton ressemblant à celui de Firefox, pris
> > dans la boîte ouverte avec "personnaliser" (clic droit dans la barre d'outil
> > puis "personnaliser"). Mais avoir les deux boutons en même temps est un peu
> > luxueux et inutile...
> 
> This button recovers the functions it had in 2.3.3 if one drags to the
> toolbar the button which looks like Firefox's, taken in the tools palette
> (opened by right-clicking the toolbar, then "Customize…". But having both
> buttons at the same time is a useless luxury.
> 
> NB. Le bouton "Rechercher" (ressemblant au bouton "Go" [Aller à?]) venant de
> la boîte à outils devrait suffire. Le petit bouton avec un triangle pointe
> en bas, qui fait partie intégrante de la barre d'adresse à main droite,
> n'est pas un bouton de recherche mais un bouton d'historique
yes I know. that is as il 2.3.3
>L'autre bouton, immédiatement à gauche de ce dernier, sert à marquer les "bookmarks"
> (favoris? signets?).

the search button is just on the right of the history button

> Il y a aussi (dans la boîte à outils) une barre de recherche distincte de la
> barre d'adresse, que l'on peut faire glisser sur n'importe quelle barre
> d'outils (je la mets à la place des "bookmarks" que je range dans la boîte à
> outils, pour ouvrir celles-ci le menu me suffit). Cette barre de recherche
> permet (si on le désire) de sélectionner un moteur autre que celui par
> défaut. Lorsqu'elle est présente, c'est sur elle qu'agit le bouton
> "Rechercher".

mais quand elle on l'enlève, ou qu'ell est absente, le bouton "rechercher", celui qu'on ne prend pas dans la boîte à bouton, devient inerte.
excuse for my french, i read better than I write. 

>La recherche à partir de la barre d'adresse peut toujours être
> activée, soit en cliquant sur l'élément inférieur du menu déroulant qui
> apparaît sous la barre d'adresse, soit en appuyant sur "Entrée" après avoir
> mis cet élément en surbrillance (par exemple au moyen de la touche
> flèche-en-haut).
Oui, mais dans la 2.3.3, quand on met quelque chose à rechercher dans la barre d'adresse, le bouton recherche, quand on clique dessus, exécute la recherche avec le moteur de recherche choisi dans "édition/préférences" sans avoir besoin du second bouton de recherche dont je ne connaissais même pas l’existence dans la 2.3.3
> 
> > 
> > Y hope this frech explanation whith my answer's describe more clarely the
> > default. This default is present on 4 XP machines whith seamonkey 2.4.1.
> > sincerly
Ce défaut n'est pas que sur une machine mais sur toutes les machines que je connais ayant Seamonkey.
> > Bertrand
> 
> N.B. Bertrand, peux-tu essayer de déterminer si ceci est un doublon de la
> bug 687186 ? Si le texte anglais est trop difficile pour toi, n'hésite pas à
> me demander des explications par courriel.
> 
> Bertrand, can you try to determine if this is a duplicate of bug 687186 ? If
> the English text is too hard for you, feel free to email me to ask
> explanations.
That is not a duplicate, the problem whith Windows 7 is with the context menu and non with directly the reach button. That seems so to me. But the explanations are not so clear and I don't experiment with Seven : my OS is XP.

Thanks a lot Tony for yous french translation. Excuse me, but I don't learn english at school. I learned english just to read technical review since fifty years. My school first language is german.
Hm. IIUC, what the reporter means is that the search *button* does nothing in SeaMonkey 2.4 and later unless the search *bar* (the search input box) has been dragged to some toolbar by customization.

Si j'ai bien compris, le problème est que le *bouton* de recherche est inactif sur SeaMonkey 2.4 et suivants si la *barre* de recherche (la zone d'entrée pour recherche) n'a pas été placée (par personnalisation) sur une barre d'outils.

Bertrand, is that it? Est-ce que c'est bien ça?

Comment 7

7 years ago
(In reply to Tony Mechelynck [:tonymec] from comment #6)
> Hm. IIUC, what the reporter means is that the search *button* does nothing
> in SeaMonkey 2.4 and later unless the search *bar* (the search input box)
> has been dragged to some toolbar by customization.

Clicking the Search button sends the content of the Location Bar field to the preferred search engine if it isn't an URL. If an URL is in the Location Bar and the Search button is clicked Seamonkey moves to www.google.(com|fr|de).

The Search button does NOT send the content of the Search field. This is misleading.

Seamonkey 2.4 and later have as default this Navigation Toolbar: Back, Forward, Reload, Stop, Location Bar, Search Button, Print, Throbber/Seamonkey Home. Together with Preferences - Browser - Location Bar - Unknown Locations: Perform a web search when entered text is not a web location = True 

This gives a mysterious user experience. The Search button should be replaced with the Go button in the Navigation Toolbar. After clicking the Go button Seamonkey looks for the preference "Perform a web search when entered text is not a web location". If this is true (as default) and the content of the Location Bar is an URL this URL is directly called. If it isn't an URL it is send to the preferred search engine. The Go Button acts in the same way as the Enter key does.

Conclusion: The Search button should be replaced with the Go button in the Navigation Toolbar in the shipped version.
(Reporter)

Comment 8

7 years ago
(In reply to Hb from comment #7)
> (In reply to Tony Mechelynck [:tonymec] from comment #6)
> > Hm. IIUC, what the reporter means is that the search *button* does nothing
> > in SeaMonkey 2.4 and later unless the search *bar* (the search input box)
> > has been dragged to some toolbar by customization.
> 
> Clicking the Search button sends the content of the Location Bar field to
> the preferred search engine if it isn't an URL. If an URL is in the Location
> Bar and the Search button is clicked Seamonkey moves to
> www.google.(com|fr|de).
> 
> The Search button does NOT send the content of the Search field. This is
> misleading.
> 
> Seamonkey 2.4 and later have as default this Navigation Toolbar: Back,
> Forward, Reload, Stop, Location Bar, Search Button, Print,
> Throbber/Seamonkey Home. Together with Preferences - Browser - Location Bar
> - Unknown Locations: Perform a web search when entered text is not a web
> location = True 
> 
> This gives a mysterious user experience. The Search button should be
> replaced with the Go button in the Navigation Toolbar. After clicking the Go
> button Seamonkey looks for the preference "Perform a web search when entered
> text is not a web location". If this is true (as default) and the content of
> the Location Bar is an URL this URL is directly called. If it isn't an URL
> it is send to the preferred search engine. The Go Button acts in the same
> way as the Enter key does.
> 
> Conclusion: The Search button should be replaced with the Go button in the
> Navigation Toolbar in the shipped version.

Hello HB
The GO button has the funtion to go in an ip address, the SEARCH-défault Buttom was to go directly in the search engine choosed as in 2.3.3. "Go" isn't "Search" !  Please you must given again in the search-default button the function that it had before the 2.4 version. I don't agree your considerations.
sincerly
Bertrand
Bertrand: Si je comprends bien ce que dit Hb (et mes expériences le confirment) le bouton "Rechercher" ouvre la page d'accueil du moteur de recherche choisi (Google par défaut) lorsque la barre d'adresse contient une adresse (et j'ajouterai: ou si elle est vide). On peut alors remplir le formulaire avec les paramètres de la recherche. Lorsque la barre d'adresse contient quelque chose qui n'est pas une URL, le même bouton lance immédiatement une recherche.

Je constate de plus (et ça me paraît assez bizarre) que le bouton "Recherche" lance une recherche à partir de la barre d'adresse mais en utilisant le moteur sélectionné dans la barre de recherche, tandis que l'élément inférieur du menu déroulant de la barre d'adresse lance une recherche utilisant le moteur sélectionné dans les Préférences. Ces deux moteurs peuvent être différents (et il est possible d'en sélectionner provisoirement un troisième dans la barre latérale qui s'ouvre et se ferme par F9).

Je constate aussi que si le menu déroulant s'est ouvert sous la barre d'adresse pendant que j'y tapais quelque chose, il faut cliquer plusieurs fois le bouton "Recherche" avant que la recherche ne démarre: ce bouton ferme le menu déroulant (et ne fait rien d'autre) s'il est ouvert (il peut arriver que le menu se rouvre immédiatement), il lance une recherche si le menu déroulant est fermé.

Le bouton "Go" ("Aller à"?) va à l'adresse indiquée si la barre d'adresse en contient une, ne fait rien si elle est vide, et lance une recherche si elle contient autre chose et que la préférence mentionnée a été sélectionnée. Ici aussi, si le menu déroulant est ouvert ce bouton se contente de le fermer.

Pour lancer une recherche à partir de la barre de recherche, on peut soit appuyer sur Entrée soit cliquer sur l'espèce de loupe à l'extrémité de cette barre.

Si tu vois autre chose que ce que je viens de décrire, c'est que ta version (2.4 pour Windows) et la mienne (2.7a1 pour Linux) se comportent différemment.
(Reporter)

Comment 10

7 years ago
hello tony
Sous Windows, il semble que le bouton recherche traditionnel ne fonctionne pas du tout comme prévu. Le bouton GO appelle bien le moteur de recherche avec ce qu'il y a dans la barre d'adresse.
Le bouton de recherche traditionnel était bien pratique dans la version 2.3.3 puisqu'il cherchait ce qu'il y avait dans la barre d’adresse, si ce n'était pas une adresse ip, à travers le moteur de recherche et appelait le moteur de recherche dans le cas contraire.
C'est ce que j'ai voulu signifier à HP : le bouton traditionnel "rechercher" devrait ouvrir la page d'accueil du moteur de recherche, ce qui n'est pas le cas dans la version 2.4.x et ce que ne fait pas GO.
Bref ce bouton recherche fait un peu désordre (voir dans les news.mozilla.org/mozillaz.suppor.seamonkey un message du 08/10/2011 de flyguy)
Merci Tony
(Reporter)

Comment 11

7 years ago
Rebonjour,
Je complète : l'anomalie concernant le bouton de recherche non traditionnel (celui avec changement de choix de moteur) que tu utilises (au paragraphe 2), je l'ai constaté lors de mes différents essais et que le choix de la barre latérale prend le pas sur celui du bouton non traditionnel, et pas l'inverse, ce qui ferait 3 moteurs effectivement mais plutôt 2 car celui de la barre latérale si on fait une recherche, prend le moteur du bouton non traditionnel, donc il n'est pas opérationnel. Les deux utilisables sont celui qu'on trouve en dessous de la barre d'adresse, c'est celui de Préférence, l'autre se trouve dans le bouton non traditionnel.
Avez-vous le bouton traditionnel (une loupe suivie du mot "Rechercher") qui est dans la version Windows ?
Bertrand
(Reporter)

Comment 12

7 years ago
Hello Tony
One solution is : (bug 693080) browser.search.opentabforcontextsearch must have as value "true",
It was "false".
J'ai inversé la valeur qui est devenue true. Ca fonctionne beaucoup mieux
Sincerly and thank to Jens Hatlak
Bertrand

Comment 13

7 years ago
Bonjour, Bertrand...

I just ran into this, following up on a trouble ticket for a client. In this case, Mozilla/5.0 (X11; Linux i686; rv:7.0) Gecko/20110922 Firefox/7.0 SeaMonkey/2.4.

The behavior I saw (regardless the setting of browser.search.opentabforcontextsearch) was that the *second* click of the search button went to the default engine and passed the search parameters (two clicks, not a double-click or the single click, as expected).

Suggest changing the name of this bug to "Multiple clicks required for search button in SeaMonkey 2.4" - I do not have permissions to do that.

Cheers, all.

Lewis
(Reporter)

Comment 14

7 years ago
(In reply to Lewis Rosenthal from comment #13)
> Bonjour, Bertrand...
> 
> I just ran into this, following up on a trouble ticket for a client. In this
> case, Mozilla/5.0 (X11; Linux i686; rv:7.0) Gecko/20110922 Firefox/7.0
> SeaMonkey/2.4.
> 
> The behavior I saw (regardless the setting of
> browser.search.opentabforcontextsearch) was that the *second* click of the
> search button went to the default engine and passed the search parameters
> (two clicks, not a double-click or the single click, as expected).
> 
> Suggest changing the name of this bug to "Multiple clicks required for
> search button in SeaMonkey 2.4" - I do not have permissions to do that.
> 
> Cheers, all.
> 
> Lewis

If I simple-click or double-click on this button with the value of browser.search.opentabforcontextsearch at false, there runned nothing.

Now, i don't understand : I inverte to become as before (value false) and the search button is always ok. After stop the machine and run my machine the button is ok. That is a singular bug and not a probleme with mulitple click. What append ? I experimente that on the same machine.
And now, on the same machine, with true value, the search button is unactive without the other seach button of the button pannel.
What append ?
I will experiment on an other XP machine.

Bertrand
(In reply to Lewis Rosenthal from comment #13)
> Bonjour, Bertrand...
> 
> I just ran into this, following up on a trouble ticket for a client. In this
> case, Mozilla/5.0 (X11; Linux i686; rv:7.0) Gecko/20110922 Firefox/7.0
> SeaMonkey/2.4.
> 
> The behavior I saw (regardless the setting of
> browser.search.opentabforcontextsearch) was that the *second* click of the
> search button went to the default engine and passed the search parameters
> (two clicks, not a double-click or the single click, as expected).
> 
> Suggest changing the name of this bug to "Multiple clicks required for
> search button in SeaMonkey 2.4" - I do not have permissions to do that.
> 
> Cheers, all.
> 
> Lewis

Hi Lewis. As I said in French in comment #9, in SeaMonkey 2.7a1 I notice that if my typing in the URL bar opens the "awesome bar" autocomplete menu, clicking the Search button will close the menu (which sometimes reopens immediately) and do nothing else. It is only when the menu is not displayed that the Search button starts a search (or, if the URL bar is empty or contains a URL, opens the search engine input form)

Comment 16

7 years ago
Ah, I do indeed see your note, Tony; my apologies. I read through most of the comments in this bug before posting, but admittedly, as French is a second language for me, I did not take the time required to read those comments more carefully (beyond Bertrand's earlier comments).

Surely is an odd mess.

Apologies, all, for the bug spam.

Cheers
(Reporter)

Comment 17

7 years ago
Hello
for this serious bug, who is on this problem ?
It is the same thing whih the next 2.5 version ?
Sincerly yous
Bertrand

Comment 18

7 years ago
Similar report in http://forums.mozillazine.org/viewtopic.php?f=40&t=2414699 after migration from 2.0.11 to 2.6.1, "Search" button is non-functional.

Comment 19

7 years ago
I wonder if some of the changes I made in Bug 705452 (BrowserSearch.loadSearch() uses the current search engine if the search sidebar is selected even if the sidebar itself is hidden) fixes this problem. Anyone want to see if SeaMonkey 2.8b resolves this bug?

Comment 20

6 years ago
Reporter, is problem still exists in SeaMonkey 2.8 release?
Whiteboard: closeme WFM 2012-05-01
(Reporter)

Comment 21

6 years ago
Hello,
in 2.8 the problem exists always...
The only actualy way is to create a new profile and migrate the data from the old profile to the new.

Comment 22

6 years ago
You did check this assumption? If clean profile removes problem, then migration is the best way
(Reporter)

Comment 23

6 years ago
I don't check the migration beacause that is a long and detailed work and I have 3 profiles ill on 2 machines, but i check that : if i create a new profile, it is whithout this problem. The old profiles preserves this handicap. The migration must probably be item by item without copying files from old profile to new profile (exept probably the mail files and perhaps the filterrules).

Comment 24

6 years ago
(In reply to bertranddepommery from comment #23)
> if i create a new profile, it is whithout this problem. The old profiles
> preserves this handicap.
So, the problem may be either in settings, or in add-ons. Try to disable them in profile with problems, and see, if problem still there. To do this, go to Tools - Add-ons Manager - Extension and disable everything there. Is problem disappears, enable them one by one to find, which is causing current behavior.

Comment 25

6 years ago
I am using my same old profile, as originally migrated from 1.1.x, now on:

Mozilla/5.0 (OS/2; Warp 4.5; rv:10.0.2) Gecko/20120216 Firefox/10.0.2 SeaMonkey/2.7 ID:20120216144140

I have a good number of extensions installed, too. I am *not* seeing this issue any longer, so I suspect, Bertrand, that your issue may well be add-on-related, and you should follow Phoenix's advice in comment 24 to track down the errant extension and perhaps let the developer know.

So, to repeat my opening statement. For me, this issue no longer occurs.
(Reporter)

Comment 26

6 years ago
Hello
whith the "without echec" (mode sans echec in frensh) that run. I desactived all the addons without result.
I try other possibilities. Where extentions is in default ?
(Reporter)

Comment 27

6 years ago
Hello
with the "redemarrage" without modules and choise first, second and last the search button is runnig again.
all addons are desactived.
sincerly
Bertrand
(Reporter)

Comment 28

6 years ago
Hello
desactive the addons is'nt necessary
Thanks for your Idees
Bertrand

Comment 29

6 years ago
So, issue solved?
(Reporter)

Comment 30

6 years ago
hello
I think so
Bertrand

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: closeme WFM 2012-05-01
You need to log in before you can comment on or make changes to this bug.