Last Comment Bug 691288 - Clicking on mailto link is broken, it opens an empty compose window
: Clicking on mailto link is broken, it opens an empty compose window
Status: VERIFIED FIXED
: regression, testcase, verified-aurora
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: 7
: All All
-- major with 1 vote (vote)
: Thunderbird 10.0
Assigned To: David :Bienvenu
:
:
Mentors:
: 692072 694194 (view as bug list)
Depends on: 677643
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-03 04:29 PDT by Ludovic Hirlimann [:Usul]
Modified: 2012-01-24 09:55 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
unaffected
+
fixed
+
fixed
unaffected
fixed
fixed


Attachments
proposed fix (665 bytes, patch)
2011-10-03 07:59 PDT, David :Bienvenu
no flags Details | Diff | Splinter Review
fix with unit test (2.73 KB, patch)
2011-10-03 09:02 PDT, David :Bienvenu
neil: review+
standard8: approval‑comm‑aurora+
dkl: approval‑comm‑beta+
Details | Diff | Splinter Review

Description User image Ludovic Hirlimann [:Usul] 2011-10-03 04:29:05 PDT
Created attachment 564156 [details]
Email showing up the issue

Str:

(I have this in safe-mode with one of the yammer emails, where you can click the reply link to reply)

1) click link that look like : mailto:yammer+re+118111379+zzz@yammer.com?subject=somesubject

Results : an empty compose window opens instead of one with a too and subject field pre filled.

Console is empty. Safe-mode doesn't help.

This used to work in 8.Xbeta and is broken for me in 9.xbeta
Comment 2 User image David :Bienvenu 2011-10-03 07:35:52 PDT
This may be an issue with cloning of smtp urls not cloning all the parts we've parsed, though I thought the url cloning changes happened a couple releases ago.
Comment 3 User image Mark Banner (:standard8) 2011-10-03 07:41:15 PDT
A partial regression window, but would be useful to narrow slightly.


Broken: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a2) Gecko/20110930 Thunderbird/9.0a2

Working: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a1) Gecko/20110922 Thunderbird/9.0a1
Comment 4 User image David :Bienvenu 2011-10-03 07:59:57 PDT
Created attachment 564184 [details] [diff] [review]
proposed fix

this fixes it - not sure what caused the regression, however.
Comment 5 User image David :Bienvenu 2011-10-03 09:02:05 PDT
Created attachment 564208 [details] [diff] [review]
fix with unit test
Comment 6 User image David :Bienvenu 2011-10-06 07:31:08 PDT
*** Bug 692072 has been marked as a duplicate of this bug. ***
Comment 7 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2011-10-06 10:51:44 PDT
Bug 692072 was on SeaMonkey for Linux-x86_64. Platform ➔ All/All.
Comment 8 User image Justin Wood (:Callek) [away until Feb 27] 2011-10-06 15:56:48 PDT
FYI, (even though this has a patch), because I was curious I did a bisect to track down the regression here.

Even though I don't quite understand why on this one. Bug 677643 was the regressor here.

Specifically: http://hg.mozilla.org/mozilla-central/rev/cadb12b21740

For reference, the c-c cset I used when testing was: http://hg.mozilla.org/comm-central/rev/feb47379243c
Comment 9 User image Justin Wood (:Callek) [away until Feb 27] 2011-10-06 15:57:59 PDT
(bug affects SeaMonkey as well, moving to MailNews Core)
Comment 10 User image neil@parkwaycc.co.uk 2011-10-06 16:26:01 PDT
Comment on attachment 564208 [details] [diff] [review]
fix with unit test

Do you want to patch nsAddbookUrl as well? (Slightly different for some reason, so you'd have to patch it in two places.)
Comment 11 User image David :Bienvenu 2011-10-06 16:55:35 PDT
(In reply to neil@parkwaycc.co.uk from comment #10)
> Comment on attachment 564208 [details] [diff] [review] [diff] [details] [review]
> fix with unit test
> 
> Do you want to patch nsAddbookUrl as well? (Slightly different for some
> reason, so you'd have to patch it in two places.)

I can - I'll look at it.
Comment 12 User image Boris Zbarsky [:bz] (still a bit busy) 2011-10-06 17:34:41 PDT
> Even though I don't quite understand why on this one

Because that patch added a clone call and apparently mailnews URIs had a broken clone implementation?
Comment 13 User image David :Bienvenu 2011-10-07 08:35:34 PDT
fixed on trunk http://hg.mozilla.org/comm-central/rev/866b5e6fdea1

I'll deal with nsAddbokUrl in a different bug.

And yes, bz is obviously right. Clone was broken for mailto urls but it didn't matter before. Now we have a unit test for it.
Comment 14 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2011-10-08 13:17:55 PDT
I VERIFY that the duplicate bug 692072 (see comment #6) has now disappeared:

BAD:  Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111007 Firefox/10.0a1 SeaMonkey/2.7a1 ID:20111007003005
GOOD: Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111008 Firefox/10.0a1 SeaMonkey/2.7a1 ID:20111008003005

Clicking the link in the minimum testcase https://bug692072.bugzilla.mozilla.org/attachment.cgi?id=564885 now opens an email-compose window with "To:" and "Subject:" fields filled-in, while they were empty before.

I didn't test anything with Shredder: if the bug still appears in a build of Thunderbird 10.0a1 or SeaMonkey 2.7a1 for any platform, but started before comment #13, please mention here or in a followup bug exactly what you did, what you saw, and include your user-agent string and if possible your "Build ID" timestamp, as obtained by means of the Nightly Tester Tools extension or from the *.txt file which accompanies the build archive on the FTP server.
Comment 15 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2011-10-08 13:27:14 PDT
oops: ... "started _after_ comment #13", of course. :-/
Comment 16 User image David :Bienvenu 2011-10-11 09:44:30 PDT
Comment on attachment 564208 [details] [diff] [review]
fix with unit test

the regressing moz-central change also landed on mozilla-beta, which is why we need the fix to land on comm-beta as well.
Comment 18 User image Ian Neal 2011-10-12 17:14:15 PDT
*** Bug 694194 has been marked as a duplicate of this bug. ***
Comment 19 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2011-10-14 03:26:53 PDT
(In reply to Mark Banner (:standard8) from comment #17)
> Checked into branches:
> 
> http://hg.mozilla.org/releases/comm-aurora/rev/132257a4c0a0
> http://hg.mozilla.org/releases/comm-beta/rev/db026f4ce3e8

Mozilla/5.0 (X11; Linux x86_64; rv:9.0a2) Gecko/20111013 Firefox/9.0a2 SeaMonkey/2.6a2

The bug has also disappeared from this build of SeaMonkey-aurora.
Comment 20 User image David Lawrence [:dkl] 2012-01-24 09:55:02 PST
Comment on attachment 564208 [details] [diff] [review]
fix with unit test

Adding back approval flag that was mistakenly removed. dkl

Note You need to log in before you can comment on or make changes to this bug.