Crash when headphones removed while listening to audio

RESOLVED FIXED in mozilla13

Status

()

Core
Widget: Win32
--
critical
RESOLVED FIXED
6 years ago
19 days ago

People

(Reporter: Nilay Chheda, Assigned: bbondy)

Tracking

(Depends on: 1 bug, {crash, regression})

7 Branch
mozilla13
x86
Windows 7
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

I was watching a video on youtube. I had plugged in a head phone with my 32 bit laptop running windows 7 OS. My friend came, and he removed the headphone jack from laptop to listen the audio of the video I was watching on youtube.


Actual results:

This has happened now twice. First time automatically firefox crashed and report was submitted. I thought there might be some other problem. Today it happened again, and firefox 7 didn't crashed but hanged. On realizing, I plugged in jack again and then firefox responded back.


Expected results:

Firefox should not have hanged or crashed.
This could be a bug in flash because the flash plugin plays audio and not Firefox.
Can you please post the crash id from about:crashes ?
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 2

6 years ago
(In reply to Matthias Versen (Matti) from comment #1)
> This could be a bug in flash because the flash plugin plays audio and not
> Firefox.
> Can you please post the crash id from about:crashes ?
> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

It may be bug with flash or may be with my laptop as well because in my friend's laptop, firefox 7 is working well.
But here is the crash report that I submitted just now ! 
https://crash-stats.mozilla.com/report/index/bp-3e3bae7a-75c5-4423-9efe-535782111004

I hope this may help.
This problem is happening with any other flash audio playing site. 
By killing plugincontainer.exe process manually, I can resume back the audio. 
This was not happening before firefox 7. So I think there is something wrong on firefox's side :) 
Happy firefoxing !
(Reporter)

Updated

6 years ago
Summary: Firefox 7 hangs and/or crashes when headphone is removed while watching youtube video ! → Firefox 7 hangs and/or crashes when headphone is removed while listening to audio on any website !
(Reporter)

Updated

6 years ago
>By killing plugincontainer.exe process manually, I can resume back the audio.
Firefox hangs if the plugin inside the plugincontainer hangs. The plugincontainer itself kills the hanging plugin only after a long time.

>This was not happening before firefox 7.
The plugincontainer doesn't do anything with audio, only the plugins that are running inside are accessing the windows audio devices.
I bet that this is caused by an update of the flash plugin.
Component: General → Flash (Adobe)
Product: Firefox → Plugins
QA Contact: general → adobe-flash
Version: 7 Branch → unspecified

Updated

6 years ago
Severity: normal → critical
Crash Signature: [@ hang | mozilla::plugins::PPluginInstanceParent::CallUpdateWindow() ]
Component: Flash (Adobe) → Plug-ins
Keywords: crash
Product: Plugins → Core
QA Contact: adobe-flash → plugins
Version: unspecified → 7 Branch

Comment 4

6 years ago
I can confirm that. It's definitely not flash's fault. I just upgraded to firefox 9 and the promotional video opened (http://www.mozilla.org/en-US/firefox/9.0.1/whatsnew/). I unplugged my headphones and firefox crashed.

Note: It was in windows 7. I don't have any other output device so windows set Digital Audio (S/PDIF) as default playback device after I unplugged the headphones.

Comment 5

6 years ago
Hanged, not crashed to be exact.
>It's definitely not flash's fault.
Why are you sure this not the fault of the flash plugin ?

Comment 7

6 years ago
(In reply to Matthias Versen (Matti) from comment #6)
> Why are you sure this not the fault of the flash plugin ?
Because the video on the site I mentioned is _not_ using flash. It's embedded by html5 <video> tag.
Component: Plug-ins → Video/Audio
QA Contact: plugins → video.audio
I can reproduce this on Windows 7.  Visit http://www.mozilla.org/en-US/firefox/9.0.1/whatsnew/, click play, open the sound control panel, select the playback tab, right click the playing device, and select disable.

I get the following fatal assert in AudioSession::Start:

###!!! ABORT: State invariants violated: 'mState == UNINITIALIZED || mState == CLONED', file c:/work/mozilla-central/widget/windows/AudioSession.cpp, line 210

...where mState is currently STARTED and Start() has been called by AudioSession::OnSessionDisconnectedInternal().
Status: UNCONFIRMED → NEW
Component: Video/Audio → Widget: Win32
Ever confirmed: true
QA Contact: video.audio → win32
(Assignee)

Comment 9

6 years ago
Nice, I reproduced using the steps in Comment 8.
(Assignee)

Updated

6 years ago
Summary: Firefox 7 hangs and/or crashes when headphone is removed while listening to audio on any website ! → Crash when headphones removed while listening to audio
(Assignee)

Comment 10

6 years ago
Created attachment 598099 [details] [diff] [review]
Patch v1.

Code has been this way since it was introduced last year in July in bug 441197
Assignee: nobody → netzen
Status: NEW → ASSIGNED
Attachment #598099 - Flags: review?(jmathies)
(Assignee)

Comment 11

6 years ago
The crash signature is not the same as the one indicated in the bug, but this fixes the crash mentioned in Comment 8.  Please let me know if I should post a new bug for this instead.

Updated

6 years ago
Blocks: 441197

Updated

6 years ago
Attachment #598099 - Flags: review?(jmathies) → review+
(Assignee)

Updated

6 years ago
Target Milestone: --- → mozilla13

Comment 12

6 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #11)
> The crash signature is not the same as the one indicated in the bug, but
> this fixes the crash mentioned in Comment 8.  Please let me know if I should
> post a new bug for this instead.
Can you provide your crash ID in order to be added in the crash signature field and tracked in Socorro?
Keywords: regression
(Assignee)

Comment 13

6 years ago
http://crash-stats.mozilla.com/report/index/bp-e52f02bd-6ec8-4259-af46-332f92120217
Also updated the signature field above.
Crash Signature: [@ hang | mozilla::plugins::PPluginInstanceParent::CallUpdateWindow() ] → [@ hang | mozilla::widget::AudioSession::Start() ]
(Assignee)

Comment 14

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/174ce0df7cdd
https://hg.mozilla.org/mozilla-central/rev/174ce0df7cdd
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Crash Signature: [@ hang | mozilla::widget::AudioSession::Start() ] → [@ _chkstk] [@ _chkstk | CLocalEndpointEnumerator::OnMediaNotification(MEDIA_NOTIFICATION_BLOCK*)]
Depends on: 731812
(Assignee)

Comment 16

6 years ago
Fixed the crash signature that this fix was related to back to Comment 13.
Crash Signature: [@ _chkstk] [@ _chkstk | CLocalEndpointEnumerator::OnMediaNotification(MEDIA_NOTIFICATION_BLOCK*)] → [@ hang | mozilla::plugins::PPluginInstanceParent::CallUpdateWindow() ] → [@ hang | mozilla::widget::AudioSession::Start() ]
See Also: → bug 731812
You need to log in before you can comment on or make changes to this bug.