Closed Bug 691625 Opened 11 years ago Closed 10 years ago

Newly added app is not listed in the collection

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX
Q1 2012

People

(Reporter: krupa.mozbugs, Assigned: cvan)

References

()

Details

(Whiteboard: [webapps])

steps to reproduce:
1. Log in to AMO
2. Load https://addons-dev.allizom.org/en-US/apps/app/test-webapp-3/
3. Click on 'Add to collection'-> 'Start a new collection'
4. Create a new collection and navigate to its details page


expected behavior:
The newly added app is listed in the collections details page.

actual behavior:
Collection says that there is '1 Add-on in this collection' but the app is not listed. See https://addons-dev.allizom.org/en-US/firefox/collections/nydile/ap/
This happens because the app is not fit for public consumption; you can only view it from a direct link. This will only happen when we're in the beta stage of marketplace before apps are all public all the time. The easiest fix is probably to hide the add-to-collection UI if the app/add-on is not listable.
Target Milestone: 6.2.7 → 4.x (triaged)
Blocks: 690899
Hiding it wfm
Priority: -- → P2
Assignee: nobody → cwiemeersch
Target Milestone: 4.x (triaged) → 6.3.3
I was able to do add an app to a new or existing collection without issues. But I have hid collection links for apps per bug 692909. Will revisit this bug when collections are reinstated for apps.
Target Milestone: 6.3.3 → Q1 2012
Priority: P2 → P3
Blocks: 710074
No longer blocks: 690899
Blocks: 718560
No longer blocks: 710074
collections aren't in marketplace beta.  when they are, they'll come with a design.  -> wontfix
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.