Livemark updates shouldn't trigger score bump

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: Backend
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: philikon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
We should ignore changes to Livemark children, but somehow something still gets tracked:

317768748994	Sync.Tracker.Bookmarks	TRACE	onBeforeItemRemoved: 709
1317768748995	Sync.Tracker.Bookmarks	TRACE	Adding changed ID: 1hm1Lc6avIvu,1317768748
1317768748995	Sync.Tracker.Bookmarks	TRACE	Adding changed ID: toolbar,1317768748

Don't let the 'onBeforeItemRemoved' message fool you, this is in BookmarksTracker.prototype.onItemRemoved. Nevertheless, it tries to ignore livemarks, so I'm further investigating as to why that isn't happening.
So, I can't reproduce this anymore. I believe I may have mistaken the log output in comment 1 for a livemark, but a closer look releals that it's actually a child of the toolbar. I did delete something from the toolbar prior to trying to reproduce this bug.

So at this stage, I'm inclined to WONTFIX this bug. I can't reproduce it, neither manually nor in a test.
Blocks: 692006
RESO/WFM as I couldn't reproduce this. Please reopen with logs if they contain evidence that this is indeed a bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.