Last Comment Bug 691818 - AndroidManifest.xml implies that camera and autofocus are required
: AndroidManifest.xml implies that camera and autofocus are required
Status: RESOLVED FIXED
[pushed]
: regression
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: mozilla10
Assigned To: Matt Brubeck (:mbrubeck)
:
:
Mentors:
Depends on:
Blocks: 659188
  Show dependency treegraph
 
Reported: 2011-10-04 10:12 PDT by Matt Brubeck (:mbrubeck)
Modified: 2013-12-10 10:00 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
affected
fixed


Attachments
patch (1.79 KB, patch)
2011-10-04 10:12 PDT, Matt Brubeck (:mbrubeck)
blassey.bugs: review+
blizzard: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Matt Brubeck (:mbrubeck) 2011-10-04 10:12:49 PDT
Created attachment 564599 [details] [diff] [review]
patch

Bug 659188 added "uses-feature" declarations for camera and camera.autofocus.  These should be marked required="false", otherwise the Android Market might not show Fennec to devices without camera and autofocus hardware:
http://developer.android.com/guide/topics/manifest/uses-feature-element.html#declared

(This is similar to bug 621262, which fixed the same problem with GPS.)

This patch also cleans up two permission declarations that were accidentally added twice.

Requesting tracking-fennec because this is a regression in Fennec 9 and we might want to fix it on the Aurora branch.
Comment 2 Matt Brubeck (:mbrubeck) 2011-10-04 12:05:03 PDT
Comment on attachment 564599 [details] [diff] [review]
patch

Reqesting approval for Aurora 9.  This simple metadata change in our Android package manifest fixes a regression in Firefox 9 that might make Firefox unavailable in the Android Market on some devices.
Comment 3 Marco Bonardo [::mak] 2011-10-05 05:05:09 PDT
https://hg.mozilla.org/mozilla-central/rev/2701aeb5ad8d
Comment 4 Christopher Blizzard (:blizzard) 2011-10-06 14:56:41 PDT
Comment on attachment 564599 [details] [diff] [review]
patch

Approved for Aurora (Update 9).  Please land as soon as possible.

Note You need to log in before you can comment on or make changes to this bug.