Last Comment Bug 691845 - importxml.pl complains if an open bug has the resolution field set to ''
: importxml.pl complains if an open bug has the resolution field set to ''
Status: RESOLVED FIXED
: regression
Product: Bugzilla
Classification: Server Software
Component: Bug Import/Export & Moving (show other bugs)
: 4.0.2
: All All
: -- normal (vote)
: Bugzilla 4.0
Assigned To: Frédéric Buclin
: default-qa
:
Mentors:
Depends on: 653263
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-04 11:11 PDT by Frédéric Buclin
Modified: 2011-10-07 15:37 PDT (History)
0 users
LpSolit: approval+
LpSolit: approval4.2+
LpSolit: approval4.0+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch, v1 (1.95 KB, patch)
2011-10-05 14:19 PDT, Frédéric Buclin
dkl: review+
Details | Diff | Splinter Review

Description Frédéric Buclin 2011-10-04 11:11:20 PDT
With bug 653263, the resolution field is now always present in the XML file, even for open bugs, and importxml.pl now complains that we tried to set a resolution for this bug. The reason is that importxml.pl checks if the resolution field is defined, not set to something. It should treat an empty resolution the same way as a missing resolution.
Comment 1 Frédéric Buclin 2011-10-05 14:19:07 PDT
Created attachment 565012 [details] [diff] [review]
patch, v1
Comment 2 David Lawrence [:dkl] 2011-10-07 14:04:00 PDT
Comment on attachment 565012 [details] [diff] [review]
patch, v1

Review of attachment 565012 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good and works as expected. r=dkl
Comment 3 Frédéric Buclin 2011-10-07 15:37:24 PDT
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified importxml.pl
Committed revision 7974.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.2/
modified importxml.pl
Committed revision 7940.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified importxml.pl
Committed revision 7651.

Note You need to log in before you can comment on or make changes to this bug.