menubar is extremely difficult to read with aero-glass effect

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: matthew.atkinson, Unassigned)

Tracking

8 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 564835 [details]
Thunderbird unreadable menu.png

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20110928060149

Steps to reproduce:

Install Thunderbird using the standard theme


Actual results:

I couldn't read the Menu bar unless I looked really hard


Expected results:

The menubar should be of sufficiently high contrast to be easy to read
(Reporter)

Updated

7 years ago
Severity: normal → major
OS: Windows XP → Windows Vista
See Also: → bug 667248
(Reporter)

Comment 1

7 years ago
Bug 667248 raised the subject that this menubar was impossible to read. It is no longer *IMPOSSIBLE*, but it is still very difficult, on my Vista box at least. That bug has been marked as FIXED, so I've opened this one as the basic product is unusable for me without an addon. 

I don't know about Windows 7, but the problem is entirely absent on XP. 

Interestingly, it's not as bad when the window isn't maximised, as the background changes colour (no, I don't know why, I think it's a Windows 'feature')

The problem is also present in Firefox, though that doesn't bother me as I use the Firefox button instead of the menu bar.
As a side note, this will be fixed by bug 644169, because we'll be moving the menus to under the tabs (and thus not on top of the glass) as part of the tabs on top feature.
(Reporter)

Comment 3

7 years ago
That's different to Firefox, which has Tabs-on-top, but the Menu (if you choose to show it) is above the tabs. Two questions. 

1. Why would you make Thunderbird different from Firefox in this way? 
2. Will you also implement a Thunderbird menu button like Firefox has? If so, you should combine the releases in the same version.

Comment 4

7 years ago
Re comment #2, users would still have the option to switch back to tabs-below-menu even after bug 644169, correct? In that case, the problem with menu visibility would remain relevant.

Re comment #3 part #2, the additional (aero-only) application menu button is bug 650170.

Comment 5

7 years ago
I can confirm this issue on Windows 7. I'm getting a lot of push back from users I support regarding readability. Having the toolbars and menu bar use the same background as the folder/account pane would resolve this issue on Windows 7.

Incidentally, I'm also getting lots of comments like "Eww why does it look ugly now?!" and "I don't want to use that, it looks wrong". Can't be good from a marketing point of view...
(Reporter)

Comment 6

7 years ago
This bug is logged as in version 8 and Windows Vista, but also exists in Version 9 and 10 Beta 1, and in Windows 7. I don't know how to mark it as affecting all these. Can anyone help, as Mozilla appear to be ignoring it.

Comment 7

7 years ago
(In reply to Matthew Atkinson from comment #6)
> This bug is logged as in version 8 and Windows Vista, but also exists in
> Version 9 and 10 Beta 1, and in Windows 7. I don't know how to mark it as
> affecting all these. Can anyone help, as Mozilla appear to be ignoring it.

It's not being ignored. It's already fixed. See bug 644169.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 8

7 years ago
How does that bug address comment 4?

Comment 9

7 years ago
(In reply to :aceman from comment #8)
> How does that bug address comment 4?

By requiring that tabs be on top. There's no option to have tabs on the bottom.

Comment 10

7 years ago
OK, as long as the menu is always under the tabbar.
(In reply to Matthew Atkinson from comment #3)
> That's different to Firefox, which has Tabs-on-top, but the Menu (if you
> choose to show it) is above the tabs. Two questions. 

Hey, I realized I never replied to this…

> 1. Why would you make Thunderbird different from Firefox in this way?

Because we're making it more like Windows Explorer, and because the menus are too hard to read when they're on the glass.  It wouldn't overly surprise me if Firefox eventually went this direction, too…

> 2. Will you also implement a Thunderbird menu button like Firefox has? If
> so, you should combine the releases in the same version.

Eventually, yes, but we're waiting for some Test Pilot data first, and this seems like enough of a win to not wait for the Thunderbird menu button.

Thanks,
Blake.
(Reporter)

Comment 12

7 years ago
Just tried Earlybird and the Tabs are below the menu. Will see how this looks on Vista.
You need to log in before you can comment on or make changes to this bug.