Closed Bug 692446 Opened 8 years ago Closed 7 years ago

Firefox prompts to install windows media player plugin even though it is already installed

Categories

(Core :: Plug-ins, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox9 + ---
firefox11 - ---

People

(Reporter: mihaelav, Assigned: rstrong)

References

Details

(Whiteboard: [qa+])

Environment:
Builds:
Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (Windows NT 6.1; rv:9.0a2) Gecko/20111006 Firefox/9.0a2
Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111005 Firefox/10.0a1
OSs: 
Win7 x86, Win7 x64, Win Vista

Prerequisites:
1. Have windows media player plugin installed

Steps to reproduce:
1. Install Firefox
2. Go to a page that requires windows media player plugin (http://mozqa.com/data/firefox/plugins/mediaplayer.html)

Expected:
Video should load and play smoothly.

Actuall result:
Browser prompts to install windows media player plugin. 
During installing process, user is asked to select change, repair or remove installation. Changing or repairing causes browser to ask again to install the plugin when loading the page from Step 2.
You need to remove the plugin and install it again in order to work properly

Note: 
Microsoft windows media player plugin was not listed in plugins list (Addons Manager, about:plugins) before uninstall&reinstall.
I bet this happens because the WMP installer puts the plugin directly in the Firefox/plugins directory and doesn't use the registry.
The 64bit Firefox however is using a different directory as the 32bit one. A 64bit browser will not find the plugin if you installed it in a 32bit Firefox version,
For Win7x64 I used a 32 bit version of browser
Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0

I can also reproduce this on Windows Vista using Firefox 8.0 beta 3. I have to remove and then install Windows Media plugin again in order for a video to play.
Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0

Issue is still reproducible on latest Firefox 8 beta 4.
Confirmed that this still happens in Firefox 9.0b2 and does not happen with Internet Explorer 8.
Whiteboard: [qa+]
Asking for tracking as this essentially means users cannot watch any WMP content in Firefox.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0

Issue still reproducible in the latest beta (9beta5)
Can someone from qa work up a regression range? I sense this might be a really old regression. 

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/
Well, I just tried this on a clean virtual machine with Win7 64bit using Fx8.0.1 and Fx9b5, and this works for me. The first time I launched the browser after manually installing the plugin linked off of the PFS dialog, I got a dialog saying the plugin container process was being blocked. The plugin loaded anyway while the dialog was up. I allowed the process to run and I see no problem.

I will try on real hardware just to make sure, but I don't know why this would be happening. The key thing is that I installed the plugin manually from: http://www.interoperabilitybridges.com/windows-media-player-firefox-plugin-download

Which is what is linked off of the plugin finder service when you click on the Manual installation button.
(In reply to juan becerra [:juanb] from comment #9)
> Well, I just tried this on a clean virtual machine with Win7 64bit using
> Fx8.0.1 and Fx9b5, and this works for me. The first time I launched the
> browser after manually installing the plugin linked off of the PFS dialog, I
> got a dialog saying the plugin container process was being blocked. The
> plugin loaded anyway while the dialog was up. I allowed the process to run
> and I see no problem.
> 
> I will try on real hardware just to make sure, but I don't know why this
> would be happening. The key thing is that I installed the plugin manually
> from:
> http://www.interoperabilitybridges.com/windows-media-player-firefox-plugin-
> download
> 
> Which is what is linked off of the plugin finder service when you click on
> the Manual installation button.

Thanks Juan. Perhaps Mihaela will be able to help repro. For now, we're going to leave this tracked but this will have no effect on the current FF9 timeline.
I've tried on real hardware, Win7, Fx8.0.1 and Fx9b5, with anti-virus software and the like, and I was not able to reproduce the problem either.
Juan (if you haven't done the following already), on a clean VM without Firefox could you try first installing the WMP plugin, then installing Firefox, and then test? It could be that the WMP installer isn't doing the right thing.
I tried this scenario as well, and I didn't see a problem either.

I didn't know if the Windows Media Player v11 would have anything to do with this problem, but I tried installing that as well, and it turned out not to have an effect. The WMP plugin worked. 

(In reply to Robert Strong [:rstrong] (do not email) from comment #12)
> Juan (if you haven't done the following already), on a clean VM without
> Firefox could you try first installing the WMP plugin, then installing
> Firefox, and then test? It could be that the WMP installer isn't doing the
> right thing.
Windows 7, no Firefox installed, Windows Media Player 12.0.7.7600.16415 installed

1. Install Firefox 9.0b5
2. Start Firefox and check about:plugins 
-> no plugins installed
3. Go to http://mozqa.com/data/firefox/plugins/mediaplayer.html 
-> prompted to install plugin
4. No plugin found so I click "manual install"
-> redirected to http://www.interoperabilitybridges.com/windows-media-player-firefox-plugin-download
5. Download "Windows Media Player Firefox Plugin"
6. Quit Firefox and install wmpfirefoxplugin.exe
7. Start Firefox and check about:plugins
-> Microsoft Windows Media Player Firefox Plugin 1.0.0.8 installed (np-mswmp.dll)
8. Go to http://mozqa.com/data/firefox/plugins/mediaplayer.html
-> Video loads but a Windows Security Alert appears blocking "Plugin Container for Firefox"
9. Click "Allow Access"
-> Video buffers and works as expected
Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
I could reproduce this issue on Windows 7 using Firefox 11 beta 1.

Steps to reproduce:
1-9 -> Same steps as in Comment 14 with the difference that in step 1 I installed Firefox 11.0b1
10. Uninstall Firefox 
11. Install Firefox again
12. Go to http://mozqa.com/data/firefox/plugins/mediaplayer.html
-> prompted to install the plugin again.
Can you reproduce with a release build?
The windows installer puts the file directly in c:\program files\Mozilla Firefox\Plugins
A build installed in a different directory will not find the plugin. This is the fault of the Microsoft Installer.
(In reply to Robert Strong [:rstrong] (do not email) from comment #16)
> Can you reproduce with a release build?

Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0
Yes, I can reproduce it. The plugin needs to be installed separately for every Firefox version.
(In reply to Matthias Versen (Matti) from comment #17)
> The windows installer puts the file directly in c:\program files\Mozilla
> Firefox\Plugins
> A build installed in a different directory will not find the plugin. This is
> the fault of the Microsoft Installer.

If I install Firefox in the same location every time the plug-in is available.
Matthias, is there anything else QA can do here?
I don't think that QA can do anything.
As I already wrote, the stupid plugin installer from MS puts the plugin in c:\program files\Mozilla Firefox\plugins\ and nowhere else.
A Firefox build that is installed in a different directory will not find the Plugin.
Seamonkey is for example also affected by this. You can only manually copy the Plugin file "mswmp.dll" to get it working.
I know that behavior since they start to provide this plugin.

You could only evangelize Microsoft to fix their installer.
They should install it somewhere else and register the plugin in the registry
-> https://developer.mozilla.org/en/Adding_Extensions_using_the_Windows_Registry#Plugins
One option would be to change the plugins code to look in the well known locations for the WMP plugin. iirc it also installs into a directory in the root of the system drive if no Firefox installations are found.
That would be new to me but maybe they changed the installer.
I had only Seamonkey installed 2 years ago on my new laptop and the installer just aborted the installation. I had to pick the plugin dll from the temp directory.
rs I can do as you mentioned in Comment 22 quickly if you want.  
Please advise.
bbondy, I *think* it would be a good thing to check the possible locations for the WMP plugin instead of just relying on it being in our plugins directory (we have done similar for other plugins). I'd like jst to weigh in on this first though.

jst, what do you think of checking the possible filesystem locations where the WMP plugin would reside? Their installer does very little work in trying to find our install locations so we could check the release install plugins directory if the running instance isn't the same install and the location in the root of the system drive if the WMP installer does in fact still install into this location.
I'd be fine with that as long as Josh is.
Given this was being tracked for Firefox 9, do we want to continue to track this for Firefox 11+?
(In reply to Johnny Stenback (:jst, jst@mozilla.com) from comment #26)
> I'd be fine with that as long as Josh is.

That's also fine with me. Additionally, we should submit a bug report to MS to get them to properly use the registry.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #27)
> Given this was being tracked for Firefox 9, do we want to continue to track
> this for Firefox 11+?

Given that the repro case requires uninstalling/re-installing Firefox, and this isn't a recent regression, no need to track for 11

(In reply to Simona B [QA] from comment #15)
> 10. Uninstall Firefox 
> 11. Install Firefox again

bbondy/rstrong/jst/josh - who can grab this bug and follow up with MS?
I'll take this and work on it next week.
Assignee: nobody → netzen
Stealing from bbondy so he can focus on the Win8 work.
Assignee: netzen → robert.bugzilla
It is also reproducible on FF 10.0.4ESR.
BuildID: Mozilla/5.0 (Windows NT 6.1; rv:10.0.4) Gecko/20100101 Firefox/10.0.4
Also when trying to open http://users.skynet.be/sky40152/ape%20man.wmv, the video won't play and FF will show the save file dialog. Tested on FF 16.0a2 (2012-07-18).
(In reply to Paul Silaghi [QA] from comment #33)
> Also when trying to open http://users.skynet.be/sky40152/ape%20man.wmv, the
> video won't play and FF will show the save file dialog. Tested on FF 16.0a2
> (2012-07-18).
It played in content for me... even if there is a bug related to that it has nothing to do with this bug. If you don't have the WMP plugin installed I suspect that it is due to that file not having the proper mimetype sent by the server and the plugin finder service not knowing what to do with it. If you have the WMP plugin I suspect it might be due to your handling of wmp being set to save as for your profile. Whatever the case, that is different from this bug.
I have wmp plugin installed, but it was installed on other version of FF. That's the  problem I guess. And this is the same reason why http://mozqa.com/data/firefox/plugins/mediaplayer.html won't play on a different FF than the one wmp plugin was installed on.
(In reply to Paul Silaghi [QA] from comment #35)
> I have wmp plugin installed, but it was installed on other version of FF.
> That's the  problem I guess. And this is the same reason why
> http://mozqa.com/data/firefox/plugins/mediaplayer.html won't play on a
> different FF than the one wmp plugin was installed on.
Manually corrupting the mar will get caught by the hash check and there are ways to manually corrupt the mar that will cause the updater to crash which might be what is going on in your case.
Robert, what's needed from QA to move this bug forward. It seems we've lost traction.
I don't believe we should spend additional time on this bug. The WMP plugin is not well maintained, and I have plans in Q1 to suppress the PFS prompting for almost all plugins.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 310541
Duplicate of this bug: 421820
My created bug 421820 was marked as dupe of this bug so I want to let everyone know about the workaround how to get the WMP running in each installed version of Firefox. Simply follow the steps I have noted down on my website: http://www.hskupin.info/2009/01/13/get-window-media-player-plugin-work-with-all-installed-firefox-versions/
You need to log in before you can comment on or make changes to this bug.