Last Comment Bug 421820 - New Microsoft Windows Media Player 11 plugin is only installed for the system default Firefox version
: New Microsoft Windows Media Player 11 plugin is only installed for the system...
Status: RESOLVED DUPLICATE of bug 692446
:
Product: Plugins Graveyard
Classification: Graveyard
Component: Windows Media Player (Microsoft) (show other bugs)
: unspecified
: x86 Windows Vista
: -- major
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
https://bugzilla.mozilla.org/attachme...
: 422475 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 15:17 PDT by Henrik Skupin (:whimboo)
Modified: 2016-04-28 09:16 PDT (History)
16 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Registry hack for all Firefox instances (740 bytes, application/octet-stream)
2009-01-13 04:13 PST, Henrik Skupin (:whimboo)
no flags Details

Description Henrik Skupin (:whimboo) 2008-03-09 15:17:34 PDT
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008030904 Minefield/3.0b5pre

While trying to check the fix for bug 393845 with attachment 278687 [details] I noticed that I don't have the needed new WMP 11 plugin installed on my system. I had to manually install the plugin over the Plugin Finder Service. The setup quits with success and the plugin is listed within the software list.

After reloading the page with the attachment, restarting Firefox, or even restarting Windows the plugin isn't started and Firefox cannot play the movie. Instead I get presented the Plugin Finder Service again.

The list of plugins under the Add-ons manager doesn't show the newly installed plugin. Even the registy doesn't list the plugin under HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins. Only Silverlight and WPF exists there. So I'm not sure if this is our fault or the plugin isn't installed correctly. 

Setting this bug as major and asking for blocking1.9.
Comment 1 Henrik Skupin (:whimboo) 2008-03-09 15:24:39 PDT
I used following URL to install the plugin:
http://port25.technet.com/archive/2007/04/16/windows-media-player-plug-in-for-firefox.aspx

As I read on http://kb.mozillazine.org/Windows_Media_Player#Installing_the_new_plugin the installer copies the np-mswmp.dll into the Firefox installation directory. Does it have trouble to detect the correct one - when using a nightly build or a custom set folder?
Comment 2 Carsten Book [:Tomcat] 2008-03-09 15:47:40 PDT
works for me on Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4, as talked on irc, it seems that the plugin is only for firefox and not "minefield".

So i don't think its blocking here and maybe this bug is invalid because its a specific plugin issue.
Comment 3 Henrik Skupin (:whimboo) 2008-03-09 15:49:39 PDT
Ok I did some tests and I found the reason why it happens. The installer checks if Firefox is installed on the system by searching for "Mozilla Firefox" under HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\. It does not detect Minefield as a Firefox installation and silently stops the installation.

I installed Firefox 3 beta4 rc2 to have a test with an official release. Starting the installer afterwards correctly installs the plugin into the sub folder of the Firefox installation. So the installer will definitely work. => Remove the blocking1.9 flag and updating summary.
Comment 4 Henrik Skupin (:whimboo) 2008-03-09 15:53:57 PDT
(In reply to comment #2)
> So i don't think its blocking here and maybe this bug is invalid because its a
> specific plugin issue.

It's a plugin issue, yes. But I'm not sure if we should close it immediately. The way of how this plugin is installed doesn't seem to be correct. Why it is not installed in a seperate folder and linked here: HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins

Any chance to inform Microsoft so that they can enhance their WMP11 plugin installer?
Comment 5 Henrik Skupin (:whimboo) 2008-03-09 16:07:29 PDT
This will also affect multiple installations of Firefox. Only for the default version the plugin will be installed at the moment.
Comment 6 Matthias Versen [:Matti] 2008-03-12 17:35:09 PDT
*** Bug 422475 has been marked as a duplicate of this bug. ***
Comment 7 Gili 2008-04-28 13:52:25 PDT
This issue makes it difficult for new users to decide whether to jump to FireFox3 leaving FireFox2 installed. At first glance it looks like FireFox3 is broken and doesn't play a whole bunch of videos, users will then opt to go back to FireFox2.
Comment 8 Henrik Skupin (:whimboo) 2009-01-13 04:13:29 PST
Created attachment 356704 [details]
Registry hack for all Firefox instances

Ok, lets return to this issue. As what I've seen lately, it's easy to get the wmv plugin working with any installed development build of Firefox.

You only have to perform the following steps:
1. Use the official installer to get the plugin installed for your Firefox version.
2. Copy the file "np-mswmp.dll" from within the plugins folder to "c:\Program Files\Windows Media Player\Plugin\np-mswmp.dll". You have to create the Plugins folder manually.
3. Download and run this attached registry file. If you are using another shared folder update it within the registry file first.

After a restart your development builds should also play MWV content now.
Comment 9 Philip Chee 2009-01-13 13:41:41 PST
> Created an attachment (id=356704) [details]
> Temporary registry patch for wmv plugin

Eeek. The mime type claims to be text/plain but it's actually UTF-16 or something weird.
Comment 10 Henrik Skupin (:whimboo) 2009-01-13 15:04:57 PST
Ok, lets go with application/octet-stream for now.
Comment 11 Andreas Eibach 2009-03-14 02:20:24 PDT
Everything sounds so easy, but it isn't! Actually, I assumed that the np-wswmp.dll was included in the wmpfirefoxplugin.exe file but apparently it was not. Nothing on C:, nothing on my other partition where Minefield was installed. Nada. I had to do something I'd rather avoid: install this dll previously shared on one of those numerous file hosting services.
I'm not really alone with this: see http://kb.mozillazine.org/index.php?title=Talk:Windows_Media_Player&printable=yes

I also have Windows XP Sp2 (upgraded from WinXPsp1) and WMP10. I downloaded wmpfirefoxplugin.exe from (SITE) [...] I did a Windows search on "NPMSWMP.dll" and "NPMSWMP*" just to make sure, and nada, nothing was copied anywhere."

Correct.
And unfortunately, I have no way to trace what is copied where to because everything goes so damn fast. Nor could I find any log file or something of that sort.
Weird stuff.
Comment 12 Andreas Eibach 2009-03-14 02:21:03 PDT
(should be np-*m*swmp.dll sorry for the typo)
Comment 13 Andreas Eibach 2009-03-14 02:43:05 PDT
OK me again ... I investigated this even further: I figured out that the ffplugin.msi is actually a self-extracting .cab. So I wondered whether I could maybe open that thing with WinRAR by simply renaming it to .cab. But this failed. The file contents (LicenseRtf / NPMSWMPdll / RelNotesTxt) can be viewed, but all I get is "the archive is corrupt". But maybe the MS archive *DOES* have an issue? Maybe this is also the reason why the actual DLL doesn't get installed on many users' systems.
Comment 14 Ria Klaassen (not reading all bugmail) 2009-06-17 01:00:09 PDT
It works also flawlessly in the good old Mozilla|Plugins directory:
C:\Users\username\AppData\Roaming\Mozilla\Plugins\np-mswmp.dll

It even prefers that location over every other location even if the plugin in the other location is newer (Bug 435993).
Comment 15 Andreas Eibach 2010-09-23 03:42:14 PDT
Flawlessly?

I beg to differ!
I have here C:\Users\username\AppData\Roaming\Mozilla\Extensions\
and
C:\Users\username\AppData\Roaming\Mozilla\Firefox.

The plugins subdirectory did not even exist.
However, $FIREFOX_INSTALL_PATH\plugins worked, though I had to copy in the dll by hand.

Plus, there seems no way to _specify_ the plugins directory in about:config. Registry seems the one and only way out. Not good.
Comment 16 Paul Silaghi, QA [:pauly] 2013-05-03 00:23:35 PDT
Because bug 692446 already has a resolved status.

*** This bug has been marked as a duplicate of bug 692446 ***

Note You need to log in before you can comment on or make changes to this bug.