Closed Bug 692796 Opened 9 years ago Closed 9 years ago

We should not trigger PGO builds more than once for the same changeset

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 691675

People

(Reporter: armenzg, Unassigned)

References

Details

WARNING: this could a complete INVALID bug as I only have data for the last 2 days.

Do we have these PGO triggered builds every 4 hours on mozilla-inbound, mozilla-central, mozilla-aurora and mozilla-beta? Are we skipping if nothing has landed since last time?

If we look at theses URLs we can see that we have several extra sets of PGO test jobs for the same changeset:
https://tbpl.mozilla.org/?tree=Mozilla-Aurora&rev=0da47992b626 - 3 sets of duplication - 1 due to nightly
https://tbpl.mozilla.org/?tree=Mozilla-Aurora&rev=ad21e8e83543 - 5 sets of duplication - 1 due to nightly
https://tbpl.mozilla.org/?tree=Mozilla-Aurora&rev=e7cc149f2441 - 2 sets of duplication - no nightly

There is also a reporting issue. We see triggered PGO tests but no PGO build being represented. Perhaps tbpl simply ignores it as I can't see PGO builds at all. This might be related that PGO builds don't have an associated revision on self-serve. I can only see an opt build for any of these changesets except for when there is a nightly build.

I also see duplication of tests on Mozilla-Beta where we don't have nightly builds:
https://tbpl.mozilla.org/?tree=Mozilla-Beta&jobname=pgo&rev=276ccee22d0b - 2 sets of duplication
https://tbpl.mozilla.org/?tree=Mozilla-Beta&jobname=pgo&rev=4e666d73c807 - 7 sets of duplication
* I am surprised about this one as the next push is 5 hours later

Self-serve data:
https://build.mozilla.org/buildapi/self-serve/mozilla-beta/build/5894940
https://build.mozilla.org/buildapi/self-serve/mozilla-beta/build/5898020

I currently see another set of PGO builds being run:
WINNT 5.2 mozilla-beta pgo-build 		2011-10-07 08:09:31 	
Linux x86-64 mozilla-beta pgo-build 		2011-10-07 08:00:13 	
Linux mozilla-beta pgo-build 		2011-10-07 08:00:12
"reason": "The Nightly scheduler named 'mozilla-beta pgo' triggered this build",
This sounds like a dupe of bug 691675 to me.
Blocks: 658313
No longer blocks: pgo-improvements
You are right.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 691675
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.