Closed Bug 693058 Opened 13 years ago Closed 5 years ago

Implement Unity progress bar and quicklist

Categories

(Core :: Widget: Gtk, enhancement, P3)

7 Branch
All
Linux
enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: marco, Assigned: marco)

References

Details

I don't know if this is a bug for Mozilla or for Ubuntu developers.
I think we should make use of Unity's Launcher API (https://wiki.ubuntu.com/Unity/LauncherAPI) to implement the progress bar and the quicklist.
There's an addon for the progress bar, UnityFox.
Assignee: nobody → mar.castelluccio
Blocks: 597155
I've filed a bug in Launchpad (https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/871325), I've asked if they want to add UnityFox to their addon (actually they have two different addons, one for Unity globalmenu integration and one for other things, like apt support).
If their reply will be negative, I'll try to implement the progress bar directly into Firefox.
Chris, is there a plan to solve this issue?
(In reply to Marco Castelluccio [:marco] from comment #2)
> Chris, is there a plan to solve this issue?

Unfortunately, not at the moment. I'm only working on Firefox in my spare time now, which is quite limited already :/
(In reply to Chris Coulson from comment #3)
> (In reply to Marco Castelluccio [:marco] from comment #2)
> > Chris, is there a plan to solve this issue?
> 
> Unfortunately, not at the moment. I'm only working on Firefox in my spare
> time now, which is quite limited already :/

Is libunity stable enough? Do you think we can use it in Firefox like it's used in your UnityFox extension?
Yeah, it's certainly ok to use for current Ubuntu releases (I think all current releases have the same ABI). It could change again before the next LTS though. It's a shame I didn't get around to this before changing roles
(In reply to Chris Coulson from comment #5)
> Yeah, it's certainly ok to use for current Ubuntu releases (I think all
> current releases have the same ABI). It could change again before the next
> LTS though. It's a shame I didn't get around to this before changing roles

I don't know if the library can be used if it isn't so stable (and I don't know who should decide about this matter). In case it can be used, I could work on this as soon as I have some time available.
This statement asserts that libunity is preferred over the DBus interface:
"While the libunity API is stable, the DBus protocol underneath is not. We strongly discourage anyone from relying on it."

If libunity ends up changing, we can expect the soname to change, and so the worst that will happen is that Gecko will fail to find the library and will fall back to current behavior.  Even then, it probably won't be too difficult to adjust Gecko for changes in the libunity API.  So using libunity sounds fine.
What entries would you add in the quicklist by the way? One of the reasons I never added a quicklist for the Unityfox addon is that Unity doesn't provide a way to make it available when Firefox isn't running (so, for example, your most frequently visited sites would only appear in the menu once you'd already opened Firefox).

I did mention this limitation to the Unity developers nearly 2 years ago, but nothing happened with it
Blocks: 588314
Paolo, this is an Unity-only solution, on other DEs we'll still need to display a notification (we could use libnotify in the other cases, but it's still a notification :D).
No longer blocks: 597155
This would either be a widget or a theme bug
Component: Shell Integration → Widget: Win32
Product: Firefox → Core
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
libunity’s API is also consumed by third-party docks like Plank, and I’ve heard there are plans to get progress bars into GNOME Shell, so…
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: INVALID → ---
Status: UNCONFIRMED → NEW
Component: Widget: Win32 → Widget: Gtk
Ever confirmed: true
Priority: -- → P3
Type: defect → enhancement

We can open a new bug for GNOME Shell, if they decide to support progress bars (even if they do, I doubt they will use libunity).

Status: NEW → RESOLVED
Closed: 7 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.