Closed Bug 588314 Opened 11 years ago Closed 2 years ago

Figure out how to handle system-level download completion notifications on Windows XP, Windows 7 Classic and Linux

Categories

(Toolkit :: Downloads API, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: faaborg, Unassigned)

References

(Blocks 2 open bugs)

Details

OS X and Windows provide a standard mechanism for applications to draw the user's attention:

OS X: bounce dock icon
XP/Vista: turn task bar item orange
7: Progress bar in the task bar item, and turning the task bar item orange

We currently use these indicators to show that a download is complete, however we additionally add a second indicator which is entirely removed from both the application and the task bar entry to inform the user that a download is complete.

This notification is redundant, noisy, and non-platform native.  It is also the only remaining growl/toast in the product.  I recommend we remove it (or pref it off) for simplicity and internal and external consistency.
Blocks: 588481
(In reply to comment #0)> XP/Vista: turn task bar item orange... > We currently use these indicators to show that a download is complete,Only if the download manager is open, no?
Component: General → Download Manager
Product: Firefox → Toolkit
QA Contact: general → download.manager
It's great how Firefox trunk makes editing in textareas nearly impossible.
Trying this again with an external editor:

(In reply to comment #0)
> XP/Vista: turn task bar item orange...
> We currently use these indicators to show that a download is complete,

Only if the download manager is open, no?
Yeah, I think the download manager window is the item, that turns orange, and it of course opens when the download is initiated.
(In reply to comment #3)
> Yeah, I think the download manager window is the item, that turns orange, and
> it of course opens when the download is initiated.

I close it most of the time and let the alert notify me.

There's an option not to open the downloads window automatically as well.
(In reply to comment #4)
> (In reply to comment #3)
> > Yeah, I think the download manager window is the item, that turns orange, and
> > it of course opens when the download is initiated.
> 
> I close it most of the time and let the alert notify me.
> 
> There's an option not to open the downloads window automatically as well.

That is how I use it as well. I would certainly miss having the notification (particularly for large downloads where the growl gets pushed to my phone so I know it is finished when I'm away), so I personally would like to have a preference. Growl support is probably better left to extensions. At the same time, Growl might was well be platform-native on Mac with how ubiquitous it is.

I haven't kept up on the doorhanger progress, but would there be a doorhanger notification that a download is finished?
(In reply to comment #5)
> a doorhanger notification that a download is finished

The downloads complete popup is annoying and a CPU hog. If we could kill it entirely and switch it to a doorhanger that would be wonderful.
Version: unspecified → Trunk
I suppose we could make this depend on the new downloads UI (the panel, I think) and remove this at the same time that lands.
Do we finally want that ?
it's feasible, though we first have to verify the taskbar notifications with the new panel, since we may still have to move something from the old dm window to the browser window. Not a blocker or high priority, nice follow-up to the new panel.
Ok thanks for the clarification. ;-)
The panel is almost released. It would be time to reconsider this.
Since the panel has been released the growl is clearly redundant.
Duplicate of this bug: 859960
Blocks: 875383
This notification should not appear anymore as soon as the new Downloads API
is enabled in Nightly builds, which will happen very soon.
Blocks: 907082
Depends on: 847863
On Linux we shouldn't remove the notification, otherwise how do we draw the user attention?
Blocks: 911210
(In reply to Alex Faaborg [:faaborg] (Firefox UX) from comment #0)
> OS X and Windows provide a standard mechanism for applications to draw the
> user's attention:
> 
> OS X: bounce dock icon
> XP/Vista: turn task bar item orange
> 7: Progress bar in the task bar item, and turning the task bar item orange
> 

You forgot about Classic visual style!
No indication of taskbar item on Windows7 classic.
So, Notification popup should not be removed!
Per comment 0, this bug is only for platforms that "provide a standard mechanism for applications to draw the user's attention".
Summary: Remove (or pref off) the download complete toast/growl → Remove (or pref off) the download complete toast/growl on Mac and Windows
As I understand from bug 588481, the long-term user experience goal is to remove all the screen-level notifications that may get in the way of other tasks, replacing them with more sensible indicators like the one in the taskbar.

This is already the case on most Windows and Mac configurations, and the right way forward on Linux is to do the same, at least for some common distributions. The Unity launcher integration in bug 693058 comes to my mind.

There may be less common cases where we don't have this kind of indicator (Windows XP, Windows 7 Classic and Linux were mentioned). In those cases, I'm not sure whether we should or should not continue to provide our non-native screen-level notification. This indication lasts only a few seconds and is easy to miss in any case. We'd have to continue maintaining its code in exchange of a dubious benefit.

If reimplemented, this must only cover the cases where we don't have the taskbar indicator, and in any case this feature is not blocking the first release of the Downloads API.
Blocks: jsdownloads
No longer blocks: 907082
Depends on: 693058
I think we should use native means to notify a download, on Linux it'd mean using libnotify (it's still a notification, but it's what other applications that handle downloads do).
In GNOME 3 the native notifications don't get in the way of other tasks because they're quite quiet.
Summary: Remove (or pref off) the download complete toast/growl on Mac and Windows → Figure out how to handle system-level download completion notifications on Windows XP, Windows 7 Classic and Linux
Duplicate of this bug: 911210
Type: defect → enhancement

I don't think we need this anymore, closing

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.