Open Bug 693181 Opened 11 years ago Updated 7 years ago

Thunderbird 7.0.1 print dialog does not remember last printer

Categories

(MailNews Core :: Printing, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

REOPENED

People

(Reporter: mozilla.bugs.pb, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.23) Gecko/20110920 Firefox/3.6.23 ( .NET CLR 3.5.30729; .NET4.0E)
Build ID: 20110920075126

Steps to reproduce:

1. Print a message with ctrl-p.
2. Select printer other than default printer.
3. Complete printing.
4. Print same message with ctrl-p.


Actual results:

2nd attempt at printing defaults to default printer.


Expected results:

2nd attempt at printing should default to last-used by TB printer.

(Running Win XP sp3.)
This might or might not be related to bug https://bugzilla.mozilla.org/show_bug.cgi?id=692181 .

Another way to phrase the bug:  printer to which TB defaults is no longer sticky.  It should be.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Component: General → Printing
Product: Thunderbird → MailNews Core
QA Contact: general → printing
Resolution: --- → DUPLICATE
Duplicate of bug: 692181
Un-duping, as noted in bug 692181 comment 16.
(wow, the bug numbers are almost identical -- off by 1000 -- confused me for a minute. :))
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
See bug 692181 for some comments, and question to which this is an answer.

I have not been using Linux in recent times, so I don't know what the behavior is there.  Under Windows, the common behavior is for the last-selected printer in the print dialog to be sticky.  Apps that don't do that get complaints.  For example, FF 3.6.23, and prior versions, have sticky printer default.  (Sorry, I haven't gone over to newer versions of FF yet due to memory issues and lack of time to try 7.)  Also, prior versions of TB had sticky printer selection, so this is a regression.

(Yes, I also was at first confused by the seemingly same bug numbers.)
Perhaps I should add that typically in Windows apps, the first printer offered as the default is the system default.  However, if the user selects a different printer in that app, the app typically (not always) keeps that as its default, without changing the system default.

This makes sense to me because different apps have different printer needs.  For example, I almost never want to print to paper from a browser -- I just print to pdf, using a pdf "printer".  On the other hand, if I'm printing from a pdf viewer, I'm not going to want to print to pdf, right?  Rather to paper.  If I'm printing from say Photoshop, I probably want to print to a photo printer, not to my monochrome laser printer.  In the case of TB, I almost always want to print to pdf, although the system default is a hardcopy printer.  (That is needed because of the few apps that don't allow me to select an alternate printer.)

Now, it may be that someone actually decided that TB should NOT remember the last-used printer.  If so, hopefully they will find out about this bug report.
Duplicate of this bug: 692192
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
See Also: → 692181
You need to log in before you can comment on or make changes to this bug.