Last Comment Bug 693371 - Merge fx-team into remote-debug to get the Firefox 10 updates
: Merge fx-team into remote-debug to get the Firefox 10 updates
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Panos Astithas [:past] (away until 7/21)
:
Mentors:
Depends on:
Blocks: minotaur
  Show dependency treegraph
 
Reported: 2011-10-10 11:15 PDT by Panos Astithas [:past] (away until 7/21)
Modified: 2011-10-12 00:05 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Console output from hanging test (4.62 KB, text/plain)
2011-10-11 06:30 PDT, Panos Astithas [:past] (away until 7/21)
no flags Details
Working patch (3.48 KB, patch)
2011-10-11 07:05 PDT, Panos Astithas [:past] (away until 7/21)
dcamp: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] (away until 7/21) 2011-10-10 11:15:10 PDT
We need another merge from fx-team to get the latest changes as well as the version bump to 10.
Comment 1 Panos Astithas [:past] (away until 7/21) 2011-10-10 11:16:29 PDT
Did the merge, fixed the induced bustage, but there is still a failing unit test I'm investigating.
Comment 2 Panos Astithas [:past] (away until 7/21) 2011-10-11 06:30:25 PDT
Created attachment 566190 [details]
Console output from hanging test

The test_breakpoint-01.js test hangs as can be seen in this console output. The reason is that the eval source script is received with the live property undefined, instead of true (or even false). I'm still trying to figure out which recent change broke this.
Comment 3 Panos Astithas [:past] (away until 7/21) 2011-10-11 07:05:18 PDT
Created attachment 566206 [details] [diff] [review]
Working patch

The problem was that Debugger.Script no longer exposes a "live" property, because all scripts are live by default. With this patch the merge works fine.
Comment 4 Panos Astithas [:past] (away until 7/21) 2011-10-12 00:05:21 PDT
https://hg.mozilla.org/users/dcamp_campd.org/remote-debug/rev/9dc264a88b14

Note You need to log in before you can comment on or make changes to this bug.