Closed Bug 693459 Opened 9 years ago Closed 9 years ago

Skype Click to call extension not disabled as installed by 3rd party on upgrade to fx 8

Categories

(Toolkit :: Add-ons Manager, defect)

8 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 693698
Tracking Status
firefox8 + ---

People

(Reporter: verdi, Unassigned)

Details

Attachments

(1 file)

I expected that the Skype click to call extension (bundled with Skype) would have been disabled upon updating to Firefox 8. Instead is was marked as installed by me and incompatible (but set to be updated and enabled automatically). http://people.mozilla.org/~mverdi/screenshots/skype_click_to_call-20111010-164715.jpg

http://people.mozilla.org/~mverdi/screenshots/extensions-20111010-165515.jpg
Attachment #566053 - Attachment mime type: text/plain → application/octet-stream
Michael, I haven't checked the sqlite file, but where gets this add-on installed? Is it inside your profile folder?
Well, the second screenshot answers my question. So Skype installs this extension directly into the users default profile. That's why it has been marked as installed by yourself.
Actually it installs it to the application directory, the other location that we consider to be user managed. This is a surprise, I didn't think any apps were still doing that.
Track this. We have one shot at this dialog and we know the skype add-on is behaving badly: https://plus.google.com/114490712483753086051/posts/FCYYZorhikj
I did some more testing and filed this bug https://bugzilla.mozilla.org/show_bug.cgi?id=693698
(In reply to [:Cww] from comment #4)
> Track this. We have one shot at this dialog and we know the skype add-on is
> behaving badly:
> https://plus.google.com/114490712483753086051/posts/FCYYZorhikj

I still really don't understand what tracking means. If it means the drivers have determined that this bug must be fixed before shipping 8, then we should pull this from beta and aurora now. The changes required to fix this case without getting Skype to do the right thing are quite difficult and unlikely to be do-able in a month (and we wouldn't get any user testing of them at all).
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 693698
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.