Note: There are a few cases of duplicates in user autocompletion which are being worked on.

3rd Party add-ons from the application folder are not disabled on upgrade

VERIFIED FIXED in Firefox 8

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: verdi, Assigned: mossop)

Tracking

({verified-beta})

8 Branch
mozilla10
x86
Windows 7
verified-beta
Points:
---
Dependency tree / graph
Bug Flags:
in-litmus +

Firefox Tracking Flags

(firefox8+ fixed, firefox9+ fixed)

Details

(Whiteboard: [qa!])

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
Created attachment 566272 [details]
Add-ons before and after updating to Firefox 8

1. I did a clean install of Firefox 7.0b6 in Windows 7. It had a fresh profile. 
2. I then downloaded and installed a variety of programs that bundle Firefox add-ons:
* Skype - http://skype.com
* Weatherbug - http://weatherbug.com
* Free FLV player for Windows - http://applian.com/flvplayer/
* Advanced SystemCare - http://www.iobit.com/advancedsystemcareper.html
* PDFCreator - http://www.pdfforge.org/pdfcreator
* Defraggler - http://www.piriform.com/defraggler/download

3. After restarting Firefox 7 I had a lot of third party add-ons (some were disabled because they weren't compatible).
4. I updated Firefox 7 to Firefox 8. During the update process my add-ons were checked and none of them were identified as third party. All were checked to keep and to be active (some were deactivated because they weren't compatible)
5. Firefox 8 still has a lot of third party add-ons.

I have the Program directory and the profile zipped up. I can upload them if they'd be helpful.
(Assignee)

Comment 1

6 years ago
Can you attach a copy of extensions.sqlite from your profile.
Blocks: 476430
(Reporter)

Comment 2

6 years ago
Created attachment 566286 [details]
extensions.sqlite from the profile folder
(Assignee)

Updated

6 years ago
Duplicate of this bug: 693459
(Assignee)

Updated

6 years ago
Attachment #566286 - Attachment mime type: text/plain → application/octet-stream
nom'ing for tracking Fx8 -- we should make sure this isn't broken before advertising it as a Firefox 8 feature.
tracking-firefox8: --- → ?
(Reporter)

Comment 5

6 years ago
Created attachment 566388 [details]
The ubuntu addon was disabled on update

I updated my Ubuntu VM from Fx 7 to 8 and the Ubuntu add-on was flagged as third party on upgrade.
(Reporter)

Comment 6

6 years ago
Created attachment 566389 [details]
extensions.sqlite from the linux profile
(Assignee)

Comment 7

6 years ago
Thanks for the updates, the problems here are all because the third party add-ons are getting installed to the profile or application directory, I'm trying to work out whether it's possible to solve this problem.
As mentioned by Dave over on bug 693459 he wants to have it also tracked for Aurora.
tracking-firefox9: --- → ?
(In reply to Dave Townsend (:Mossop) from comment #7)
> Thanks for the updates, the problems here are all because the third party
> add-ons are getting installed to the profile or application directory, I'm
> trying to work out whether it's possible to solve this problem.

If all else fails, can we ship a list of extensions that we know are being installed by third parties even though they look from the point of view of the add-on management code like extensions the user has installed?
(Assignee)

Comment 10

6 years ago
For reference the following is the install location of all the add-ons listed in attachment 566286 [details]:

app-profile|Ask Toolbar
app-profile|Complitly - Speed up your search with your personal search suggestions tool
app-profile|Freecorder Toolbar
app-profile|YouTube Video Download Wizard
app-global|Default
app-global|Skype Click to Call
app-global|IObit Toolbar
app-global|pdfforge Toolbar
app-global|Widgi Toolbar Platform

Updated

6 years ago
tracking-firefox8: ? → +
tracking-firefox9: ? → +
Whiteboard: [qa+]
(Assignee)

Comment 11

6 years ago
I'm splitting this up so this bug covers third-party add-ons in the application folder and bug 694575 covers those in the profile folder.
Summary: 3rd Party Add-ons are not disabled on upgrade → 3rd Party add-ons from the application folder are not disabled on upgrade
(Assignee)

Updated

6 years ago
Assignee: nobody → dtownsend
Blocks: 693743
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
No longer blocks: 693743
(Assignee)

Comment 12

6 years ago
Created attachment 567775 [details] [diff] [review]
patch rev 1

This makes the upgrade UI class any non-themes in the application directory as third party installs and updates the testcase to match. Distribution add-ons remain as they were.
Attachment #567775 - Flags: review?(bmcbride)
Attachment #567775 - Flags: review?(bmcbride) → review+
(Assignee)

Comment 13

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/064189e08af2
Whiteboard: [qa+] → [qa+][inbound]
https://hg.mozilla.org/mozilla-central/rev/064189e08af2

adding [inbound] is no more needed (indeed it's actually discouraged)
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [qa+][inbound] → [qa+]
Target Milestone: --- → mozilla10

Comment 15

6 years ago
Comment on attachment 567775 [details] [diff] [review]
patch rev 1

I think we really want this for completeness in the feature. Yes, it's late. Without this change, we're far less effective when we help users disable unwanted add-ons.
Attachment #567775 - Flags: approval-mozilla-beta?

Comment 16

6 years ago
If it's not approved for Aurora, those who will update from 3.6 to 9 won't have this change.
(Assignee)

Updated

6 years ago
Attachment #567775 - Flags: approval-mozilla-aurora?

Comment 17

6 years ago
Comment on attachment 567775 [details] [diff] [review]
patch rev 1

---------------------------------[ Triage Comment ]---------------------------------

Approving for 8beta and 9aurora as this is a good fix for a new feature and was approved via in person conversations.

Please land ASAP.
Attachment #567775 - Flags: approval-mozilla-beta?
Attachment #567775 - Flags: approval-mozilla-beta+
Attachment #567775 - Flags: approval-mozilla-aurora?
Attachment #567775 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 18

6 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/dc0a0e5cd2bd
https://hg.mozilla.org/releases/mozilla-aurora/rev/56032076e440
status-firefox8: --- → fixed
status-firefox9: --- → fixed
(Reporter)

Comment 19

6 years ago
This is awesome!!
Mozilla/5.0 (Windows NT 6.1; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20100101 Firefox/9.0

Verified in Firefox9Beta3, Firefox Aurora and Nightly on Windows XP, 7. Switched the shownselectionUI pref to enable the UI dialog after an upgrade. Used Pdfforce Tollbar, Widgi Toolbar Platform, AVG Safe search. All these are dsiplayed as Third Party in the selection dialog after an upgrade.
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
Keywords: verified-beta
Flags: in-litmus?(virgil.dicu)
Flags: in-litmus?(virgil.dicu) → in-litmus+
You need to log in before you can comment on or make changes to this bug.