GData provider does not allow adding an alarm to events I'm invited to

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
7 years ago
4 years ago

People

(Reporter: mozilla-bugs, Unassigned)

Tracking

Lightning 1.0b7
x86
Mac OS X

Details

(Reporter)

Description

7 years ago
When someone else creates and event and invites me, I can see it in Lightning, double-click to see the details and change my reply. But, there is no 
option to add an alarm / reminder. For events that I create myself, I can add and later edit the reminder.
This is supported in the Google Calendar web interface, so it seems likely that there is API for it.
Just as a note to self, since on the first read I didn't see this: This happens when adding an alarm to an event that is owned by someone else.

Eric, here are some details about development since you mentioned you are a programmer:

* You can read the source code here: <http://mxr.mozilla.org/comm-central/source/calendar/providers/gdata/> or you can download it via mercurial at http://hg.mozilla.org/comm-central/

* The build system takes care of packaging the extension, so if you plan on further contributing you should build Thunderbird+Lightning+GData Provider. Instructions here: <https://developer.mozilla.org/En/Simple_Thunderbird_build>

* The easy way to start out if you would like to avoid building is to just take a nightly (or release) .xpi from the gdata provider, unpack it into a directory and then create a file named after the extension id (as seen in em:id in the install.rdf which is in the xpi) in your profile/extensions/ directory.

* The API is described at <http://code.google.com/apis/gdata/docs/1.0/reference.html>, note I am using the old version of the API.

* You will want to find out what needs to be posted when modifying an item to make sure you don't get an access denied error. This will likely be things like the generation that I set on the item, or maybe another extended property that can't be set. Try removing them one by one to see if its possible to change an item you don't own. 

* If you need ad-hoc help, you can find me on irc.mozilla.org, channel #calendar.
Assignee: nobody → mozilla-bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Eric, it looks like you have no interest to work on this?
(Reporter)

Comment 3

6 years ago
(In reply to Philipp Kewisch [:Fallen] (away until May 28th) from comment #2)
> Eric, it looks like you have no interest to work on this?

I wish I had the bandwidth, but I don't see it happening in the near future.
Ok, if you do find time, please let us know.
Assignee: mozilla-bugs → nobody
Whiteboard: [needs updated patch]
Status: ASSIGNED → NEW
Duplicate of this bug: 799505
There has been a major rewrite of the Provider for Google Calendar between version 0.32 and 1.0. A vast number of bugs have been fixed during this rewrite, therefore I am closing lots of old bugs that I think might either be fixed or no longer apply to the latest version.

Please read the updated FAQ [1] for details on known issues. If you can reproduce your issue with the latest version of the Provider for Google Calendar and you can't find an existing bug that handles your case, please reopen this issue.

Thank you for your understanding.

[1] https://wiki.mozilla.org/Calendar:GDATA_Provider
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 7

4 years ago
I am still affected by this bug (Lightning 2.6.6, Provider 1.0.2). So please reopen it.
Whiteboard: [needs updated patch]

Comment 8

4 years ago
I'm still seeing this. Please reopen.
Lightning 3.3.1
Provider for Google Calendar 1.0.2
Flags: needinfo?(philipp)
What happens is likely the same error message as in bug 1101175.
Status: RESOLVED → REOPENED
Flags: needinfo?(philipp)
Resolution: WORKSFORME → ---
Please check out the xpi in bug 1101175 and check if it works
Duplicate of this bug: 1112530
New xpi to check out in bug 1123720. Closing INCOMPLETE pending a reply, hope its fixed by now.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.