If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Only list free webapps/add-ons in the dropdown box for upsell settings

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Developer Pages
P4
normal
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: krupa, Assigned: andym)

Tracking

Details

(Whiteboard: [webapps], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Load https://addons-dev.allizom.org/en-US/developers/addon/app-337450/payments/3
2. Notice the options available in the dropdown menu.

expected behavior:
Only free webapps are listed.

actual behavior:
paid webapps and add-ons are listed.
(Assignee)

Comment 1

6 years ago
Can't reproduce yet, locally on -dev and in tests only free addons are shown.
(Assignee)

Updated

6 years ago
Assignee: nobody → amckay
(Reporter)

Comment 2

6 years ago
I see this http://screencast.com/t/Nmkp8FuaSh.

Andy, do you have disabled add-ons/paid webapps associated with the same account?
(Assignee)

Updated

6 years ago
Priority: -- → P4
(Reporter)

Comment 3

6 years ago
I can link mark an add-on as upsell to an app which seems wrong.
Summary: Only list free webapps in the dropdown box for upsell settings → Only list free webapps/add-ons in the dropdown box for upsell settings
Is this a dupe of bug 679824?
(Reporter)

Comment 5

6 years ago
Nope. This bug is about free apps and add-ons-> We shouldn't be listing premium or disabled add-ons/apps in upsell dropdown. The other bug is about not listing add-ons with contributions.
(Reporter)

Comment 6

6 years ago
Note https://apps-preview-dev.allizom.org/en-US/apps/app/goofy/?src=cb-dl-home is marked as upsell for "DuckSauce" when both are premium apps. This seems bad. Is this bug still P4?
(Reporter)

Comment 7

6 years ago
Created attachment 579940 [details]
screenshot
(In reply to krupa raj 82[:krupa] from comment #6)
> Note
> https://apps-preview-dev.allizom.org/en-US/apps/app/goofy/?src=cb-dl-home is
> marked as upsell for "DuckSauce" when both are premium apps. This seems bad.
> Is this bug still P4?

If no one else can reproduce it, yeah.
Blocks: 710074
No longer blocks: 690899
(Assignee)

Comment 9

6 years ago
The only way I can reproduce this is by making an addon the target of an upsell and then making that addon premium. Will stop this.
(Assignee)

Comment 10

6 years ago
https://github.com/mozilla/zamboni/commit/9b8365
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.