Last Comment Bug 693968 - (stix-1.1) Add Support for STIX fonts 1.1
(stix-1.1)
: Add Support for STIX fonts 1.1
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: All All
: P5 normal with 2 votes (vote)
: mozilla31
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 407059 947650
Blocks: 947654
  Show dependency treegraph
 
Reported: 2011-10-12 04:37 PDT by Frédéric Wang (:fredw)
Modified: 2014-04-25 00:47 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Frédéric Wang (:fredw) 2011-10-12 04:37:48 PDT

    
Comment 1 Frédéric Wang (:fredw) 2011-10-13 12:15:35 PDT
STIX Fonts 1.1 Beta has been released. I open this bug to prepare support for the final version. The zip archive has two folders:

- STIX-General/, which contains the 29 fonts from STIX 1.0. Some file names seem to have changed, but fortunately not those we use in our *.properties files (STIXGeneral, STIXNonUnicode, STIXSizeTwoSym, STIXSizeThreeSym, STIXSizeFourSym, STIXSizeFiveSym, STIXIntegralsD).

- STIX-Word/, which contains STIX-Bold.otf, STIX-BoldItalic.otf, STIX-Regular.otf, STIX-Italic.otf and the font used for operator stretching STIXMath-Regular.otf. This one has a MATH table that we could read when bug 407059 is fixed.

Other changes mentioned in the doc:

• (02B2) The height has been adjusted 
• (02F7) Symbol has been added 
• (02C6, 02C7, 02DC, 02F7) Width has been added 
• (203E) Upright and italic glyphs adjusted 
• (1D730, 1D6F6) Glyphs enhanced 
• (Bold Blackboard Characters) Moved from the PUA to STIXGeneralBold. (2145-­‐2149) were removed and added to the 1D5xx range. 
• (2219) Diminished the difference in size between the light and bold bullet operator 
• (22C0-­‐22C3) Bold shapes created and added to STIXGeneralBold 
• (20EC, 20ED) Characters in STIXGeneralItalic have been moved below the baseline 
• (2145-­‐2149) Removed 
• (22D2, 22D3) These have been swapped 
• (22FF) Shape has been altered 
• (23DC-­‐23E1) Altered to diminish distortion when stretched 
• (29BF) Glyph enhanced 
• (2AFC, 2AFF) Text sizes created in STIXGeneral. 2AFF added to STIXSize2Symbols 
• (E335, E37B) Corrected position in STIXNonUniBolIta 
• (E387, E388) The shape of \midbaritlambda has been made equal to \lambdabar in STIXNonUniIta and STIXNonUniBolIta 
• (1DA3/E041,1D8/E042,0347/E060,27CB/E09F,27CD/E0A0,A792/E0A1,26E2/E0E4) Moved from PUA to STIXGeneral. 
• (E0387) Bold center dot removed from PUA
• (0347/E060, A792/E0A1) Moved from PUA to STIXGeneralBold.
Comment 2 will69 2011-10-24 07:42:40 PDT
The 29 old fonts from the STIX-General folder clutter up the Word font family drop-down menu, or even worse, produce a wide visible gap, because they don't contain all the glyphs necessary for preview. Would it be possible to use the five fonts from the new STIX-Word folder only? This would produce only two (readable) entries in the Word fonts drop-down menu.
Comment 3 Karl Tomlinson (:karlt) 2011-10-26 15:12:30 PDT
I don't see cmap entries for the variant sizes in the STIX Math family, so we'd need bug 407059 fixed to use that.  (XITS Math is similar)
Comment 4 will69 2012-03-01 02:54:09 PST
STIX Fonts 1.1 have been released.
Comment 5 Frédéric Wang (:fredw) 2014-04-25 00:47:37 PDT
I'm closing all these font-specific meta bug since the main work has been done in bug 407059 and bug 947650. Remaining issues will be handled on the OpenType MATH bugs.

Once bug 1000879 is merged, one will be able to verify the initial OpenType MATH support with the MathML torture test:
https://developer.mozilla.org/en-US/docs/Mozilla/MathML_Project/MathML_Torture_Test

Note You need to log in before you can comment on or make changes to this bug.