If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

javascript prompt() uses 100% cpu

VERIFIED DUPLICATE of bug 61590

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 61590
17 years ago
17 years ago

People

(Reporter: Daniel J. Peng, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
In Mozilla 0.7 and 0.8, CPU utilization jumps to 100% when the javascript
prompt() dialog is open.  Just open up the URL and watch your CPU utilization
skyrocket.

Comment 1

17 years ago
Browser, not engine. Reassigning to XP Toolkit/Widgets for further triage - 
not sure if that is the appropriate component, either.

Confirming with Mozilla 2001-12-19-xx on Linux. CPU is pinned at 100%
on prompt(), alert(), and confirm(). 


COMPARISONS 

I should note that on the same Linux box, NN4.7 also uses 100% CPU 
for prompt() and confirm(). But not alert(), which spikes at 100% 
but then comes down.

Mozilla 2001-02-19-xx on my WinNT box uses spikes at 30% CPU on these,
and then goes down to 1%. So this may be Linux-specific -
Assignee: rogerl → trudelle
Status: UNCONFIRMED → NEW
Component: Javascript Engine → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: pschwartau → jrgm

Comment 2

17 years ago
Sorry, that was 2001-02-19-xx on Linux ...
Duplicate of 'Modal "OK" warning windows eat CPU - see trace'

*** This bug has been marked as a duplicate of 61590 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Marking Verified Duplicate - 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.