If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Modal "OK" warning windows eat CPU - see trace

RESOLVED DUPLICATE of bug 56978

Status

()

Core
XUL
P3
normal
RESOLVED DUPLICATE of bug 56978
17 years ago
16 years ago

People

(Reporter: John Hayward-Warburton, Assigned: Dan M)

Tracking

Trunk
mozilla1.0
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When a modal window (such as "The connection was refused when attempting to
contact...") appears on Linux, the browser loops through this:

poll([{fd=8, events=POLLIN}, {fd=15, events=POLLIN}, {fd=5, events=POLLIN,
revents=POLLIN}, {fd=36, events=POLLIN}], 4, 0) = 1
gettimeofday({975585802, 671095}, NULL) = 0
ioctl(8, FIONREAD, [0])                 = 0

while waiting for "OK" to be clicked. This has been seen on my system for a
while, but latest is nightly 2000112821.

Comment 1

17 years ago
very related to bug 56978, but this observation isn't included there.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
->danm
Assignee: trudelle → danm
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla1.0
*** Bug 69443 has been marked as a duplicate of this bug. ***
This happens for all Javascript prompt(), alert(), and confirm() dialogs.
*** Bug 69622 has been marked as a duplicate of this bug. ***
*** Bug 77162 has been marked as a duplicate of this bug. ***
I think this is a duplicate of bug 56978
bug 56978 just got fixed.  Please retest this?  (no mozilla here at the moment)
Looks good.  prompt(), alert(), confirm() dialogs no longer hog CPU.

Marking duplicate.

*** This bug has been marked as a duplicate of 56978 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.