JavaScript benchmarks regression 50% slower

RESOLVED DUPLICATE of bug 694527

Status

()

defect
RESOLVED DUPLICATE of bug 694527
8 years ago
8 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/6d5fd5a30c71
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111015 Firefox/10.0a1 ID:20111015031037

Reproducible: Always

Steps to Reproduce:
1. Start Firefox with clean profile
2  Open URL http://www.webkit.org/perf/sunspider-0.9.1/sunspider-0.9.1/driver.html


RESULTS SunSpider 0.9.1 on m-c hourly:
http://hg.mozilla.org/mozilla-central/rev/9545b88eed82
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014030948
281.0ms
http://hg.mozilla.org/mozilla-central/rev/ca73f057dab7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014030040
279.1ms
http://hg.mozilla.org/mozilla-central/rev/68799855e853
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014053038
280.5ms
http://hg.mozilla.org/mozilla-central/rev/349f3d4b2d87
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014073836
375.6ms
http://hg.mozilla.org/mozilla-central/rev/921f44191dcb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014105639
375.8ms
http://hg.mozilla.org/mozilla-central/rev/45ac18984273
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014111438
374.8ms
http://hg.mozilla.org/mozilla-central/rev/6d5fd5a30c71
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111015 Firefox/10.0a1 ID:20111015031037
369.1ms

Pushlog;
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=68799855e853&tochange=349f3d4b2d87




RESULTS SunSpider 0.9.1 on m-i hourly:
http://hg.mozilla.org/integration/mozilla-inbound/rev/5f16d668ce5a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111013 Firefox/10.0a1 ID:20111013172738
280.0ms
http://hg.mozilla.org/integration/mozilla-inbound/rev/d2a037d0354d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111013 Firefox/10.0a1 ID:20111013193438
279.6ms
http://hg.mozilla.org/integration/mozilla-inbound/rev/aa2e380c86fb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111013 Firefox/10.0a1 ID:20111013221339
285.7ms
http://hg.mozilla.org/integration/mozilla-inbound/rev/56c7568767f1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014001038
279.3ms
http://hg.mozilla.org/integration/mozilla-inbound/rev/6715771c1d9a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014005938
280.3ms
http://hg.mozilla.org/integration/mozilla-inbound/rev/4b87afed1d1c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014023738
281.2ms
http://hg.mozilla.org/integration/mozilla-inbound/rev/61dd23c012ee
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014031339
371.9ms
http://hg.mozilla.org/integration/mozilla-inbound/rev/d50bd6d5b097
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014032038
370.8ms

Pushlog;
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4b87afed1d1c&tochange=61dd23c012ee

Triggered by:
61dd23c012ee	Chris Leary — Bug 673188: Compile regexps lazily. (r=mrbkap)
(Reporter)

Comment 1

8 years ago
On latest Nightly hourly build
http://hg.mozilla.org/mozilla-central/rev/3b58a9df4c8c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111015 Firefox/10.0a1 ID:20111015042139
282.9ms

This was fixed by Bug 694527
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 694527
You need to log in before you can comment on or make changes to this bug.