Last Comment Bug 694801 - VC11 fails to compile angle because pool_allocator<T> doesn't have operator =
: VC11 fails to compile angle because pool_allocator<T> doesn't have operator =
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: :Ehsan Akhgari
:
: Milan Sreckovic [:milan]
Mentors:
: 687268 (view as bug list)
Depends on: 709369
Blocks: VC11
  Show dependency treegraph
 
Reported: 2011-10-15 17:24 PDT by :Ehsan Akhgari
Modified: 2011-12-09 15:33 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (5.89 KB, patch)
2011-10-15 17:46 PDT, :Ehsan Akhgari
jacob.benoit.1: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2011-10-15 17:24:14 PDT

    
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2011-10-15 17:35:14 PDT
I dont have VC11 at the moment so I can hardly make a patch, but if you do make a patch I'll drive it in ANGLE upstream.
Comment 2 :Ehsan Akhgari 2011-10-15 17:46:08 PDT
Created attachment 567310 [details] [diff] [review]
Patch (v1)

I had to convert the reference member to a pointer in order to be able to assign to it inside operator=.

I will look into upstreaming this fix.
Comment 3 :Ehsan Akhgari 2011-10-15 21:21:27 PDT
*** Bug 687268 has been marked as a duplicate of this bug. ***
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2011-10-19 07:13:19 PDT
Comment on attachment 567310 [details] [diff] [review]
Patch (v1)

Review of attachment 567310 [details] [diff] [review]:
-----------------------------------------------------------------

Just add a mention of the ANGLE revision number in README.mozilla.
Comment 6 Marco Bonardo [::mak] 2011-10-20 02:58:07 PDT
https://hg.mozilla.org/mozilla-central/rev/1cd13969b61e

Note You need to log in before you can comment on or make changes to this bug.