Last Comment Bug 709369 - Firefox 9 emergency: update ANGLE to the same version used in Firefox 10
: Firefox 9 emergency: update ANGLE to the same version used in Firefox 10
Status: VERIFIED FIXED
[qa!][qa!:9]
: verified-beta
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Benoit Jacob [:bjacob] (mostly away)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks: 690735 694801 696889 697333
  Show dependency treegraph
 
Reported: 2011-12-09 15:33 PST by Benoit Jacob [:bjacob] (mostly away)
Modified: 2011-12-28 06:52 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments

Description Benoit Jacob [:bjacob] (mostly away) 2011-12-09 15:33:15 PST
The Google Maps team is reporting to us that they many reports from users that the WebGL-enabled version of Google Maps, in Firefox 8 and 9, is crashing certain versions of the Intel Direct3D driver on Windows.

The interesting thing is that this problem doesn't exist in Firefox >= 10 and in Chrome. It's possible that something in ANGLE changes that makes us not tickle this driver bug anymore. It's possible that this is ANGLE r807.

Can I get approval to update mozilla-beta's ANGLE to the same version that is used in mozilla-aurora? That means backporting:

changeset:   79001:83d9a9bfa6bd
tag:         angle4
user:        Benoit Jacob <bjacob@mozilla.com>
date:        Wed Nov 02 00:56:35 2011 -0400
summary:     Bug 697333 - Update ANGLE to r809 - no review

changeset:   79000:86958303da30
tag:         angle3
user:        Benoit Jacob <bjacob@mozilla.com>
date:        Tue Oct 25 08:58:43 2011 -0400
summary:     Bug 696889 - Upgrade ANGLE to r802 - no review

changeset:   78999:9c15a57d8be1
tag:         angle2
user:        Ehsan Akhgari <ehsan@mozilla.com>
date:        Wed Oct 19 10:17:02 2011 -0400
summary:     Bug 694801 - VC11 fails to compile angle because pool_allocator<T> doesn't have operator =; r=bjacob

changeset:   78998:1f06daff6343
tag:         angle1
tag:         qbase
user:        Benoit Jacob <bjacob@mozilla.com>
date:        Sat Oct 01 00:03:10 2011 -0400
summary:     Bug 690735 - upgrade ANGLE to r774 - no review, just syncing with upstream



Tryserver push:
https://tbpl.mozilla.org/?tree=Try&rev=dc42bce13fd6
Comment 1 Alex Keybl [:akeybl] 2011-12-12 13:51:47 PST
[Triage Comment]
Approving for beta with the understanding that we can still back this out before building from release if we find any major regressions. We don't normally take such large patches at this point in beta, but given the

* user effect
* alternative options
* (low) record of regression
* bake time on FF10

we've decided to take the FF10 ANGLE on FF9 beta.
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2011-12-12 13:57:14 PST
This is correct, we will be able to back this out if we need to.
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2011-12-12 15:27:18 PST
http://hg.mozilla.org/releases/mozilla-beta
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2011-12-12 15:27:34 PST
http://hg.mozilla.org/releases/mozilla-beta/rev/d79906a35a2a
Comment 5 Vlad [QA] 2011-12-16 01:24:55 PST
Hi guys.
Can you advice me how to test this issue?

Thanks
Comment 6 Benoit Jacob [:bjacob] (mostly away) 2011-12-16 04:57:24 PST
On Windows, in about:support, the WebGL Renderer line should mention 809 somewhere in the ANGLE version number. If it mentioned 740 instead, that would mean that the update didn't take place.
Comment 7 Vlad [QA] 2011-12-16 06:32:15 PST
I have verified this using the steps from comment6 on:

Mozilla/5.0 (Windows NT 6.1; rv:9.0) Gecko/20100101 Firefox/9.0 beta 6 and the issue is fixed:

WebGL RendererGoogle Inc. -- ANGLE (NVIDIA GeForce 210) -- OpenGL ES 2.0 (ANGLE 0.0.0.809)

Setting resolution to Verified Fixed on Beta.
Comment 8 Vlad [QA] 2011-12-28 06:29:10 PST
Verified also on:
Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

Setting resolution to Verified Fixed - see also comment7

Note You need to log in before you can comment on or make changes to this bug.