The default bug view has changed. See this FAQ.

Dragging tabs over blank thumbnails leaves traces over it

RESOLVED FIXED in Firefox 11

Status

Firefox Graveyard
Panorama
RESOLVED FIXED
6 years ago
11 months ago

People

(Reporter: Eric Sh., Assigned: raymondlee)

Tracking

Trunk
Firefox 11

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111015 Firefox/10.0a1
Build ID: 20111015123308

Steps to reproduce:

Dragging a tab over an unloaded tab(with "Don't load until selected" checked) leaves ugly traces over the preview.



Expected results:

The previews for unloaded tabs should be filled with a solid color.

Updated

6 years ago
Component: General → Panorama
QA Contact: general → panorama
Version: 10 Branch → Trunk
Eric, can you please provide a screencast or screenshot of the issue? I couldn't reproduce this on my machine so far.
(Reporter)

Comment 2

6 years ago
Created attachment 567467 [details]
Example of the drawing bug

The two tabs n the left are "unloaded".
Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111019 Firefox/10.0a1

I tried this both on Windows 7 and XP, but couldn't reproduce so far.

Even with the pref set, Panorama still displays thumbnails for tabs in groups after restarting Firefox. At least on my end. When a tab thumbnail wasn't displayed (blank tab) I could still drag tabs over the thumbnail without any graphical corruptions happening.

STR:
1. Start Firefox Nightly.
2. From Options-general select Show my windows and tabs from last time.
3. Select the "Don't load tabs until selected" preference.
4. Create 3 groups in Panorama, each with a couple of tabs.
5. Close and restart firefox.
6. Drag a tab over a blank tab thumbnail.


Like I wrote above, I can't trigger any blank tabs as in Eric's screenshot.

Could you provide any other information on this, Eric?

Have you tried reproducing under a clean profile? http://support.mozilla.com/en-US/kb/Managing-profiles
(Reporter)

Comment 4

6 years ago
I have successfully reproduced this in latest nightly using a clean profile, after step 4 clear firefox's cache(Network -> Clear Cache) and then do step 5.

If taht also doesn't ork then try restarting, clearing cache and then restarting again :)
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111021 Firefox/10.0a1

I can confirm this, but there is no need in the end to check "Don't load until selected" if clearing the cache.

STR:
1. Start Firefox with a clean profile.
2. Create two groups of at least 2 tabs each in Panorama.
3. Set "Show my windows and tabs from last time" in Preferences/Options.
4. Clear Cache.
5. Close and restart Firefox.
6. Enter Panorama and drag a tab over a blank thumbnail.

Firefox 4 also displays this issue if using the same profile as in F10 (with cleared cache-to create blank thumbnails). Dragging over blank tabs draws temporary lines over it. However, dropping the dragged tab, re-initializes the thumbnail to its blank state.

Tim can say if this can be improved or not, so I'll just let the bug to unconfirmed at the moment.
OS: Windows XP → All
Hardware: x86 → All
(Reporter)

Comment 6

6 years ago
(In reply to Virgil Dicu [QA] from comment #5)
> Tim can say if this can be improved or not, so I'll just let the bug to
> unconfirmed at the moment.

If you just draw a white rectangle over those places instead of nothing this can be fixed quickly.

And a thing like this must be a bug - which is something that shouldn't happen.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Panorama drawing problem with "Don't load until selected" → Dragging tabs over blank thumbnails leaves traces over it
(Assignee)

Comment 7

5 years ago
Created attachment 575816 [details] [diff] [review]
v1
Assignee: nobody → raymond
Status: NEW → ASSIGNED
Attachment #575816 - Flags: review?(ttaubert)
(Assignee)

Comment 8

5 years ago
(In reply to Raymond Lee [:raymondlee] from comment #7)
> Created attachment 575816 [details] [diff] [review] [diff] [details] [review]
> v1

Passed Try
https://tbpl.mozilla.org/?tree=Try&rev=82cd4b6c7eb5
Comment on attachment 575816 [details] [diff] [review]
v1

Review of attachment 575816 [details] [diff] [review]:
-----------------------------------------------------------------

Alas, I can't reproduce that. Please make sure this fixes the issue :) Looks good, thanks!
Attachment #575816 - Flags: review?(ttaubert) → review+
(Assignee)

Comment 10

5 years ago
Created attachment 576404 [details] [diff] [review]
Patch for checkin
Attachment #575816 - Attachment is obsolete: true
(Assignee)

Comment 11

5 years ago
(In reply to Tim Taubert [:ttaubert] from comment #9)
> Comment on attachment 575816 [details] [diff] [review] [diff] [details] [review]
> v1
> 
> Review of attachment 575816 [details] [diff] [review] [diff] [details] [review]:
> -----------------------------------------------------------------
> 
> Alas, I can't reproduce that. Please make sure this fixes the issue :) Looks
> good, thanks!

The patch works for me on Mac.
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/2c0174077ab7
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/2c0174077ab7
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 11
(Reporter)

Comment 14

5 years ago
Thanks to everyone helping fix this!
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.