Last Comment Bug 694821 - Dragging tabs over blank thumbnails leaves traces over it
: Dragging tabs over blank thumbnails leaves traces over it
Status: RESOLVED FIXED
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: -- normal
: Firefox 11
Assigned To: Raymond Lee [:raymondlee]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-15 23:38 PDT by Eric Sh.
Modified: 2016-04-12 14:00 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Example of the drawing bug (12.63 KB, image/png)
2011-10-17 09:02 PDT, Eric Sh.
no flags Details
v1 (1.47 KB, patch)
2011-11-20 23:53 PST, Raymond Lee [:raymondlee]
ttaubert: review+
Details | Diff | Splinter Review
Patch for checkin (1.51 KB, patch)
2011-11-22 21:22 PST, Raymond Lee [:raymondlee]
no flags Details | Diff | Splinter Review

Description Eric Sh. 2011-10-15 23:38:44 PDT
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111015 Firefox/10.0a1
Build ID: 20111015123308

Steps to reproduce:

Dragging a tab over an unloaded tab(with "Don't load until selected" checked) leaves ugly traces over the preview.



Expected results:

The previews for unloaded tabs should be filled with a solid color.
Comment 1 Tim Taubert [:ttaubert] 2011-10-17 02:05:42 PDT
Eric, can you please provide a screencast or screenshot of the issue? I couldn't reproduce this on my machine so far.
Comment 2 Eric Sh. 2011-10-17 09:02:08 PDT
Created attachment 567467 [details]
Example of the drawing bug

The two tabs n the left are "unloaded".
Comment 3 Virgil Dicu [:virgil] [QA] 2011-10-19 08:20:00 PDT
Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111019 Firefox/10.0a1

I tried this both on Windows 7 and XP, but couldn't reproduce so far.

Even with the pref set, Panorama still displays thumbnails for tabs in groups after restarting Firefox. At least on my end. When a tab thumbnail wasn't displayed (blank tab) I could still drag tabs over the thumbnail without any graphical corruptions happening.

STR:
1. Start Firefox Nightly.
2. From Options-general select Show my windows and tabs from last time.
3. Select the "Don't load tabs until selected" preference.
4. Create 3 groups in Panorama, each with a couple of tabs.
5. Close and restart firefox.
6. Drag a tab over a blank tab thumbnail.


Like I wrote above, I can't trigger any blank tabs as in Eric's screenshot.

Could you provide any other information on this, Eric?

Have you tried reproducing under a clean profile? http://support.mozilla.com/en-US/kb/Managing-profiles
Comment 4 Eric Sh. 2011-10-19 14:14:58 PDT
I have successfully reproduced this in latest nightly using a clean profile, after step 4 clear firefox's cache(Network -> Clear Cache) and then do step 5.

If taht also doesn't ork then try restarting, clearing cache and then restarting again :)
Comment 5 Virgil Dicu [:virgil] [QA] 2011-10-21 08:44:20 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111021 Firefox/10.0a1

I can confirm this, but there is no need in the end to check "Don't load until selected" if clearing the cache.

STR:
1. Start Firefox with a clean profile.
2. Create two groups of at least 2 tabs each in Panorama.
3. Set "Show my windows and tabs from last time" in Preferences/Options.
4. Clear Cache.
5. Close and restart Firefox.
6. Enter Panorama and drag a tab over a blank thumbnail.

Firefox 4 also displays this issue if using the same profile as in F10 (with cleared cache-to create blank thumbnails). Dragging over blank tabs draws temporary lines over it. However, dropping the dragged tab, re-initializes the thumbnail to its blank state.

Tim can say if this can be improved or not, so I'll just let the bug to unconfirmed at the moment.
Comment 6 Eric Sh. 2011-10-21 11:00:27 PDT
(In reply to Virgil Dicu [QA] from comment #5)
> Tim can say if this can be improved or not, so I'll just let the bug to
> unconfirmed at the moment.

If you just draw a white rectangle over those places instead of nothing this can be fixed quickly.

And a thing like this must be a bug - which is something that shouldn't happen.
Comment 7 Raymond Lee [:raymondlee] 2011-11-20 23:53:36 PST
Created attachment 575816 [details] [diff] [review]
v1
Comment 8 Raymond Lee [:raymondlee] 2011-11-21 10:07:04 PST
(In reply to Raymond Lee [:raymondlee] from comment #7)
> Created attachment 575816 [details] [diff] [review] [diff] [details] [review]
> v1

Passed Try
https://tbpl.mozilla.org/?tree=Try&rev=82cd4b6c7eb5
Comment 9 Tim Taubert [:ttaubert] 2011-11-22 21:05:05 PST
Comment on attachment 575816 [details] [diff] [review]
v1

Review of attachment 575816 [details] [diff] [review]:
-----------------------------------------------------------------

Alas, I can't reproduce that. Please make sure this fixes the issue :) Looks good, thanks!
Comment 10 Raymond Lee [:raymondlee] 2011-11-22 21:22:15 PST
Created attachment 576404 [details] [diff] [review]
Patch for checkin
Comment 11 Raymond Lee [:raymondlee] 2011-11-22 21:23:58 PST
(In reply to Tim Taubert [:ttaubert] from comment #9)
> Comment on attachment 575816 [details] [diff] [review] [diff] [details] [review]
> v1
> 
> Review of attachment 575816 [details] [diff] [review] [diff] [details] [review]:
> -----------------------------------------------------------------
> 
> Alas, I can't reproduce that. Please make sure this fixes the issue :) Looks
> good, thanks!

The patch works for me on Mac.
Comment 12 Tim Taubert [:ttaubert] 2011-11-24 17:20:03 PST
https://hg.mozilla.org/integration/fx-team/rev/2c0174077ab7
Comment 13 Tim Taubert [:ttaubert] 2011-11-29 21:51:14 PST
https://hg.mozilla.org/mozilla-central/rev/2c0174077ab7
Comment 14 Eric Sh. 2011-11-30 00:46:29 PST
Thanks to everyone helping fix this!

Note You need to log in before you can comment on or make changes to this bug.