Caller ID from Mozilla says "CALIFORNIA" instead of "Mozilla"

RESOLVED WORKSFORME

Status

Infrastructure & Operations
Telecom
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Benjamin Smedberg, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
When people call me from the Mozilla phone system or when I call people from my MoCo voip line, the caller ID says "CALIFORNIA" instead of "Mozilla". Since caller IDs of this form are very commonly used by telemarketers and political robocallers, I'd really like the caller ID to say "Mozilla" instead.

Updated

6 years ago
Severity: normal → enhancement

Updated

6 years ago
Assignee: server-ops-telecom → ravi
This is a bug not an enhancement.  We're setting "Mozilla Corporation" on the way out.  This means the phone company is overriding it.  (they didn't used to).
Severity: enhancement → normal
Default Route appears to go to Telepacific currently.
OK, Telepacific doesn't let us set a name, we can only set the number going out through them.  I can't reproduce this though.  I've tried setting the outgoing ID to our main number as well as a random sampling of our 650 area code DID numbers, and I'm always getting "MOZILLA CORP" on the receiving end for the name.
Assignee: ravi → justdave

Comment 4

6 years ago
The receiving carrier will do a LIDB lookup.  The DB is populated by the LEC who provides us service.  If the receiving carrier doesn't have access to the DB where our record is the lookup will fail and the label will default to the originating state (California).  Individual carriers can also filter it along the way.

If we can verify it is correctly displaying on a carrier the probability that it is being filtered is very high and an equal probability of us getting that remote carrier to fix it.

If you have some ideas it's all yours.
Assignee: justdave → server-ops-telecom

Comment 5

6 years ago
Er, more like a very low probability of us getting that remote carrier to fix it.
FWIW, CallerID Name is not transmitted with the phone call on the PSTN.  It's generated by the recipient's local phone company from a national database prior to delivery to the last hop.  The only time the name we set is preserved is if the call is end-to-end VoIP.  The most likely case here is that your recipient's local phone company has an out-of-date copy of that database.
Assignee: server-ops-telecom → justdave
er, midair there, sorry.
Assignee: justdave → server-ops-telecom
And yeah, what Ravi said. :)
OK, based on my test calls all came through with MOZILLA CORP on the caller ID and Ravi's explanation about the way the fallback works on the recipient end, it's the fault of the recipient's phone company, and there's not really anything we can do about it.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.