Last Comment Bug 694954 - [highlighter] [infobar] If a node is not visible anymore, the infobar should point to the direction of the node
: [highlighter] [infobar] If a node is not visible anymore, the infobar should ...
Status: RESOLVED FIXED
[good first bug][mentor=paul][lang=js...
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: Firefox 12
Assigned To: Paul Rouget [:paul]
:
Mentors:
Depends on: 689939
Blocks: 663830
  Show dependency treegraph
 
Reported: 2011-10-17 05:22 PDT by Paul Rouget [:paul]
Modified: 2011-12-29 09:37 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (1.80 KB, patch)
2011-12-07 08:22 PST, Paul Rouget [:paul]
rcampbell: review+
Details | Diff | Splinter Review
patch v1.1 (3.73 KB, patch)
2011-12-19 08:19 PST, Paul Rouget [:paul]
rcampbell: review+
Details | Diff | Splinter Review
patch 2 (4.96 KB, patch)
2011-12-21 06:44 PST, Paul Rouget [:paul]
rcampbell: review+
Details | Diff | Splinter Review

Description Paul Rouget [:paul] 2011-10-17 05:22:46 PDT
The current behavior is to move the infobar to the top-right corner. It would make more sense to keep the infobar aligned with the node, and make it point to its direction.
Comment 1 Paul Rouget [:paul] 2011-12-07 08:22:05 PST
Created attachment 579696 [details] [diff] [review]
patch v1
Comment 2 Rob Campbell [:rc] (:robcee) 2011-12-09 07:47:54 PST
Comment on attachment 579696 [details] [diff] [review]
patch v1

I see what you did there.

Is this something we need a test for?
Comment 3 Jared Wein [:jaws] (please needinfo? me) 2011-12-11 00:16:26 PST
Assigning this to Paul as it appears that he is working on this. 

I'm trying to keep the status of our mentored bugs up to date. Please unassign if this was done in error.
Comment 4 Paul Rouget [:paul] 2011-12-19 08:19:05 PST
Created attachment 582834 [details] [diff] [review]
patch v1.1

with test
Comment 5 Rob Campbell [:rc] (:robcee) 2011-12-19 10:45:31 PST
-    let rect = this._highlightRect;
-    if (rect && this._highlighting) {
+    if (this._highlightRect) {
       let winHeight = this.win.innerHeight * this.zoom;
       let winWidth = this.win.innerWidth * this.zoom;
+
+      let rect = {top: this._highlightRect.top,
+                  left: this._highlightRect.left,
+                  width: this._highlightRect.width,
+                  height: this._highlightRect.height};

this didn't apply cleanly. Wondering if you had some other patch installed previously, as the let winHeight = … and winWidth lines were not there.

Added them.
Comment 6 Rob Campbell [:rc] (:robcee) 2011-12-19 10:55:22 PST
https://hg.mozilla.org/integration/fx-team/rev/8a9d9d0d3897
Comment 7 Tim Taubert [:ttaubert] 2011-12-20 00:55:21 PST
Backed out because of orange

https://hg.mozilla.org/integration/fx-team/rev/37b413b9c87b
Comment 8 Paul Rouget [:paul] 2011-12-21 06:44:44 PST
Created attachment 583479 [details] [diff] [review]
patch 2

So this should fix the test issue.
https://tbpl.mozilla.org/?tree=Try&rev=9e5579f7bb5e
Comment 9 Paul Rouget [:paul] 2011-12-21 09:23:00 PST
Apparently, this is working.
Comment 10 Rob Campbell [:rc] (:robcee) 2011-12-22 07:36:08 PST
Comment on attachment 583479 [details] [diff] [review]
patch 2

alright, let's try this again. :)
Comment 11 Rob Campbell [:rc] (:robcee) 2011-12-22 11:19:06 PST
https://hg.mozilla.org/integration/fx-team/rev/bb8833c7cbf9
Comment 12 Tim Taubert [:ttaubert] 2011-12-29 09:37:38 PST
https://hg.mozilla.org/mozilla-central/rev/bb8833c7cbf9

Note You need to log in before you can comment on or make changes to this bug.