Spacebar causes page down in textarea after F9

VERIFIED DUPLICATE of bug 5419

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 5419
17 years ago
17 years ago

People

(Reporter: Tim Powell, Assigned: kinmoz)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I'm seeing this in Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.8) Gecko/20010219.

This can be reproduced every time.
1. Collapse the sidebar to the left using the button on the splitter (I'm not
sure if it matters which tab is shown in the sidebar before it's collapsed. It
may need to be search).
2. Go to a bug in bugzilla
3. Start typing in the Additional Comments field.
4. Press F9 (hides the sidebar splitter)
5. Press F9 again (shows the sidebar splitter again).
6. Keep typing in the additional comments textarea.

Every space typed will scroll the page down.

It appears you can also reproduce this by doing the following:
1. Go to a bug in bugzilla.
2. With the sidebar open, switch to the search tab and click in the search box.
3. Press the button on the sidebar splitter to collapse the sidebar.
4. Click into the Additional Comments textarea and begin typing.

Actual Behavior: Every space typed will scroll the page down.
Expected: Spaces only show up in the textarea and do not scroll page.

Both of these are related to focus not being moved to entirely to the textarea
when it is clicked or the sidebar is hidden.

Workaround: You can stop the space scroll behavior by clicking on the page
(outside the textarea) and then clicking back into the textarea.

I'll be really surprised if this isn't a duplicate of a more general bug about
problems with focus switching. It's possible that this is a duplicate of bug
26882, but I can't quite decipher what that bug is about, so I thought I'd log
this one.
(Reporter)

Comment 1

17 years ago
Trying F9 with the sidebar not collapsed and set to the bookmarks tab also shows
some strange behavior. Hiding the sidebar with F9 works fine and you can keep
typing in the textarea. However, when you press F9 to show the sidebar again and
try to keep typing, characters are lost. I assume they're being directed to the
sidebar, but since the sidebar has no way to show input focus in this case, it
is pretty confusing, especially since the cursor remains in the textarea while
the bookmarks are loading.

I guess the main thing to note here is that it is unexpected for the sidebar to
steal focus when it is collapsed.
(Reporter)

Comment 2

17 years ago
It looks like this type of focus problem is showing up elsewhere. Perhaps this
is similar to Bug 68004?

Comment 3

17 years ago
I am going to pass this off to the editor group. it is a strange one.
Assignee: rods → beppe

Comment 4

17 years ago
assigning to kin for debug
Assignee: beppe → kin

Comment 5

17 years ago
updated qa contact
QA Contact: bsharma → vladimire

Updated

17 years ago
Blocks: 70812
(Assignee)

Comment 6

17 years ago
I'm unable to reproduce this bug using both methods you describe, in my 03/07/01
debug Win32 build.

This sounds like the elusive bug #5419 which has been around for a long long time.

*** This bug has been marked as a duplicate of 5419 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
Cannot reproduce with windows 98 build 2001-03-29-04-Mtrunk, and it does sound a
lot like the bug 5419. Verifying Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.