Allow opening event if invitation has already been processed

RESOLVED FIXED in 1.0

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Fallen, Assigned: Fallen)

Tracking

unspecified
x86
Mac OS X
Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
Created attachment 567656 [details] [diff] [review]
Fix - v1

Summary says it all, patch fixes. Too bad we are in string freeze.
Attachment #567656 - Flags: review?
(Assignee)

Updated

6 years ago
Attachment #567656 - Flags: review? → review?(bv1578)

Comment 1

6 years ago
You solved my part of bug #695247 with this. Thanks.
(Assignee)

Comment 2

6 years ago
I'd like to see this version of the patch for 1.0 if possible, Decathlon, do you have time for review this week?
Flags: blocking-calendar1.0+
Whiteboard: [needed beta][no l10n impact]

Comment 3

6 years ago
Unless I'm doing something wrong, this patch seems not working.

I sent an invitation from a Google calendar. After processed the event (accepted or declined), when I click on the "Open" button in the imip-bar, I get an empty summary dialog (it contains only two labels "General" and "Title:" and a separator).
The  error console reports:

Error: calendar is null
Source File: chrome://calendar/content/calendar-summary-dialog.js
Line: 87
(Assignee)

Comment 4

6 years ago
Created attachment 570969 [details] [diff] [review]
Fix - v2

Try this one, it should work better!
Attachment #567656 - Attachment is obsolete: true
Attachment #567656 - Flags: review?(bv1578)
Attachment #570969 - Flags: review?(bv1578)
(Assignee)

Comment 5

6 years ago
Pushed to comm-central changeset 034b7f135819
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
(Assignee)

Comment 6

6 years ago
Backported to releases/comm-aurora changeset 99fef5dc1a0e
Target Milestone: Trunk → 1.0b9
(Assignee)

Comment 7

6 years ago
Backported to releases/comm-beta changeset be53f3a1377d
Target Milestone: 1.0b9 → 1.0b8

Comment 8

6 years ago
Philipp, there's something wrong in the UI behavior.
I get a different information when I open the summary dialog from the "open" button in the imip-bar or when I open it by double clicking the event in the view.
After accepted the invitation, in the first case the dialog shows the item "I will confirm later" in the reply drop-down menu, instead in the second the item is "I will attend".
(Assignee)

Comment 9

6 years ago
Uhoh, thats not good. Let me check what going on, I was sure that I used the item retrieved from the getItem() call, but it seems not.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

6 years ago
Created attachment 571916 [details] [diff] [review]
Fix - v2.1

This patch applies on top of fix v2 and corrects that issue. It will be part of 1.0rc3 builds.
Attachment #571916 - Flags: review?(bv1578)
(Assignee)

Comment 11

6 years ago
comm-central changeset f0b2b1abfbd4
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: 1.0b8 → Trunk
(Assignee)

Comment 12

6 years ago
Backported to releases/comm-aurora changeset 43a28e66abc2
Target Milestone: Trunk → 1.0b9
(Assignee)

Comment 13

6 years ago
Backported to releases/comm-beta changeset af21343d6e4a
Target Milestone: 1.0b9 → 1.0b8

Comment 14

6 years ago
This works.
There is only a (minor) issue about the information updating given by the dialog: when you change the invitation reply from the dialog opened by the "open" button, the mail is sent (and the reply actually updated), but if you open again the dialog with the button, the reply still is in the previous status. You have to select another message then again your massage and clicking on the "open" button to see the new reply status.
The same doesn't happen by changing and opening the event in the view.


Another problem, not caused by this patch, is that when you answer to an invitation (accept/decline/tentative), the UI doesn't always ask the calendar where adding the event. Lightning often adds the event to the last used calendar without asking.
As far as you know, is it a known bug? I can't find it.
(Assignee)

Comment 15

6 years ago
(In reply to Decathlon from comment #14)
> This works.
> There is only a (minor) issue about the information updating given by the
> dialog: when you change the invitation reply from the dialog opened by the
> "open" button, the mail is sent (and the reply actually updated), but if you
> open again the dialog with the button, the reply still is in the previous
> status. You have to select another message then again your massage and
> clicking on the "open" button to see the new reply status.
> The same doesn't happen by changing and opening the event in the view.
I see. So we'd likely have the imip bar observe the item and see if it was changed. We definitely need better observers :-) Can you do me a favor and file a bug on this?



> Another problem, not caused by this patch, is that when you answer to an
> invitation (accept/decline/tentative), the UI doesn't always ask the
> calendar where adding the event. Lightning often adds the event to the last
> used calendar without asking.
> As far as you know, is it a known bug? I can't find it.
It is known, but I think its just bad UI. What happens is that if only one calendar is configured to the email address that was invited, we don't ask the user since it doesn't make sense to ask for just one calendar.

Possible solution:

* Make the add button a dropdown button so the user can pick the calendar in line. If there is just one calendar then there would also just be one in the dropdown.

* Add an item "Other Calendar..." that educates that the email address needs to be set up correctly and offer changing the setting for each calendar.

Maybe you could also file a bug on that.

Comment 16

6 years ago
I think this introduced bug #695247 ...

Comment 17

6 years ago
Sorry for the spam, it should be bug #707966

Updated

6 years ago
Attachment #570969 - Flags: review?(bv1578)

Updated

6 years ago
Attachment #570969 - Flags: review+

Comment 18

6 years ago
Comment on attachment 571916 [details] [diff] [review]
Fix - v2.1

r+ for both Fix - v2 and Fix - v2.1 together

From comment 0 it seems the text "Open" in the button should be different?


(In reply to Philipp Kewisch [:Fallen] from comment #15)
> I see. So we'd likely have the imip bar observe the item and see if it was
> changed. We definitely need better observers :-) Can you do me a favor and
> file a bug on this?

filed bug 720263
Attachment #571916 - Flags: review?(bv1578) → review+
Depends on: 707966

Comment 19

6 years ago
Just as a notice, this does not work with Conversations. I filled a bug at https://github.com/protz/GMail-Conversation-View/issues/574
You need to log in before you can comment on or make changes to this bug.