Last Comment Bug 695256 - Switch from PRBool to bool and replace PR_TRUE/PR_FALSE with true/false in comm-central
: Switch from PRBool to bool and replace PR_TRUE/PR_FALSE with true/false in co...
Status: RESOLVED FIXED
[good first bug]
:
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 12.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
: 108584 (view as bug list)
Depends on: 675553 690892
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 21:13 PDT by Philip Chee
Modified: 2012-09-30 01:14 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
PRBool replacement script for sed. (217 bytes, text/plain)
2011-12-29 10:13 PST, Mark Banner (:standard8)
no flags Details
PR_TRUE/FALSE replacement script for sed (128 bytes, text/plain)
2011-12-29 10:14 PST, Mark Banner (:standard8)
no flags Details
find & sed script for replacements (182 bytes, text/plain)
2011-12-29 10:18 PST, Mark Banner (:standard8)
mozilla: review+
Details

Description Philip Chee 2011-10-17 21:13:41 PDT
q.v. Mozilla Central bugs:
Bug 690892 - replace PR_TRUE/PR_FALSE with true/false in mozilla-central.
Bug 675553 - Switch from PRBool to bool on a CLOSED TREE.
Comment 1 Mark Banner (:standard8) 2011-10-18 01:36:07 PDT
I think considering this is just a script run against the repo, we should just do all of comm-central in one changeset and be done with it.
Comment 2 Justin Wood (:Callek) 2011-10-18 01:42:51 PDT
(In reply to Mark Banner (:standard8) from comment #1)
> I think considering this is just a script run against the repo, we should
> just do all of comm-central in one changeset and be done with it.

Sounds Good. You can do this if you like, with post-landing review from me if you want. And promise to spot-check first :-) (so hopefully we don't have in-tree-bustage)

(I just want to wait until the SeaMonkey buildbot master comes back up before landing it)
Comment 3 Mark Banner (:standard8) 2011-10-18 01:54:57 PDT
Well, I'd at least expect a run through try server first.
Comment 4 Mark Banner (:standard8) 2011-12-29 10:13:46 PST
Created attachment 584783 [details]
PRBool replacement script for sed.
Comment 5 Mark Banner (:standard8) 2011-12-29 10:14:19 PST
Created attachment 584785 [details]
PR_TRUE/FALSE replacement script for sed
Comment 6 Mark Banner (:standard8) 2011-12-29 10:18:52 PST
Created attachment 584790 [details]
find & sed script for replacements

I think whilst we're in this natural quiet period we should just get this done - afaik no big patches are pending, and they can always be patched - see the scripts on the dependent bugs.

These scripts are for OS X, replace <script> in this attachment with the name of the sed script from either of the other attachments.

I've pushed this to try as:

http://hg.mozilla.org/try-comm-central/rev/c60b80c3f05e

http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry&rev=c60b80c3f05e

If the builds are successful and pass tests, I'm proposing to push this to comm-central as soon as I can - I'll do a post to the newsgroups as well.
Comment 7 Tony Mechelynck [:tonymec] 2011-12-29 10:33:11 PST
In reply to comment #6:
IIUC, this covers Thunderbird and MailNews Core. What about SeaMonkey code not shared with Fx & Tb?
- this bug or another bug?
- covered yes/no by the sed scripts?
- covered yes/no by the try builds?
- tested yes/no after building?
Comment 8 David :Bienvenu 2011-12-29 11:32:00 PST
Comment on attachment 584790 [details]
find & sed script for replacements

I think this is just the find script, but it looks OK.
Comment 9 Mark Banner (:standard8) 2011-12-29 11:59:35 PST
(In reply to David :Bienvenu from comment #8)
> I think this is just the find script, but it looks OK.

Yes, see the other two attachments (sorry, I wasn't caring too much about individual reviews on each).

(In reply to Tony Mechelynck [:tonymec] from comment #7)
> In reply to comment #6:
> IIUC, this covers Thunderbird and MailNews Core. What about SeaMonkey code
> not shared with Fx & Tb?

This covers all of comm-central code apart from ldap/sdks/c-sdk which is imported from an external location, and would be up to the maintainers to change if they wanted to.
Comment 10 Mark Banner (:standard8) 2011-12-30 09:19:28 PST
I landed this earlier today, everything seems fine still:

http://hg.mozilla.org/comm-central/rev/f9d611e3d0a5
Comment 11 :Ms2ger (⌚ UTC+1/+2) 2012-09-30 01:14:25 PDT
*** Bug 108584 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.