Last Comment Bug 695665 - Remove instances of getMostRecentWindow from the script debugger
: Remove instances of getMostRecentWindow from the script debugger
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Panos Astithas [:past]
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks: minotaur
  Show dependency treegraph
 
Reported: 2011-10-19 06:11 PDT by Panos Astithas [:past]
Modified: 2011-10-19 09:04 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Simple fix (1.79 KB, patch)
2011-10-19 06:16 PDT, Panos Astithas [:past]
dcamp: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] 2011-10-19 06:11:35 PDT
There are a couple of places where we use windowMediator.getMostRecentWindow. This is not a good idea as suggested in bug 583041 comment 93, especially with e10s.
Comment 1 Panos Astithas [:past] 2011-10-19 06:16:01 PDT
Created attachment 568024 [details] [diff] [review]
Simple fix

It turns out the existing calls were not needed at all.

Note You need to log in before you can comment on or make changes to this bug.