intermittent tests/dom/indexedDB/test/test_leaving_page.html | This test left crash dumps behind, but we weren't expecting it to! (off mainthread abort)

RESOLVED DUPLICATE of bug 696362

Status

()

Core
DOM: IndexedDB
RESOLVED DUPLICATE of bug 696362
6 years ago
5 years ago

People

(Reporter: mak, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Looks like something is beeing destroyed on the wrong thread

https://tbpl.mozilla.org/php/getParsedLog.php?id=6965692&tree=Firefox

2524 INFO TEST-START | /tests/dom/indexedDB/test/test_objectCursors.html
TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_objectCursors.html | Exited with code -2147483645 during test run
INFO | automation.py | Application ran for: 0:01:34.700000
INFO | automation.py | Reading PID log: c:\users\cltbld\appdata\local\temp\tmpbyanm-pidlog
PROCESS-CRASH | /tests/dom/indexedDB/test/test_objectCursors.html | application crashed (minidump found)
Crash dump filename: c:\users\cltbld\appdata\local\temp\tmp8-y85t\minidumps\82ca2ede-93aa-463b-87a8-a5e41800e2b6.dmp
Operating system: Windows NT
                  6.1.7600 
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXCEPTION_BREAKPOINT
Crash address: 0x7275111b

Thread 33 (crashed)
 0  mozalloc.dll!mozalloc_abort(char const * const) [mozalloc_abort.cpp:edcd50167446 : 77 + 0x0]
    eip = 0x7275111b   esp = 0x1277f4f0   ebp = 0x1277f590   ebx = 0x00000040
    esi = 0x7284e457   edi = 0x7288a392   eax = 0x00000000   ecx = 0x7288a4c8
    edx = 0x00000001   efl = 0x00000206
    Found by: given as instruction pointer in context
 1  xul.dll!NS_DebugBreak_P [nsDebugImpl.cpp:edcd50167446 : 345 + 0x9]
    eip = 0x6c8e14d0   esp = 0x1277f4fc   ebp = 0x1277f590
    Found by: call frame info
 2  xul.dll!AbortIfOffMainThreadIfCheckFast [nsCycleCollector.cpp:edcd50167446 : 1278 + 0x17]
    eip = 0x6c8e3e10   esp = 0x1277f920   ebp = 0x1277f9ac   ebx = 0x038492e4
    Found by: call frame info
 3  xul.dll!nsCycleCollector::Suspect2(nsISupports *) [nsCycleCollector.cpp:edcd50167446 : 2491 + 0x4]
    eip = 0x6c8e45f6   esp = 0x1277f938   ebp = 0x1277f9ac
    Found by: call frame info
 4  xul.dll!NS_CycleCollectorSuspect2_P [nsCycleCollector.cpp:edcd50167446 : 3420 + 0x8]
    eip = 0x6c8e46af   esp = 0x1277f940   ebp = 0x1277f9ac
    Found by: call frame info
 5  xul.dll!nsCycleCollectingAutoRefCnt::decr(nsISupports *) [nsISupportsImpl.h:edcd50167446 : 211 + 0xa]
    eip = 0x6c1d58cd   esp = 0x1277f948   ebp = 0x1277f9ac
    Found by: call frame info
 6  xul.dll!nsDOMEventTargetHelper::Release() [nsDOMEventTargetHelper.cpp:edcd50167446 : 89 + 0x10]
    eip = 0x6c3d0ec5   esp = 0x1277f95c   ebp = 0x1277f9ac   ebx = 0x00000000
    Found by: call frame info
 7  xul.dll!mozilla::dom::indexedDB::OpenDatabaseHelper::~OpenDatabaseHelper() + 0xf
    eip = 0x6c4d0626   esp = 0x1277f96c   ebp = 0x1277f9ac
    Found by: call frame info
 8  xul.dll!mozilla::dom::indexedDB::OpenDatabaseHelper::Release() [OpenDatabaseHelper.cpp:edcd50167446 : 521 + 0x20]
    eip = 0x6c4d0683   esp = 0x1277f978   ebp = 0x1277f9ac
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 696362
(Reporter)

Updated

6 years ago
Depends on: 696362
(Reporter)

Updated

6 years ago
No longer depends on: 696362
Component: DOM → DOM: IndexedDB
Version: Trunk → unspecified
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.