Last Comment Bug 696362 - OpenDatabaseHelper's dtor can release objects on the wrong thread.
: OpenDatabaseHelper's dtor can release objects on the wrong thread.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13)
:
Mentors:
: 696338 (view as bug list)
Depends on:
Blocks: 687361
  Show dependency treegraph
 
Reported: 2011-10-21 06:21 PDT by Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13)
Modified: 2011-10-22 05:28 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (4.96 KB, patch)
2011-10-21 06:21 PDT, Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13)
no flags Details | Diff | Review
Patch (7.30 KB, patch)
2011-10-21 12:35 PDT, Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13)
bent.mozilla: review+
Details | Diff | Review

Description Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-10-21 06:21:04 PDT
Created attachment 568639 [details] [diff] [review]
Patch
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-10-21 10:12:15 PDT
*** Bug 696338 has been marked as a duplicate of this bug. ***
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-10-21 12:35:53 PDT
Created attachment 568741 [details] [diff] [review]
Patch

Something more like this, perhaps?
Comment 3 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-10-21 13:02:45 PDT
Comment on attachment 568741 [details] [diff] [review]
Patch

Review of attachment 568741 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/indexedDB/AsyncConnectionHelper.h
@@ +74,5 @@
>    HelperBase(IDBRequest* aRequest)
>      : mRequest(aRequest)
>    { }
>  
> +  ~HelperBase();

Definitely make this virtual.

@@ +197,5 @@
>     * Gives the subclass a chance to release any objects that must be released
>     * on the main thread, regardless of success or failure. Subclasses that
>     * implement this method *MUST* call the base class implementation as well.
>     */
> +   void ReleaseMainThreadObjects();

Why this change? Leave it virtual (aids understanding).
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-10-22 05:25:29 PDT
https://hg.mozilla.org/mozilla-central/rev/475896b92d6c
Comment 5 Marco Bonardo [::mak] 2011-10-22 05:27:51 PDT
I think bug 696338 was caused by this?
Comment 6 Marco Bonardo [::mak] 2011-10-22 05:28:38 PDT
ah sorry, missed the duping, somehow

Note You need to log in before you can comment on or make changes to this bug.