Compact Folders throws error message cmd_compactFolder. TypeError: this._resetThreadPane is not a function

RESOLVED FIXED in Thunderbird 12.0

Status

Thunderbird
Folder and Message Lists
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Alexander Bergmann, Assigned: Magnus Melin)

Tracking

({regression})

7 Branch
Thunderbird 12.0
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
If I try to compact all folders of the current account using "File -> Compact Folders", I get an error message in the Error Console of Thunderbird. (However, the actual compacting is done successfully.)

1. Create a New Profile
2. Add POP account
3. Select any folder, e.g. "Local Folders -> Outbox"
4. "File -> Compact Folders"
5. Open the Error Console ("Tools -> Error Console")

Error: An error occurred executing the cmd_compactFolder command: TypeError: this._resetThreadPane is not a function
Source File: chrome://global/content/globalOverlay.js
Line: 100

Arch Linux / Thunderbird 7.0.1

Comment 1

6 years ago
Confirming on linux, TB7 and TB8.
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Database
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: front-end → database
Version: unspecified → 7
Summary: Compact Folders throws error message cmd_compactFolder → Compact Folders throws error message cmd_compactFolder. TypeError: this._resetThreadPane is not a function

Comment 2

6 years ago
I couldn't find any declaration for the _resetThreadPane() function in the whole comm-central tree. 
The function is called from mail/base/content/folderPane.js line 2300. I don't know what it is supposed to do but the exception probably isn't intentional. Magnus Melin, it seems you merged that line into the file, can you find out what is it for?
(Assignee)

Comment 3

6 years ago
Looks like i only changed the indention (and such) - http://hg.mozilla.org/comm-central/diff/2f6ef8daa83e/mail/base/content/folderPane.js. I don't know what it's for. Maybe hg grep can tell... or then it was obsolete when i touched the code already.

Comment 4

6 years ago
I see now. Can you find out who put it there before? But maybe it is from the time before hg.
(Assignee)

Comment 5

6 years ago
Ok, so this is a regression from bug 474701 which removed that function - http://hg.mozilla.org/comm-central/diff/b0e37b312b54/mail/base/content/folderPane.js but forgot to remove it from this one place.
Assignee: nobody → mkmelin+mozilla
Blocks: 474701
Status: NEW → ASSIGNED
Component: Database → Folder and Message Lists
Keywords: regression
OS: Linux → All
Product: MailNews Core → Thunderbird
QA Contact: database → folders-message-lists
Hardware: x86 → All
(Assignee)

Comment 6

6 years ago
Created attachment 585128 [details] [diff] [review]
proposed fix

Remove it.
Attachment #585128 - Flags: review?(bugmail)
Comment on attachment 585128 [details] [diff] [review]
proposed fix

Oops!  Thanks for reporting this and thanks for the fix!
Attachment #585128 - Flags: review?(bugmail) → review+
(Assignee)

Comment 8

6 years ago
http://hg.mozilla.org/comm-central/rev/e358fbbcf194
->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 12.0

Comment 9

6 years ago
Had this been written in C, the compiler could have caught this.
Is there any such tool (static analysis) for Javascript code in Gecko? Or is it not possible to check for undefined functions in JS?
(In reply to :aceman from comment #9)
> Had this been written in C, the compiler could have caught this.
> Is there any such tool (static analysis) for Javascript code in Gecko? Or is
> it not possible to check for undefined functions in JS?

Joshua ?
You need to log in before you can comment on or make changes to this bug.