bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Create the combined my apps/add-ons page

RESOLVED FIXED in 6.2.9

Status

addons.mozilla.org Graveyard
Public Pages
P1
normal
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: clouserw, Assigned: Andy McKay)

Tracking

unspecified
6.2.9

Details

(Reporter)

Description

7 years ago
This page shows all your downloads and purchases together.  This bug also includes a mobile view.  If you just cook up a backend, Davor can help with the front end.

15:28 <@clouserw> fligtar: there is a bug filed for a 'my apps' page (694717).  We already have a "my purchases" page with apps+add-ons - is this a separate/new page just for apps?
15:28 <@clouserw> seems like we should just have a "my app/add-ons" page that includes everything you've downloaded, regardless of free/purchased
15:29 <@fligtar> yeah, should be the same page
15:31 <@clouserw> andym: does that make sense?
15:32 <andym> yeah should work
15:33 <andym> we should rename it from "my purchases" to ...?}
15:37 <@clouserw> fligtar: ?  I've got no good ideas
15:38 <@fligtar> My Downloads I guess
15:38 <@fligtar> if we're including free stuff
15:38 <@fligtar> actually, let's keep it as purchases for now
15:39 <@fligtar> even if we show free stuff
(Reporter)

Updated

7 years ago
Duplicate of this bug: 695534
(Reporter)

Updated

7 years ago
Duplicate of this bug: 694717
(Assignee)

Comment 3

7 years ago
Could we seperate out free and purchased in the UI? There's primarily a technical requirement that free are pulled from JS and purchased are pulled from Python. So things like pagination are things I'd like to avoid for the first pass.
(Reporter)

Comment 4

7 years ago
Let's do what you gotta do to get something out.  UX has office hours on Friday if someone doesn't chime in here with a design before then.
I do not think this page should depend on Jibe or our App Sync service, since those are designed to allow the user agent to store in the cloud a list of apps from all app stores and self-publishers. I don't think the user wants to give AMO access to all the apps they've gotten from other sources.
(Assignee)

Comment 6

7 years ago
https://github.com/mozilla/zamboni/commit/8f2403
https://github.com/mozilla/zamboni/commit/fd64c6
https://github.com/mozilla/zamboni/commit/840dad

We track the installs of free apps along with purchased apps or addons. Note I removed sorting by date to do this because I also changed the page to cope with multiple purchase, refunds and purchases. Can probably be put back in again with some fiddling.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.