Closed Bug 696639 Opened 8 years ago Closed 8 years ago

sort languages in font preferences according to the user interface language

Categories

(Firefox :: Preferences, defect)

9 Branch
x86_64
Linux
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 54746

People

(Reporter: amir.aharoni, Unassigned)

Details

User Agent: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:9.0a2) Gecko/20111021 Firefox/9.0a2
Build ID: 20111021043849

Steps to reproduce:

I tried to adjust fonts for different languages. I went to preferences -> content -> fonts. There's a list of languages: Arabic, Armenian, Bengali etc. It is sorted according to the language names in English.


Actual results:

When the language names are translated to other language, the alphabetical order is different, but the English order remains. So, in Hebrew Arabic is the first in the list, even though it's not the first according to the order of the Hebrew alphabet.


Expected results:

The languages should be sorted according to the current interface language collation order.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 54746
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.