Open Bug 54746 Opened 22 years ago Updated 6 years ago

Language encodings in font prefs dialog not sorted on non-English locales

Categories

(Firefox :: Preferences, defect, P3)

defect

Tracking

()

REOPENED

People

(Reporter: bobj, Unassigned)

References

Details

(Keywords: intl, l12y)

Language encodings are listed in a seemingly random order.
The order be alphabetical (and therefore change with localization).
As a special case, User-Defined should be last.
Accepting bug, for Future. Please nominate for RTM if desired.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Forgot build info in my previous comment: Build 2000092808 on US Win95.
cc'd rchen for L10N FYI.  If this bug gets fixed, then list will need
to be reordered for each localization.
Keywords: mozilla1.0
Changed QA contact to ylong@netscape.com.
Keywords: intl
QA Contact: teruko → ylong
The Language encodings still not looks been sorted on both 02-05-2001 Mtrunk and 
01-31-Mtest-ja build.
Reassign to jbetak.
Status: ASSIGNED → NEW
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
mark all future new as assigned after move from erik to ftang
Status: NEW → ASSIGNED
Depends on: 142864
-> to default owner (rather than ftang's WONTFIX)
Assignee: ftang → smontagu
Status: ASSIGNED → NEW
Target Milestone: Future → ---
It's not random, but listed in the order we list them in xul files. I'm not sure
alphabetic sorting is a good thing, though. How about this?

1. localizable top element : Japanese for ja, Western for en,fr, de, etc
2. Alphabetic listing of the rest (consider what collation rules to use...)
3. Unicode and User-defined








Keywords: mozilla1.0l12y
OS: Other → All
QA Contact: amyy → i18n
Duplicate of this bug: 696639
Assignee: smontagu → nobody
Component: Internationalization → Preferences
Product: Core → Firefox
QA Contact: i18n → preferences
Firefox sorts the available list of languages alphabetically by name.

http://hg.mozilla.org/mozilla-central/annotate/0a91da5f5eab/browser/components/preferences/languages.js#l103
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
This isn't fixed. The code linked in comment 12 sorts the list of languages for the "Choose your preferred language for displaying pages" dialog. This bug is about the list of languages for font preferences.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Jungshik Shin from comment #10)
> It's not random, but listed in the order we list them in xul files. I'm not
> sure
> alphabetic sorting is a good thing, though. How about this?
> 
> 1. localizable top element : Japanese for ja, Western for en,fr, de, etc
> 2. Alphabetic listing of the rest (consider what collation rules to use...)
> 3. Unicode and User-defined

Currently, we have Simplified Chinese and the two Traditional Chinese entries sorted (in the English localization) as if by "Chinese", so that all three appear together, and it'd be nice to maintain that, as well as the special-case for "Other Writing Systems" (formerly "Unicode") that goes at the end of the list. So any sorting we do for the localized names will need to be aware of these special cases somehow.
(In reply to Jonathan Kew (:jfkthame) from comment #14)
> Currently, we have Simplified Chinese and the two Traditional Chinese
> entries sorted (in the English localization) as if by "Chinese", so that all
> three appear together, and it'd be nice to maintain that

In the case of the Character Encoding submenu of the View menu, this is accomplished by labeling the entries "Chinese, Simplified" and "Chinese, Traditional" to make sure they have a prefix for sorting. (I'm not actually sure if they have a common prefix in the Simplified Chinese and Traditional Chinese localizations themselves, though!)
The list is sorted in en-US, as implied in the last few comments.
Summary: Language encodings in font prefs dialog not sorted → Language encodings in font prefs dialog not sorted on non-English locales
You need to log in before you can comment on or make changes to this bug.