Closed Bug 696732 Opened 9 years ago Closed 9 years ago

Blank tab is displayed if device orientation is changed while the page starts loading

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox8 unaffected, firefox9 affected, firefox10 affected, firefox11 affected, firefox12 fixed)

RESOLVED FIXED
Tracking Status
firefox8 --- unaffected
firefox9 --- affected
firefox10 --- affected
firefox11 --- affected
firefox12 --- fixed

People

(Reporter: xti, Assigned: mbrubeck)

References

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:
1. Open Fennec App
2. Browse to any webpage
3. When the page starts to load, change device orientation
4. Check if the page was loaded correctly

Expected result:
After step 5, the page is completely loaded without any issues.

Actual result:
After changing the phone orientation, tab remains blank, even if the page was loaded completely.

Notes:
- this issue is reproducible ~4-5 times out of 10.
- please see the following video: http://www.youtube.com/user/qaioana#p/a/u/0/HE5hsr3pfTM
Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20111023
Firefox/10.0a1 Fennec/10.0a1
Device: HTC Desire Z
OS: Android 2.3.3
Xti would you check to see if this is reproducible on Firefox 9 or 8?
Attached image screenshot
(In reply to Kevin Brosnan [:kbrosnan] from comment #2)
> Xti would you check to see if this is reproducible on Firefox 9 or 8?

I was able to reproduce this issue on the latest Aurora build, but I couldn't reproduce it on the latest Beta build..
tracking-fennec: --- → ?
This issue doesn't occur on:
Build ID : Mozilla /5.0 (Android;Linux armv7l;rv:9.0a1) Gecko/20110822 Firefox/9.0a1 Fennec/9.0a1 
http://hg.mozilla.org/mozilla-central/rev/f41df039db03

but it occurs on:
Build ID : Mozilla /5.0 (Android;Linux armv7l;rv:9.0a1) Gecko/20110823 Firefox/9.0a1 Fennec/9.0a1
http://hg.mozilla.org/mozilla-central/rev/7eb1a56eaaf1

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f41df039db03&tochange=7eb1a56eaaf1
bug 679923? dougt or blassey thoughts?
Yes, probably bug 679923.  Bug 703945 was a similar problem caused by the code that was first added in 679923.
Blocks: 679923
I believe this is fixed by bug 712517, which landed for Firefox 12.
Assignee: nobody → mbrubeck
Status: NEW → RESOLVED
Closed: 9 years ago
Depends on: 712517
Resolution: --- → FIXED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.