Last Comment Bug 712517 - Rotating device can display blank white screens
: Rotating device can display blank white screens
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 9
: ARM Android
: -- normal (vote)
: Firefox 12
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
Depends on:
Blocks: 679923 696732 712076
  Show dependency treegraph
 
Reported: 2011-12-20 17:33 PST by Tony Chung [:tchung]
Modified: 2012-01-19 04:39 PST (History)
17 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
aLogcat (58.00 KB, text/plain)
2011-12-21 01:05 PST, Andreea Pod
no flags Details
log (64.06 KB, text/plain)
2011-12-21 01:26 PST, Cristian Nicolae (:xti)
no flags Details
logcat (8.38 KB, text/plain)
2011-12-21 16:13 PST, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details
revert bug 679923 on Android (2.72 KB, patch)
2011-12-28 20:25 PST, Matt Brubeck (:mbrubeck)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
akeybl: approval‑mozilla‑release-
Details | Diff | Splinter Review
mbrubeck's build logcat (62.33 KB, text/plain)
2011-12-29 04:38 PST, Cristian Nicolae (:xti)
no flags Details

Description Tony Chung [:tchung] 2011-12-20 17:33:31 PST
Per https://bugzilla.mozilla.org/show_bug.cgi?id=703945#c15, opening a new bug to track this.

In summary, rotating the device on any content will cause a blank white screen to stick.  Firefox 9 build.

TLDR; 
Stuart is reporting on his motorola Atrix (android 2.3.4) that he's still seeing blank white pages after a series of rotations and zooms.   This is against Firefox 9 release.

Waverley, can you take a look and see if you can reproduce on your devices?

irclog for context:

[12:28am] dougt: tchung: stuarts says that beta is busted.  do you know anything about that?
[12:28am] tchung: dougt: no, we signed off on it prior to going to market.  what's the issue?
[12:29am] stuart: https://bugzilla.mozilla.org/show_bug.cgi?id=703945
[12:29am] stuart: i think
[12:29am] firebot: Bug 703945 nor, --, Firefox 11, mbrubeck, RESO FIXED, blank screen after rotate on every site
[12:29am] stuart: hm though that looks more recent
[12:30am] stuart: maybe not though
[12:30am] tchung: stuart: bug says firefox 11.  we haven't looked at nightly XUL builds too mmuch
[12:30am] stuart: tchung: this was Firefox Beta from market
[12:30am] stuart: which i assume will be Firefox real soon now?
[12:30am] stuart: which i assume has been tested..?
[12:31am] tchung: hmm, investigating.  yes, firefox 9 has already been shipped
[12:31am] tchung: we tested it pretty hard in beta, and did not see this bug afaik
[12:31am] • stuart tries real quick
[12:31am] stuart: mm yeah nice white page
[12:31am] tchung: what build?
[12:32am] stuart: 9.0 beta rev 541d40f07d00
[12:33am] tchung: stuart: what device u have
[12:33am] stuart: atrix
[12:33am] stuart: its really easy to reproduce
[12:33am] stuart: by just rotating a few times
[12:33am] dougt: stuart: i am using 8, and it works for me.
[12:33am] dougt: let me grab the beta too
[12:34am] stuart: trying to find exact str
[12:34am] stuart: but have seen it twice now on 3 sites in the last 3 minutes
[12:34am] tchung: stuart: what android version do u have?
[12:34am] stuart: 2.3.4 (stock)
[12:34am] tchung: ok
[12:35am] stuart: go load the caltrain timetable page
[12:35am] stuart: and zoom/rotate a bit
[12:35am] stuart: and it happens fairly often
[12:35am] tchung: ok
[12:35am] stuart: (i could see it on my fantasy football page too, but i was logged in)
[12:36am] stuart: its also not in one orientation or thhe other -- can happen in both
[12:36am] stuart: and you can still scroll and such
[12:36am] stuart: but its all white
[12:37am] tchung: i see it flicker white, but it resumes content for me
[12:37am] stuart: did 9 get pushed to market? i can test that build
[12:37am] tchung: I'm on a sgs2
[12:37am] tchung: stuart: its supposedly pushed yes, but market hasn't appeared yet
[12:37am] tchung: stuart: can u grab 9.0rc from ftp in the meantime?
[12:37am] stuart: its in market for me
[12:37am] stuart: updating
[12:37am] tchung: so is it still easy to white page if you start clean
[12:40am] stuart: i'm seeing a slightly different bug
[12:40am] stuart: where i hit back and the page contents didn't update
[12:40am] stuart: adn aren't repainting
[12:40am] stuart: in release
[12:40am] tchung: that too
[12:41am] stuart: in fact
[12:41am] stuart: none of the pages are fully repainting when i hit back
[12:41am] stuart: rotating fixes it
[12:41am] tchung: stuart: this affects other pages or just timetable site?
[12:42am] stuart: other pages too
[12:42am] stuart: rotating seems to lose page position
[12:42am] stuart: as well
[12:43am] stuart: yeah
[12:43am] stuart: just got release to white page
[12:43am] tchung: think thats known
[12:43am] tchung: so rotating a few times, you'll get white page to stick?
[12:43am] stuart: yes
[12:44am] stuart: in actual usage, it was happening enough that i stopped using it
[12:48am] stuart: tchung: can you not repro?
[12:48am] tchung: stuart: so is it still easy to white page if you start clean
[12:48am] tchung: not on 2 devices yet.  (galaxy nexus and SGS2)
[12:49am] stuart: tchung: wiping my profile
[12:50am] stuart: tchung: yeah can repro
[12:53am] tchung: stuart: can u comment in the bug?  wonder if bug is not really fixed.  we'll check other devices
Comment 1 Aaron Train [:aaronmt] 2011-12-20 18:05:48 PST
Unable to reproduce --

Tested via:

Samsung Galaxy Tab 10.1 (Android 3.1)
Mozilla/5.0 (Android; Linux armv7l; rv:9.0) Gecko/20111212 Firefox/9.0 Fennec/9.0

Samsung Galaxy Nexus (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:9.0) Gecko/20111212 Firefox/9.0 Fennec/9.0

Samsung Galaxy SII (Android 2.3.4)
Mozilla/5.0 (Android; Linux armv7l; rv:9.0) Gecko/20111212 Firefox/9.0 Fennec/9.0

HTC Nexus One (Android 2.3.6)
Mozilla/5.0 (Android; Linux armv7l; rv:9.0) Gecko/20111212 Firefox/9.0 Fennec/9.0
Comment 2 Andreea Pod 2011-12-21 01:05:53 PST
Created attachment 583423 [details]
aLogcat

Mozilla /5.0 (Android;Linux armv7l;rv:9.0) Gecko/20111216 Firefox/9.0 Fennec/9.0
Device: Lg Optimus 2X (Android 2.2)

I was able to reproduce this bug. I tried about seven or eight times, two times I got black screen and tow times white screen, following next steps:
- clear Firefox profile from android system settings
- open the application
- go to http://www.caltrain.com/schedules/weekdaytimetable.html
- wait for the page to load 
- turn the device from portrait to landscape

When turning it back in portrait the page displays as expected. 

I saved the attached log second time when I got black screen.
Comment 3 Cristian Nicolae (:xti) 2011-12-21 01:26:22 PST
Created attachment 583426 [details]
log
Comment 4 Cristian Nicolae (:xti) 2011-12-21 01:27:58 PST
Is this issue related to bug 696732? It seems that the same steps are performed and there is the same actual result.
Comment 5 Cristian Nicolae (:xti) 2011-12-21 01:34:42 PST
This issue is still reproducing on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0)Gecko/20111216
Firefox/9.0 Fennec/9.0
Device: Samsung Galaxy S
OS: Android 2.2
Comment 6 Catalin Suciu [:csuciu] 2011-12-21 01:50:10 PST
Unable to reproduce on: 
Samsung Galaxy S2 (Android 2.3.4), HTC Desire (Android 2.2), Samsung Nexus (Android 4.0.1), Samsung Nexus S (Android 2.3.6)
Mozilla /5.0 (Android;Linux armv7l;rv:9.0) Gecko/20111216 Firefox/9.0 Fennec/9.0
Comment 7 Matt Brubeck (:mbrubeck) 2011-12-21 10:13:33 PST
I believe Stuart reported that Firefox 8 was unaffected on his devices, and the bug first appeared in Firefox 9.  Can we get a narrower regression range?
Comment 8 Matt Brubeck (:mbrubeck) 2011-12-21 10:17:22 PST
I'm not sure if this is relevant, but the affected devices so far (Optimus 2X, Galaxy S2, and Atrix) are all dual-core (Tegra 2) phones running Android 2.x.
Comment 9 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-12-21 16:01:21 PST
I can reproduce this in Firefox 9, there the whole screen gets black (except the status bar of Android). I can also reproduce on trunk, there the page gets black, not the Fennec UI. Tested on the LG Optimus Black.
Comment 10 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-12-21 16:13:14 PST
Created attachment 583663 [details]
logcat

This is a logcat file of when I got a white screen in Firefox 9 on the LG Optimus black while rotating to landscape mode. The white screen bug is different from the black screen bug to me, because the xul UI is still visible for me (after panning) with that mode. In the black screen mode, nothing of Fennec is visible anymore.
Comment 11 Andreea Pod 2011-12-21 23:30:29 PST
The same thing as Martijn described above happens for me about the white and black screen.

I can't reproduce this all the time, so it would be impossible for me to find the regression window, maybe someone for who is 100% reproducible or if we could find some STR that lead to this every time I would try.
Comment 12 Cristian Nicolae (:xti) 2011-12-22 00:45:12 PST
(In reply to Matt Brubeck (:mbrubeck) from comment #7)
> I believe Stuart reported that Firefox 8 was unaffected on his devices, and
> the bug first appeared in Firefox 9.  Can we get a narrower regression range?

There is a regression range in bug 696732
Comment 13 Matt Brubeck (:mbrubeck) 2011-12-22 10:59:52 PST
Does this happen in XUL Fennec 11 (Aurora) or 12 (Nightly) builds?
Comment 14 Matt Brubeck (:mbrubeck) 2011-12-28 14:52:59 PST
This is probably a regression from bug 693930.  If we can't find a low-risk solution, we should back out bug 693930 and related patches that depend on it.

Since I can't reproduce this bug, my plan this week or next is to create some builds with extra logging that testers can run.  This might get me enough information to know exactly what the problem is.
Comment 15 Matt Brubeck (:mbrubeck) 2011-12-28 20:10:41 PST
(In reply to Matt Brubeck (:mbrubeck) from comment #14)
> This is probably a regression from bug 693930.  If we can't find a low-risk
> solution, we should back out bug 693930 and related patches that depend on
> it.

Wrong bug - I meant this is probably a regression from bug 679923.
Comment 16 Matt Brubeck (:mbrubeck) 2011-12-28 20:25:30 PST
Created attachment 584696 [details] [diff] [review]
revert bug 679923 on Android

This patch disables the code for bug 679923, on Android only.  (We can keep it enabled for Maemo/Meego, since the problems seems to be related to Android widget code sending notifications in unexpected ways.)  This should also fix bug 696732 and maybe bug 712076.

Bug 679923 reduced the memory footprint of background tabs in XUL Fennec.  Disabling the code will increase that footprint back to where it was in Firefox 8.

http://people.mozilla.com/~mbrubeck/fennec-712517.apk is a test build based on recent nightly code plus this patch.  Someone who can reproduce this bug, please test both my build and a XUL Nightly build from https://wiki.mozilla.org/Mobile/Platforms/Android#Tablet_Users and let me know whether the patch makes a difference.
Comment 17 Cristian Nicolae (:xti) 2011-12-29 04:35:26 PST
(In reply to Matt Brubeck (:mbrubeck) from comment #16)
> Created attachment 584696 [details] [diff] [review]
> revert bug 679923 on Android

> http://people.mozilla.com/~mbrubeck/fennec-712517.apk is a test build based
> on recent nightly code plus this patch.  Someone who can reproduce this bug,
> please test both my build and a XUL Nightly build from
> https://wiki.mozilla.org/Mobile/Platforms/Android#Tablet_Users and let me
> know whether the patch makes a difference.

I tried to reproduce this issue on your test build, but it didn't occur on HTC Desire Z (Android 2.3.3) and Samsung Galaxy S (Android 2.2). Instead, another issue has occurred once on Galaxy S: the screen turned to black except the Android Notification Bar. I hope that the attached log file will be useful.

Also this bug didn't occur for the XUL Nightly build from https://wiki.mozilla.org/Mobile/Platforms/Android#Tablet_Users. I tested it both on Samsung Galaxy S and Asus EEE Transformer (Android 3.2.1).
Comment 18 Cristian Nicolae (:xti) 2011-12-29 04:35:59 PST
This issue doesn't occur on:
Build ID : Mozilla /5.0 (Android;Linux armv7l;rv:9.0a1) Gecko/20110822 Firefox/9.0a1 Fennec/9.0a1 
http://hg.mozilla.org/mozilla-central/rev/f41df039db03

but it occurs on:
Build ID : Mozilla /5.0 (Android;Linux armv7l;rv:9.0a1) Gecko/20110823 Firefox/9.0a1 Fennec/9.0a1
http://hg.mozilla.org/mozilla-central/rev/7eb1a56eaaf1

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f41df039db03&tochange=7eb1a56eaaf1
Comment 19 Cristian Nicolae (:xti) 2011-12-29 04:38:42 PST
Created attachment 584732 [details]
mbrubeck's build logcat
Comment 20 Matt Brubeck (:mbrubeck) 2011-12-29 10:13:51 PST
(In reply to Matt Brubeck (:mbrubeck) from comment #16)
> Bug 679923 reduced the memory footprint of background tabs in XUL Fennec. 
> Disabling the code will increase that footprint back to where it was in
> Firefox 8.

A minor correction:  Bug 679923 actually reduced the memory footprint for the *foreground* tab, when the Fennec *app* is in the background.

(In reply to Cristian Nicolae (:xti) from comment #17)
> Also this bug didn't occur for the XUL Nightly build from
> https://wiki.mozilla.org/Mobile/Platforms/Android#Tablet_Users. I tested it
> both on Samsung Galaxy S and Asus EEE Transformer (Android 3.2.1).

Hmm, that means this bug was already fixed sometime between Firefox 9.0 and trunk (Firefox 12.0a1).  It would be interesting to find the "un-regression range" to see what changeset fixed the bug.  Could Cristian or someone else look into that?

This also means that my test build was not useful, since it was built on top of nightly (which did not have the bug in the first place).  I'll post a new test build based on Firefox 9 instead.

(In reply to Cristian Nicolae (:xti) from comment #18)
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=f41df039db03&tochange=7eb1a56eaaf1

This confirms that bug 679923 is the most likely cause.
Comment 21 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-12-29 11:12:22 PST
I'm afraid I'm having too much difficulty reproducing this issue on my LG Optimus Black device (using Firefox 9) to be able to find an "un-regression range". I'm appr. trying to reproduce this for the last 10 minutes or so, and I've only managed to reproduce it once (with the str from comment2).
Comment 22 Matt Brubeck (:mbrubeck) 2011-12-29 11:21:04 PST
Here's a new test build based on Firefox 9 plus the patch from this bug:
http://people.mozilla.com/~mbrubeck/fennec-712517-b.apk
Comment 23 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-12-29 12:01:51 PST
(In reply to Matt Brubeck (:mbrubeck) from comment #22)
> Here's a new test build based on Firefox 9 plus the patch from this bug:
> http://people.mozilla.com/~mbrubeck/fennec-712517-b.apk

I think this test build definitely will help with the problem. Here's why:
With the regular builds from Fennec 9, every time, after I've rotated the device, the web page will show white for a fraction of a second. With this test build, I don't see that happening at all.
So I think that 'fraction of a second showing up white after screen rotation', is an indication of this bug.

That being said, I'm not really able to reliably reproduce this bug at all, as I've said before, so I can't tell if the test build would fix it, for sure.
Comment 24 Aaron Train [:aaronmt] 2011-12-29 12:25:46 PST
Have we tried the devices on DeviceAnywhere?
Comment 25 Tony Chung [:tchung] 2011-12-29 12:28:38 PST
(In reply to Aaron Train [:aaronmt] from comment #24)
> Have we tried the devices on DeviceAnywhere?

i tried the Motorola Atrix on DA, and unfortunately it doesnt have the option to allow installing unknown APK sources.   Worth trying another tegra device though.
Comment 26 Tony Chung [:tchung] 2011-12-29 13:18:38 PST
Tried on a LG G2X with the try build, rotating on caltrain.com/timetable.  no luck reproducing with matt's try build.  ugh
Comment 27 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-29 14:26:45 PST
Comment on attachment 584696 [details] [diff] [review]
revert bug 679923 on Android

Seems like this isolates the problematic patch well enough for Android
Comment 28 Tony Chung [:tchung] 2011-12-29 15:23:02 PST
(In reply to Tony Chung [:tchung] from comment #26)
> Tried on a LG G2X with the try build, rotating on caltrain.com/timetable. 
> no luck reproducing with matt's try build.  ugh

Also unable to reproduce on the G2X using Firefox 9.0 from market.   I am no help today.
Comment 29 Cristian Nicolae (:xti) 2011-12-30 06:10:00 PST
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #23)
> (In reply to Matt Brubeck (:mbrubeck) from comment #22)
> > Here's a new test build based on Firefox 9 plus the patch from this bug:
> > http://people.mozilla.com/~mbrubeck/fennec-712517-b.apk
> 
> I think this test build definitely will help with the problem. Here's why:
> With the regular builds from Fennec 9, every time, after I've rotated the
> device, the web page will show white for a fraction of a second. With this
> test build, I don't see that happening at all.
> So I think that 'fraction of a second showing up white after screen
> rotation', is an indication of this bug.
> 
> That being said, I'm not really able to reliably reproduce this bug at all,
> as I've said before, so I can't tell if the test build would fix it, for
> sure.

I was able to reproduce that half of a second of a blank white screen on this test build, but nothing more, except one black screen as I mentioned in comment #17 (see attached screenshot). 

I tried to find an un-regression range, but here it is what I found so far:
- testing the Nightly build since 12/04/11 I was able to reproduce this issue
- for the build since 12/11/11, I was able to reproduce only that half of a second white screen
- for the build since 12/19/11, I was able to reproduce once the black screen mention above.

Imo, this patch has fixed the white screen issue.
Comment 30 Matt Brubeck (:mbrubeck) 2012-01-03 10:36:16 PST
Comment on attachment 584696 [details] [diff] [review]
revert bug 679923 on Android

Landed on inbound for Firefox 12:
https://hg.mozilla.org/integration/mozilla-inbound/rev/df86a9abc6fa

[Approval Request Comment]
Regression caused by (bug #): bug 679923 (landed in Firefox 9)

User impact if declined: Tabs frequently become blank on some devices, with no obvious recovery or workaround.  Also, other regressions from bug 679923 such as bug 712076 and bug 696732 which also cause intermittent blank screens.

Testing completed (on m-c, etc.): Some of the symptoms (including the ones from this particular bug) are already fixed in Firefox 11 and later by an unknown change and so they cannot be tested there.  (Difficulty in reproducing the bug on most devices has made it hard to find the exact range where it was fixed.)  Instead, QA tested a build of Firefox 9 with this patch applied.

I plan to land this patch on central, aurora, and beta, because some of the other regressions affect all three branches.  However, we aren't currently publishing XUL Fennec builds on the Aurora or Nightly channels, so we won't get any non-QA user testing until the patch hits Beta.

Risk to taking this patch (and alternatives if risky):

This patch is Android-only and low-risk; it just ifdefs out code that originally landed in Firefox 9.  The main downside of the patch is that it reverts a memory footprint improvement that affects Firefox on Android while running in the background.  The memory held for layers while Firefox is backgrounded will regress to the same level as Firefox 8.

As an alternative, we can do additional testing to find the real causes of the regressions, and develop patches targeted at the specific regressions, rather than reverting the change that caused them.  However, I don't think this is  both risk and high-effort, since I don't have access to a device where I can reproduce the bugs on demand, and we are already phasing out XUL Fennec on Android and have very few resources testing new code there.
Comment 31 Matt Brubeck (:mbrubeck) 2012-01-03 10:40:09 PST
Marking Firefox 11 as "affected" because it does not yet have the patch applied.  Firefox 11 is not affected by the original bug reported here, but it is still affected by dependent bugs 696732 and 712076.
Comment 32 Matt Brubeck (:mbrubeck) 2012-01-03 10:41:25 PST
Comment on attachment 584696 [details] [diff] [review]
revert bug 679923 on Android

Also requesting approval-mozilla-release.  This Android-only regression fix would be good to take *if* we decide we need a 9.0.2 release.
Comment 33 Marco Bonardo [::mak] 2012-01-04 04:45:57 PST
https://hg.mozilla.org/mozilla-central/rev/df86a9abc6fa
Comment 34 Alex Keybl [:akeybl] 2012-01-04 15:43:17 PST
Comment on attachment 584696 [details] [diff] [review]
revert bug 679923 on Android

[Triage Comment]
Approving for aurora/beta and leaving the release flag as ?, although we don't expect there to be a 9.0.2 at this time.
Comment 36 Aaron Train [:aaronmt] 2012-01-06 06:49:43 PST
[QA Triage - this will be in 10.0b4]
Comment 37 Alex Keybl [:akeybl] 2012-01-06 11:31:47 PST
Comment on attachment 584696 [details] [diff] [review]
revert bug 679923 on Android

[Triage Comment]
9.0.2 was discussed in yesterday's channel meeting. We have no issues that warrant chemspilling, so minusing for release.
Comment 38 Cristian Nicolae (:xti) 2012-01-12 02:02:26 PST
It seems that this issue is not reproducible anymore on the latest Beta build. 

Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:10.0)Gecko/20120111
Firefox/10.0 Fennec/10.0
Device: Samsung Galaxy S
OS: Android 2.2
Comment 39 Camelia Urian 2012-01-19 04:39:20 PST
Mozilla /5.0 (Android;Linux armv7l;rv:10.0) Gecko/20120118 Firefox/10.0 Fennec/10.0
Device: Lg Optimus 2X (Android 2.2)

Issue not reproducible on latest Beta 10.b5 build.
Marking bug as verified.

Note You need to log in before you can comment on or make changes to this bug.