Lightning not emailing invites for CalDAV calendar (communigatePro 5.4.2n)

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
7 years ago
4 years ago

People

(Reporter: kent, Assigned: a.nitschke)

Tracking

Lightning 1.0b7

Details

(Whiteboard: [CalDAV server: Communigate][calconnect25])

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Created an event and tried to invite attendees.  


Actual results:

Lightning is not emailing invites for CalDAV calendar.  We use CommunigatePro 5.4 IMAP server that has a CalDAV.  Used to work in prior versions.  


Expected results:

Should have mailed a meeting.ics file..
(Reporter)

Comment 1

7 years ago
Thunderbird version 7.01
Lightning version 1.0b7
CommunigatePro 5.4.2n
Severity: normal → critical
Is the 'send invitation' checkbox in the new event dialog enabled and checked? Is a valid email account assigned to the calendar? Do you see related error messages in Tools > Error Console when creating the invitation?
(Reporter)

Comment 3

7 years ago
The 'send invitation' is checked but greyed out.. Yes there are valid email accounts assigned to the calendar.  There are no errors reported in the Error Console.  If I click on Compose email to all Attendees, it brings up the Thunderbird Write window with all the Attendees listed as recipients, but it doesn't attach a meeting.ics file...
Or could be related to Bug 692571.

Comment 5

7 years ago
Kent, can you sniff the HTTP headers in the conversion from lightning with the calendar server?

I guess CumminigatePro has the calendar-schedule set in the DAV header.

Comment 6

7 years ago
Kent please update this issue.

Similar report bug #701334 ...
(Reporter)

Comment 7

7 years ago
I'm sorry Felix, I don't have time to debug this right now.
(Reporter)

Comment 8

7 years ago
This is becoming a critical issue for my company.  Without the ability to invite attendees to events, this program becomes unusable.  I will be forced to put everyone back on Outlook, which I dread.  It's taking me 4 years to get most people off, I'm afraid I won't be able to convince people to use it again if we migrate off.....

Comment 9

7 years ago
Hi Kent, you have not answered the questions above. Without these nobody will be able to look into this.

However, if this is critical for your company you might want to have somebody fix the issue, I am sure that your patch will be gladly included if it solves the problem.
(Reporter)

Comment 10

7 years ago
I believe you are correct about the related bugs..  It works with local calendars.  How do I turn on debugging for lightning?

Comment 11

7 years ago
https://wiki.mozilla.org/Calendar:QA_CalDAV_Support#Diagnosis_hints has small notes. Otherwise a trace generated with http://www.wireshark.org/ might help.
(Reporter)

Comment 12

7 years ago
This is the error I received...

Error: this.baseUri is null
Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/kent.ARTSWAY-MFG/AppData/Roaming/Thunderbird/Profiles/f7mdba2g.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js
Line: 193

Comment 13

7 years ago
For debugging a developer will need the whole traffic which is logged to the console in debug mode I think. 

Or you can get it by using wireshark.

I think the message you posted comes from the error console, doesn't it?
(Reporter)

Comment 14

7 years ago
Created attachment 578598 [details]
Log file of inviting an attendee using CalDAV

Here is the log file

Comment 15

7 years ago
Hm, I think there are several problems the one in comment #13 does not match to the attachment #578598 [details]. 

There seems to be a test installation at http://mobileoffice.biz/ however this is currently not reachable ... 

http://host.mobileoffice.biz/ gives access to the system, but I do not have any user ...
Summary: Lightning not emailing invites for CalDAV calendar (communigatePro 5.4) → Lightning not emailing invites for CalDAV calendar (communigatePro 5.4.2n)
(Reporter)

Comment 16

7 years ago
Felix,

Contact me directly and I will give you a test account on our server...

kent@artsway-mfg.com
(Reporter)

Updated

7 years ago
Severity: critical → blocker
Priority: -- → P1
(Reporter)

Comment 17

7 years ago
Still broken in version 1.2......
(Reporter)

Comment 18

7 years ago
Created attachment 593843 [details]
debug log file for version 1.2

Attached is the debug log file for version 1.2.  This version still doesn't invite attendees..

Comment 19

7 years ago
Hey,

I have the exact same issue. We are running DAVICALL | Thunderbird 11 | Lightning 13b3.

On local calenders invites works. On remote caldav calendars invite box is checked but greyed out and no invites are send.

How can I help?

Comment 20

7 years ago
Workaround is to create the event on the local calendar, then move it do the CalDAV calendar.  This results in an incorrect From: in the email invite, if the local calendar is associated with a different email address, but at least it gets the invite sent.

Thunderbird 11.0, Lightning 1.3, DAViCAL.
Severity: blocker → normal

Comment 21

6 years ago
i also use thunderbird 12.0.1, lightning 1.4 and DaviCal. So maybe it is a Problem between Lightning in its newe iterations and DaviCal? Should we contact DaviCal support also?

Comment 22

6 years ago
This change to davical configuration on my system allowed the invites to be emailed out.

http://wiki.davical.org/w/Common_Problems#Invitation_email_with_Lightning

Add the following line to your configuration <ip-or-canonical-name>-conf.php in /etc/davical 
$c->enable_auto_schedule = false;
(Reporter)

Comment 23

6 years ago
This is still a problem with the new thunderbird: 14.0  and lightning: 1.6.  Apparently no-one considers this a problem.  I guess they don't care about loosing several hundred people to outlook..  I can't believe we are the only ones using thunderbird/lightning/CommunigatePro..  I really don't want to have to move to Outlook/Exchange, the thought of it gives me nightmares....
Whiteboard: [CalDAV server: Communigate][calconnect25]
(Assignee)

Comment 24

6 years ago
I try to solve the bug.
Assignee: nobody → a.nitschke
see also bug 674959 for why this happens on davical and what it's expecting in terms of lightning's responsibility.

@kent: wouldn't hiring somebody to fix this for you be a lower cost option than switching?

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 26

5 years ago
Working for me with Thunderbird 17.0.7, Lightning 1.9.1 and Apple iCloud calendar connected as CalDAV https://p01-caldav.icloud.com/123456789/calendars/CALENDAR-ID-NUMBER/

Comment 27

5 years ago
I'm experiencing this bug under Debian Wheezy with Thunderbird 17.0.7 and Lightning 1.9.1 connected to DAViCal 1.1.1-1.

The fix suggested in comment 22 fixed the issue. Add this to the davical config:

$c->enable_auto_schedule = false;

Comment 28

5 years ago
HI,

I am trying to find this solution long time a go. Do you know how to enable this on Horde Email Groupware? Horde Groupware also use Caldav for client to connect calendar and I also got the same problem as describe above.

Thanks,
Sovannaroth
Priority: P1 → --

Comment 29

4 years ago
I can confirm that the bug is also still existent in the combination Thunderbird 24.5.0 running on Ubuntu, Lightning 2.6.5 and Horde 5.1.5/kronolith 4.1.4.
Please don't pile on with issues using different server configurations until its clear that this happens on most every server. It makes it hard to debug the original issue.

The baseUri issue sounds like bug 760827. Do you have this pref enabled?

I'd suggest everyone who has this issue and is using a different server config to create a new issue that can be handled separately. When doing so, enable calendar.debug.log and calendar.debug.log.verbose in the advanced config editor (Options > Advanced > General > Config Editor) and show us some logs about what is happening.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.