Last Comment Bug 696832 - Ux Designs for Menu
: Ux Designs for Menu
Status: VERIFIED FIXED
[birch] [Product Approved]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: Sriram Ramasubramanian [:sriram]
:
Mentors:
: 700723 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-24 12:13 PDT by Erin Lancaster [:elan]
Modified: 2012-01-09 15:36 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
mockups of menus on Gingerbread vs ICS (369.68 KB, image/jpeg)
2011-10-25 14:01 PDT, Ian Barlow (:ibarlow)
no flags Details
mockups of menus with items in the correct order (315.77 KB, image/jpeg)
2011-10-31 13:21 PDT, Ian Barlow (:ibarlow)
no flags Details
Graphic assets for menus for Froyo, Gingerbread, ICS, at a multitude of pixel densities (162.55 KB, application/zip)
2011-10-31 13:22 PDT, Ian Barlow (:ibarlow)
no flags Details
Patch: Option 1: Icons for menus based on the SDK version (141.96 KB, patch)
2011-11-07 17:39 PST, Sriram Ramasubramanian [:sriram]
mark.finkle: review-
Details | Diff | Review
List of directories in SDK 14 (26.63 KB, image/png)
2011-11-08 10:14 PST, Sriram Ramasubramanian [:sriram]
no flags Details
Patch: Icons for menus based on the SDK version (123.40 KB, patch)
2011-11-08 11:38 PST, Sriram Ramasubramanian [:sriram]
mark.finkle: review+
Details | Diff | Review

Description Erin Lancaster [:elan] 2011-10-24 12:13:13 PDT
Meta bug.
Comment 1 Ian Barlow (:ibarlow) 2011-10-25 14:01:29 PDT
Created attachment 569496 [details]
mockups of menus on Gingerbread vs ICS

More polished mocks and assets are on the way, but this should be enough to start with.
Comment 2 Ian Barlow (:ibarlow) 2011-10-31 13:21:30 PDT
Created attachment 570821 [details]
mockups of menus with items in the correct order

Please use the basic menu layouts, as per the attached mocks

Note some customization of the menu on ICS phones — is this possible to add icons into the menu, to help differentiate page actions from browser actions?

------------

Order of menu items:

Site actions (show icons)
* Refresh
* Forward (if applicable)
* Bookmark (or Remove)
* Share
* Find in Page
* Save as PDF
* Page Info

Browser Actions (no icons)
* Add-ons
* Preferences
* Downloads
Comment 3 Ian Barlow (:ibarlow) 2011-10-31 13:22:18 PDT
Created attachment 570822 [details]
Graphic assets for menus for Froyo, Gingerbread, ICS, at a multitude of pixel densities
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-31 14:22:18 PDT
Handing over to dev for impl
Comment 5 Sriram Ramasubramanian [:sriram] 2011-10-31 15:18:27 PDT
As per the documentation, http://developer.android.com/guide/topics/resources/providing-resources.html#AlternativeResources , 
we should have identifiers as 

drawable-ldpi-v8/
drawable-mdpi-v8/
..
..
drawable-xhdpi-v14/

Is this approach fine?
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-31 20:28:40 PDT
The approach is fine, but let's try to minimize the number of variations. For example, mdpi is the lowest resolution we currently support. Do we need to split based on SDK version? Just make sure we are only building what we actually need.
Comment 7 Sriram Ramasubramanian [:sriram] 2011-11-01 10:09:05 PDT
Usually people don't specify based on SDK versions. The froyo had a grey shadow, that makes it visible on black background. On white background, the shadow is barely visible. They started using the same for gingerbread, if I'm right.

So, usually the list is specified as
drawable-mdpi/
drawable-hdpi/
drawable-hdpi-large/
and so on.

Ian had given different icons for different Android versions. That scared me, and made me think that, "should we specify it based on the SDK version?"
I am not sure if we need to pack 10 different versions of the same icon. This is definitely going to bloat the APK size. We can probably have it in birch (or mozilla-central), and the rel-eng can create different APKs based on the android versions and post different APKs in the market.

The other catch here is that Gingerbread has versions v9 and v10. Honeycomb has v11, v12 and v13. This leaves as creating 2 copies for gingerbread and 3 copies for honeycomb alone.
Comment 8 Sriram Ramasubramanian [:sriram] 2011-11-01 10:09:55 PDT
In short, I feel, the icon resources between froyo and gingerbread can be shared (sorry Ian). This reduces us to lesser resources being shipped in more generic folders.
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-02 22:44:41 PDT
Surely there are Android guidelines for what menu images to package with an application and have it work on different versions of Android OS.
Comment 10 Sriram Ramasubramanian [:sriram] 2011-11-07 17:39:31 PST
Created attachment 572690 [details] [diff] [review]
Patch: Option 1: Icons for menus based on the SDK version

This option uses "vX" (like v8, v11), to identify the SDK version for the "drawables". The ldpi, mdpi and hdpi are specified for each of the SDK versions (8, 9 and 11). 

This guarantees that the icon we want is being picked. The extra advantage is that, if we want to cut down on the size of the apk based on the android version, in the market, drawable-*-v8 can alone be built for froyo, and so on.

http://developer.android.com/guide/practices/ui_guidelines/icon_design_tab.html - This article uses this kind of approach.

I would also like to try the other option of using drawable-small, drawable-large qualifiers. However I'm not sure if that can be as perfect as this.
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-07 21:02:54 PST
Comment on attachment 572690 [details] [diff] [review]
Patch: Option 1: Icons for menus based on the SDK version

A few comments:
* We don't support any ldpi devices. Remove them all.
* v11 is honeycomb and I don't think we support anything but xhdpi, right? Or are you using v11 as a fallback for ICS too?

r- to at least remove the ldpi files, unless you or Ian know why we should support it.
Comment 12 Sriram Ramasubramanian [:sriram] 2011-11-08 10:14:00 PST
Created attachment 572868 [details]
List of directories in SDK 14

I was looking at the list of directories in SDK v14. They have ldpi values in them. And yes, the ldpi, mdpi, and hdpi in V11 was for supporting ICS.
Comment 13 Madhava Enros [:madhava] 2011-11-08 10:54:51 PST
Is "quit" as a menu item prioritized for v1?

People seemed to ask for it a lot in the market before we had it, but it's possible that's because of our memory usage.
Comment 14 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-08 11:01:22 PST
*** Bug 700723 has been marked as a duplicate of this bug. ***
Comment 15 Sriram Ramasubramanian [:sriram] 2011-11-08 11:38:47 PST
Created attachment 572922 [details] [diff] [review]
Patch: Icons for menus based on the SDK version

This has the "ldpi" versions removed from the patch.
"Find in page" option has also been removed, however, the icons are left with the patch so that we don't have to search for them (rename them) and add them later.
Comment 16 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-08 14:00:15 PST
https://hg.mozilla.org/projects/birch/rev/35ccca93351e
Comment 17 Aaron Train [:aaronmt] 2011-11-09 07:24:19 PST
20111109040505
http://hg.mozilla.org/projects/birch/rev/edd8921d5bb8
Samsung Nexus S (Android 2.3.6)
Comment 18 Wesley Johnston (:wesj) 2011-11-10 10:33:49 PST
These patches were backed while investigating Talos failures.  Now that tests are green again, we will need to reland.
Comment 19 Brad Lassey [:blassey] (use needinfo?) 2011-11-11 09:00:12 PST
backout was backed out https://hg.mozilla.org/projects/birch/rev/6f925b45a547
Comment 20 Aaron Train [:aaronmt] 2011-11-14 06:45:00 PST
20111114041052
http://hg.mozilla.org/projects/birch/rev/859ecdfe0168
Samsung Galaxy SII (Android 2.3.4)

Note You need to log in before you can comment on or make changes to this bug.