Closed Bug 697382 Opened 9 years ago Closed 9 years ago

alert-service is not registered/launched on i386

Categories

(Firefox :: Shell Integration, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: stransky, Assigned: stransky)

References

()

Details

desktop-notification (e.g. "download finished") is not thrown on 32-bit linux system (Fedora 15). It affects firefox only (official mozilla binary (7.0.1), latest trunk, package shipped by Fedora). Thunderbird works as expected.

nsAlertsService::nsAlertsService() is not even called on i386, I'm still investigating it.
No longer depends on: 404738, 388743, 469880
Keywords: mobile
Assignee: nobody → stransky
Hm, the malfunction in download manager was caused by browser.download.manager.showAlertOnComplete pref settings, so alert service works as expected (although the examples from toolkit/components/alerts/test are broken).
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.