Last Comment Bug 697390 - Using switch-to-tab before Panorama moves new tabs around
: Using switch-to-tab before Panorama moves new tabs around
Status: RESOLVED FIXED
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: -- normal
: Firefox 10
Assigned To: Raymond Lee [:raymondlee]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-26 02:36 PDT by Tim Taubert [:ttaubert]
Modified: 2016-04-12 14:00 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1 (7.62 KB, patch)
2011-10-27 03:24 PDT, Raymond Lee [:raymondlee]
ttaubert: review+
Details | Diff | Review
Patch for checkin (7.66 KB, patch)
2011-10-27 09:04 PDT, Raymond Lee [:raymondlee]
no flags Details | Diff | Review

Description Tim Taubert [:ttaubert] 2011-10-26 02:36:37 PDT
STR:

1) Have at least two groups with at least one tab per group
2) Restart Firefox
3) Open a new tab
4) Use switch-to-tab to jump to another group's tab

Actual result:

The tab from (3) was moved to the group we just switched to.

Expected result:

The new tab should of course not move around.
Comment 1 Raymond Lee [:raymondlee] 2011-10-27 03:24:00 PDT
Created attachment 569922 [details] [diff] [review]
v1
Comment 2 Tim Taubert [:ttaubert] 2011-10-27 05:01:24 PDT
Comment on attachment 569922 [details] [diff] [review]
v1

Review of attachment 569922 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, nice solution!
Comment 3 Raymond Lee [:raymondlee] 2011-10-27 09:04:39 PDT
Created attachment 569995 [details] [diff] [review]
Patch for checkin

Pushed to try and waiting for results
https://tbpl.mozilla.org/?tree=Try&rev=bc4f4694ae7b
Comment 4 Raymond Lee [:raymondlee] 2011-10-27 23:03:01 PDT
(In reply to Raymond Lee [:raymondlee] from comment #3)
> Pushed to try and waiting for results
> https://tbpl.mozilla.org/?tree=Try&rev=bc4f4694ae7b

There is a leak on OS X debug.  Investigating
Comment 5 Raymond Lee [:raymondlee] 2011-10-29 21:37:48 PDT
(In reply to Raymond Lee [:raymondlee] from comment #4)
> (In reply to Raymond Lee [:raymondlee] from comment #3)
> > Pushed to try and waiting for results
> > https://tbpl.mozilla.org/?tree=Try&rev=bc4f4694ae7b
> 
> There is a leak on OS X debug.  Investigating

It turned out that it's caused by other patch.

The leak does't happen in this push.
https://tbpl.mozilla.org/?tree=Try&rev=58e8625d9c24
Comment 6 Tim Taubert [:ttaubert] 2011-10-30 03:04:51 PDT
https://hg.mozilla.org/integration/fx-team/rev/56c72e3c1f03
Comment 7 Tim Taubert [:ttaubert] 2011-10-31 03:17:07 PDT
https://hg.mozilla.org/mozilla-central/rev/56c72e3c1f03

Note You need to log in before you can comment on or make changes to this bug.