auto-width left float containing only nested right float is too wide

RESOLVED FIXED

Status

()

Core
Layout: Floats
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Hixie (not reading bugmail), Unassigned)

Tracking

(Blocks: 1 bug, {css1, testcase})

Trunk
css1, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reflow-refactor][Hixie-P3][CSS1-5.5.25][A2], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
According to the CSS working group (per the August 2000 F2F [1]) nested floats 
do not affect the formatting context of the ancestors of the float, and do not
get the outer float to shrink wrap about them. We do this correctly when the
outer float also has text in it ([2][3]), but when a float is directly contained
within another float, we mess up and shrink wrap the inner float.

See: http://www.hixie.ch/tests/adhoc/css/box/float/001.html

-- References --
[1] It's a little brief, but:
    http://lists.w3.org/Archives/Member/w3c-css-wg/2000JulSep/0119.html
[2] http://www.hixie.ch/tests/adhoc/css/box/float/002.html
[3] http://www.hixie.ch/tests/adhoc/css/box/float/003.html
(Reporter)

Comment 1

17 years ago
Nesting floats is not very common. Suggesting delaying until post-mozilla0.9.
Keywords: css1, mozilla1.0, testcase
QA Contact: petersen → ian
Summary: float containing only nested float doesn't get sized to nothing → float containing only nested float doesn't get sized to nothing [FLOAT]
This is actually a decision I'd like to revisit in the working group - I'd like
to see the outer floats shrink-wrap.

Comment 3

17 years ago
Accepting, and, due to low-impact, moving to future. Also, adding [FLOAT] to
summary...
Status: NEW → ASSIGNED
Priority: -- → P3
Summary: float containing only nested float doesn't get sized to nothing [FLOAT] → [FLOAT] float containing only nested float doesn't get sized to nothing [FLOAT]
Target Milestone: --- → Future
(Reporter)

Updated

16 years ago
Blocks: 78094
(Reporter)

Updated

16 years ago
Whiteboard: [Hixie-P5] WG?
Whiteboard: [Hixie-P5] WG? → [Hixie-P5][CSS1-5.5.25] WG?

Comment 4

15 years ago
Reconfirmed using FizzillaCFM/2002070913. The testcase doesn't appear as
described. Setting All/All.
OS: Windows 2000 → All
Hardware: PC → All
CSS2.1 isn't really any more clear on this issue than previous CSS versions....
What's the current state of the spec on this?
(Reporter)

Comment 6

14 years ago
I think the status is dbaron and I mildly disagree. I want to say that floats
are not affected by floats within them (hence my filing this bug); dbaron wants
to say that a root formatting context grows to fit all floats, including floats
(IIRC).

The WG should discuss this in the coming months.
OK.  Over to layout:floats; hixie, feel free to take this pending WG discussion....
Assignee: attinasi → float
Status: ASSIGNED → NEW
Component: Layout → Layout: Floats
Priority: P3 → --
(Reporter)

Comment 8

14 years ago
WG discussion has changed this bug slightly...
Severity: minor → normal
Summary: [FLOAT] float containing only nested float doesn't get sized to nothing [FLOAT] → left float containing only nested right float grows too big
Whiteboard: [Hixie-P5][CSS1-5.5.25] WG? → [Hixie-P3][CSS1-5.5.25]
You're right about what we should do, but the spec doesn't require it.  10.3.5
is intentionally vague.
Summary: left float containing only nested right float grows too big → auto-width left float containing only nested right float is too wide
(Reporter)

Comment 10

14 years ago
Yes, technically "shrink-to-fit" is not defined, but I'm _reasonably_ sure that 
there's no way what we do can count as "shrink-to-fit"...
(Reporter)

Comment 11

12 years ago
Also visible when there's a right float in an abs-pos block.
Whiteboard: [Hixie-P3][CSS1-5.5.25] → [Hixie-P3][CSS1-5.5.25][A2]
Target Milestone: Future → ---
Whiteboard: [Hixie-P3][CSS1-5.5.25][A2] → [reflow-refactor][Hixie-P3][CSS1-5.5.25][A2]
Blocks: 289480
No longer blocks: 289480
Blocks: 291126

Comment 12

12 years ago
Created attachment 189864 [details]
floated and absolutely positiond divs containing floats

My testcase shows that the bug is also present when a right-floated block
contains another right-floated block. So any block that is floated or absolutey
positioned and contains a right-floated block will be effected by this problem.


BTW, since fixing this bug would fix the second line of the Acid2 test,
shouldn't this be given more attention once Gecko 1.8 is branched?

(This is my first contribution to Bugzilla, so let me know if I did something
weid.)
According to dbaron this is fixed on his REFLOW branch.
Depends on: 300030

Updated

11 years ago
Flags: in-testsuite?
Fixed on trunk by reflow branch landing.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.