[Firefox Beta] Implement Firefox Beta Notes Page

RESOLVED FIXED in 1.0

Status

www.mozilla.org
General
P1
normal
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: grace, Assigned: jlongster)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

20.00 KB, application/octet-stream
Details
3.01 KB, text/plain
Details
(Reporter)

Description

7 years ago
same implementation as bug: 697519
design bug: 697630

1 page for desktop
1 page for mobile 

Live Date: Dec. 20th.
(Reporter)

Updated

7 years ago
Priority: -- → P2
Target Milestone: --- → 4.11
(Reporter)

Updated

7 years ago
Depends on: 695778
(Reporter)

Updated

7 years ago
No longer depends on: 695778
(Reporter)

Comment 1

7 years ago
we should try to get this by 4.10 the latest.
beta might be going on the 20th (instead of a few days after the 20th).
Target Milestone: 4.11 → 4.10
(Reporter)

Comment 2

7 years ago
we should try to get this by 4.10 the latest.
beta might be going on the 20th (instead of a few days after the 20th).

Comment 3

7 years ago
Grace - doesn't look like the design is ready yet. I'm moving this to 4.11.
Target Milestone: 4.10 → 4.11

Comment 4

7 years ago
The Beta PSD did, however, land in bug 697630. Just trying to make sure everybody's on the same page since bugzilla/email has been crazy for the past few days.
(Reporter)

Comment 5

7 years ago
hi steven, 

PSD can be found here: http://mozilla.tyflanagan.com/artwork/Beta/FFx_Beta_Desktop_Notes.psd.zip

we will need to update the logo watermark image, but the overall layout should be fine, so we can start building the page for now. 

I will update the bug as soon as we have the new logo watermark image. 

thanks!
(Reporter)

Updated

7 years ago
Priority: P2 → P1
(Reporter)

Comment 6

6 years ago
hi steven, 

just a reminder, this page will need to be built and ready to use for Tuesday, Dec. 20th. 

we are still waiting for a new logo watermark image, but i believe we can start building the page and we can update the wordmark later?

just a friendly reminder. please let me know if you need any additional info.
James, I've got a static HTML version of this implemented in trunk (r98967). The HTML is identical to the Aurora Release notes with some minor changes in the header. All of the other changes are in the CSS. Let me know if you need anything.
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: r=98967, b=trunk
Assignee: steven → jlong
Missed an image update in the first commit. Fixed in trunk.
Whiteboard: r=98967, b=trunk → r=98967,98976 b=trunk
(Assignee)

Updated

6 years ago
Blocks: 684089
(Assignee)

Comment 9

6 years ago
Alex, I need an updated db and I have a few questions about the queries I should be using. Let me know when I can get that.
James and I discussed this today. I've been caught up with Firefox 9, but will have this done by tonight so that James can work out the implementation tomorrow, in preparation for Wed/Thu rollout.
Created attachment 583052 [details]
12/19 relnotes

Here's the updated DB. Set aside some time tomorrow at 12PM PT to go over the strategy for implementing notes with James.
(Assignee)

Comment 12

6 years ago
committed the generated release notes in r99203 and  r99208
Whiteboard: r=98967,98976 b=trunk → r=98967,98976,99203,99208 b=trunk
(Reporter)

Comment 13

6 years ago
hi james, 

im not sure if this is the right bug or if we have a separate one for aurora, but we are missing the aurora notes for mobile: http://www-dev.allizom.org/en-US/firefox/11.0a1/auroranotes/ (if you toggle to the mobile page it gives us a 404)

if you can please help us implement the aurora 11 notes for mobile that would be great!

thanks!
(In reply to Grace Jimenez :grace from comment #13)
> hi james, 
> 
> im not sure if this is the right bug or if we have a separate one for
> aurora, but we are missing the aurora notes for mobile:
> http://www-dev.allizom.org/en-US/firefox/11.0a1/auroranotes/ (if you toggle
> to the mobile page it gives us a 404)
> 
> if you can please help us implement the aurora 11 notes for mobile that
> would be great!
> 
> thanks!

Please file another bug for aurora. This bug tracks the beta release notes only
(Assignee)

Comment 16

6 years ago
(In reply to raymond [:retornam] from comment #14)
> (In reply to Grace Jimenez :grace from comment #13)
> > hi james, 
> > 
> > im not sure if this is the right bug or if we have a separate one for
> > aurora, but we are missing the aurora notes for mobile:
> > http://www-dev.allizom.org/en-US/firefox/11.0a1/auroranotes/ (if you toggle
> > to the mobile page it gives us a 404)
> > 
> > if you can please help us implement the aurora 11 notes for mobile that
> > would be great!
> > 
> > thanks!
> 
> Please file another bug for aurora. This bug tracks the beta release notes
> only

I can fix it here since it's so closely related to this. It should be fixed now.

Note the date on the new Aurora pages. Alex, it seems to be hooking into a later release on 1-31-2012. Can you check the database? I queried it with the version 11.0. I can manually change the date but I want to make sure it's querying the right product.
(Assignee)

Updated

6 years ago
Whiteboard: r=98967,98976,99203,99208 b=trunk → r=98967,98976,99203,99208,99219 b=trunk
(Reporter)

Comment 17

6 years ago
hi alex, 

do we want to add a short blurb on about native ui and link to the blog post? at the very top of the aurora mobile page: http://www-dev.allizom.org/en-US/mobile/11.0a1/auroranotes/?
(Reporter)

Comment 18

6 years ago
hi james, 

i also noticed that we need to update the image logo. 
the background image/logo we should use should be similar to this one: http://mozilla.tyflanagan.com/artwork/Beta/FFx_Beta_Desktop_wFinalBG.zip (ie. http://www-dev.allizom.org/en-US/firefox/beta/)

Lastly, i dont think all the new beta pages are live for. 
so the download link on the side of the page (both in desktop and mobile) should link here for now: http://www.mozilla.org/en-US/firefox/channel/ until we have all the new beta pages live. 

thanks!
(Assignee)

Comment 19

6 years ago
Ok, I changed the download link.

Not sure about the background image. Alex seemed to confirm that it was the correct one. Alex, can you chime in?
Whiteboard: r=98967,98976,99203,99208,99219 b=trunk → r=98967,98976,99203,99208,99219,99262 b=trunk
(Reporter)

Comment 20

6 years ago
yeah... this was the original design proposed, but it wasnt approved by the creative team and will need to update the image like what we have here; http://www.mozilla.org/en-US/firefox/beta/

Updated

6 years ago
Target Milestone: 4.11 → 4.12

Comment 21

6 years ago
Grace - What's the live date for this?
(In reply to Grace Jimenez :grace from comment #17)
> hi alex, 
> 
> do we want to add a short blurb on about native ui and link to the blog
> post? at the very top of the aurora mobile page:
> http://www-dev.allizom.org/en-US/mobile/11.0a1/auroranotes/?

I'll make sure to add this - do you have a link to the blog post?
(In reply to Grace Jimenez :grace from comment #20)
> yeah... this was the original design proposed, but it wasnt approved by the
> creative team and will need to update the image like what we have here;
> http://www.mozilla.org/en-US/firefox/beta/

I wasn't involved with the creative process, so Grace has the latest.
(In reply to James Long (:jlongster) from comment #16)
> Note the date on the new Aurora pages. Alex, it seems to be hooking into a
> later release on 1-31-2012. Can you check the database? I queried it with
> the version 11.0. I can manually change the date but I want to make sure
> it's querying the right product.

I'll make sure to look at this asap.
(Reporter)

Comment 25

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #23)
> (In reply to Grace Jimenez :grace from comment #20)
> > yeah... this was the original design proposed, but it wasnt approved by the
> > creative team and will need to update the image like what we have here;
> > http://www.mozilla.org/en-US/firefox/beta/
> 
> I wasn't involved with the creative process, so Grace has the latest.

http://blog.mozilla.com/futurereleases/2011/12/22/firefoxaurora11
(Assignee)

Comment 26

6 years ago
Ok, changed the background image in r99289
(Assignee)

Updated

6 years ago
Whiteboard: r=98967,98976,99203,99208,99219,99262 b=trunk → r=98967,98976,99203,99208,99219,99262,99289 b=trunk
(In reply to Laura Forrest from comment #21)
> Grace - What's the live date for this?

The live date is likely to be tomorrow late morning/early afternoon - I can do the push though, as I'm still going to be making final changes.
So I worked on this a good bit last night. Here's what's new:

* I've updated the notes and other info in the DB
* I've updated run.py to again take a channel_name since we will actually want to re-generate old notes. This will allow us to link to the release notes that first resolve a known issue from previous releases.
* I added the product_text and release_text from the DB to the top of the notes
* I fixed the release date issues by removing test data from the DB
* I fixed an issue where the query for known issues was also incorrectly picking up fixed issues

Some issues I ran into:
* Looks like the aurora notes are currently up at http://www-dev.allizom.org/en-US/firefox/11.0a1/auroranotes/ instead of http://www-dev.allizom.org/en-US/firefox/11.0a2/auroranotes/
* It didn't look like the beta template on github was up to date
* I think the developer tag needs to be added to the aurora template (currently looks un-styled)
* The resolved issue tag should link to the first notes in which the issue is fixed (not a blocker, and I can file a separate bug if needbe)
* We should probably have run.py automatically run for all releases in the Releases table (also not a blocker to posting, and I can file separately)


The patch for the github repository and the DB are attached. I can't currently do the push, since I'm unable to create the beta notes from the template in the repo.
Created attachment 583789 [details]
12/22 updated relnotes DB
Attachment #583052 - Attachment is obsolete: true
Created attachment 583790 [details]
12/22 github patch
One other issue - the template appears to be creating desktop/mobile links to http://www-dev.allizom.org/firefox/11/auroranotes/ and http://www-dev.allizom.org/mobile/11/auroranotes/ instead of the 11.0a1 (well actually 11.0a2) links.
(Assignee)

Comment 32

6 years ago
Fixed comment 31 in r99318 and committed new generated files.
Whiteboard: r=98967,98976,99203,99208,99219,99262,99289 b=trunk → r=98967,98976,99203,99208,99219,99262,99289,99318 b=trunk
(Assignee)

Comment 33

6 years ago
fixed the developer tag in aurora notes
Whiteboard: r=98967,98976,99203,99208,99219,99262,99289,99318 b=trunk → r=98967,98976,99203,99208,99219,99262,99289,99318,99322 b=trunk
It's difficult to understand what the Resolved tag in the Known Issues means... In my understanding, the issue has been fixed in Nightly or Aurora but not in Beta. Anyway it's confusing to people.

Updated

6 years ago
Target Milestone: 4.12 → 1.0

Comment 35

6 years ago
James - Is this bug resolved? If not, what are next steps?
(Reporter)

Comment 36

6 years ago
hi laura and james, 

this looks good. should be good on our end. 
can we just update the download link (on the right side of the page) to http://www.mozilla.org/en-US/firefox/beta/ (instead of the current: http://www.mozilla.org/en-US/firefox/channel/ it's linking to?)

Thanks!
(Assignee)

Comment 37

6 years ago
This is mostly waiting on Grace and Alex to sign off on this and to roll it live. Grace, I'll make that tweak and wait for Alex to tell me to push it live (if someone hasn't already)
(Reporter)

Comment 38

6 years ago
hi james. 

this is already live. 
please make the tweak and it should be ready to close.

thanks!
(Assignee)

Comment 39

6 years ago
Looks like Christian rolled this live. Please open other bugs if there's any other tweaks for this.

Pushed tweak in comment 38 in r99570
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Whiteboard: r=98967,98976,99203,99208,99219,99262,99289,99318,99322 b=trunk

Updated

6 years ago
Blocks: 715321
(In reply to Kohei Yoshino from comment #34)
> It's difficult to understand what the Resolved tag in the Known Issues
> means... In my understanding, the issue has been fixed in Nightly or Aurora
> but not in Beta. Anyway it's confusing to people.

FYI this will be fixed in bug 715321

(In reply to Alex Keybl [:akeybl] from comment #1)
> A few changes to the implementation that I'd like to make before pushing the
> GA release notes
> 
> * The resolved issue tag under Known Issues should link to the latest
> channel notes from the version of Firefox in which the issue is fixed, with
> a tag of "RESOLVED in vXY" (RESOLVED in v11)
(In reply to Alex Keybl [:akeybl] from comment #40)
> FYI this will be fixed in bug 715321

:)

Updated

6 years ago
Blocks: 721102
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.