WebGL Conformance fails on 'framebuffer-object-attachment'

RESOLVED FIXED in mozilla10

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jgilbert, Assigned: jgilbert)

Tracking

unspecified
mozilla10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

6 years ago
We currently fail a number of times in the 'framebuffer-object-attachment' test. These fails appear to be caused by readPixels not properly generating an INVALID_FRAMEBUFFER_OPERATION when needed. It looks like this is because the optimization to skip reading when the width or height is 0 kicks in before we test for all error conditions.
(Assignee)

Updated

6 years ago
Depends on: 697168
(Assignee)

Comment 1

6 years ago
Created attachment 570022 [details] [diff] [review]
Fix WebGL conf. errors in 'framebuffer-object-attachment'

Test should now pass cleanly on all platforms.
Attachment #570022 - Flags: review?(bjacob)
(Assignee)

Comment 2

6 years ago
Created attachment 570032 [details] [diff] [review]
Fix WebGL conf. errors in 'framebuffer-object-attachment'

Unbitrot.
Attachment #570022 - Attachment is obsolete: true
Attachment #570022 - Flags: review?(bjacob)
Attachment #570032 - Flags: review?(bjacob)
Attachment #570032 - Flags: review?(bjacob) → review+
(Assignee)

Comment 3

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9a1f23ae9c36
Whiteboard: [inbound]
Target Milestone: --- → mozilla10
(Assignee)

Comment 4

6 years ago
Removed [inbound] from whiteboard as per https://wiki.mozilla.org/Tree_Rules/Inbound
Whiteboard: [inbound]
https://hg.mozilla.org/mozilla-central/rev/9a1f23ae9c36
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.