Last Comment Bug 697753 - WebGL Conformance fails on 'framebuffer-object-attachment'
: WebGL Conformance fails on 'framebuffer-object-attachment'
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Jeff Gilbert [:jgilbert]
:
Mentors:
Depends on: 697168
Blocks: webgl-conformance
  Show dependency treegraph
 
Reported: 2011-10-27 10:33 PDT by Jeff Gilbert [:jgilbert]
Modified: 2011-11-01 07:40 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix WebGL conf. errors in 'framebuffer-object-attachment' (4.62 KB, patch)
2011-10-27 10:39 PDT, Jeff Gilbert [:jgilbert]
no flags Details | Diff | Review
Fix WebGL conf. errors in 'framebuffer-object-attachment' (4.69 KB, patch)
2011-10-27 10:58 PDT, Jeff Gilbert [:jgilbert]
jacob.benoit.1: review+
Details | Diff | Review

Description Jeff Gilbert [:jgilbert] 2011-10-27 10:33:13 PDT
We currently fail a number of times in the 'framebuffer-object-attachment' test. These fails appear to be caused by readPixels not properly generating an INVALID_FRAMEBUFFER_OPERATION when needed. It looks like this is because the optimization to skip reading when the width or height is 0 kicks in before we test for all error conditions.
Comment 1 Jeff Gilbert [:jgilbert] 2011-10-27 10:39:15 PDT
Created attachment 570022 [details] [diff] [review]
Fix WebGL conf. errors in 'framebuffer-object-attachment'

Test should now pass cleanly on all platforms.
Comment 2 Jeff Gilbert [:jgilbert] 2011-10-27 10:58:49 PDT
Created attachment 570032 [details] [diff] [review]
Fix WebGL conf. errors in 'framebuffer-object-attachment'

Unbitrot.
Comment 4 Jeff Gilbert [:jgilbert] 2011-10-31 17:18:54 PDT
Removed [inbound] from whiteboard as per https://wiki.mozilla.org/Tree_Rules/Inbound
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-11-01 07:40:21 PDT
https://hg.mozilla.org/mozilla-central/rev/9a1f23ae9c36

Note You need to log in before you can comment on or make changes to this bug.