Last Comment Bug 697168 - ReadPixels, TexImage2D, and TexSubImage2D incorrectly accept untyped array buffers
: ReadPixels, TexImage2D, and TexSubImage2D incorrectly accept untyped array bu...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Jeff Gilbert [:jgilbert]
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks: webgl-conformance 697560 697753
  Show dependency treegraph
 
Reported: 2011-10-25 10:30 PDT by Jeff Gilbert [:jgilbert]
Modified: 2011-11-01 07:39 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove non-spec ArrayBuffer overloads for readPixels, texImage2D, and texSubImage2D (12.55 KB, patch)
2011-10-26 14:04 PDT, Jeff Gilbert [:jgilbert]
no flags Details | Diff | Splinter Review
Remove non-spec ArrayBuffer overloads for readPixels, texImage2D, and texSubImage2D (12.56 KB, patch)
2011-10-27 10:55 PDT, Jeff Gilbert [:jgilbert]
jacob.benoit.1: review+
Details | Diff | Splinter Review

Description Jeff Gilbert [:jgilbert] 2011-10-25 10:30:25 PDT
The WebGL spec requires that readPixels only takes typed arrays, not untyped array buffers.
Comment 1 Jeff Gilbert [:jgilbert] 2011-10-26 14:04:36 PDT
Created attachment 569783 [details] [diff] [review]
Remove non-spec ArrayBuffer overloads for readPixels, texImage2D, and texSubImage2D
Comment 2 Jeff Gilbert [:jgilbert] 2011-10-26 14:06:19 PDT
ReadPixels should also no longer need a dummy IDL stub, since there's only one valid set of arguments. I have had trouble actually removing the stub, but the functionality is the same just leaving it in.
Comment 3 Jeff Gilbert [:jgilbert] 2011-10-26 14:43:51 PDT
Matching try: https://tbpl.mozilla.org/?tree=Try&rev=997e3381d771
Comment 4 Jeff Gilbert [:jgilbert] 2011-10-27 10:55:59 PDT
Created attachment 570029 [details] [diff] [review]
Remove non-spec ArrayBuffer overloads for readPixels, texImage2D, and texSubImage2D

Unbitrotted.
Comment 6 Jeff Gilbert [:jgilbert] 2011-10-31 17:17:57 PDT
Removed [inbound] from whiteboard as per https://wiki.mozilla.org/Tree_Rules/Inbound
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-11-01 07:39:31 PDT
https://hg.mozilla.org/mozilla-central/rev/2cd25d4a839b

Note You need to log in before you can comment on or make changes to this bug.